Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 451824 - sci-chemistry/vmd-1.9.1-r2 with tcl/tk-8.6 break g(r) analysis module
Summary: sci-chemistry/vmd-1.9.1-r2 with tcl/tk-8.6 break g(r) analysis module
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Alexey Shvetsov
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tcltk-8.6
  Show dependency tree
 
Reported: 2013-01-13 17:25 UTC by Benj FitzPatrick
Modified: 2013-03-01 08:23 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Benj FitzPatrick 2013-01-13 17:25:44 UTC
The radial pair distribution function module (under extensions -> analysis) is broken with the shift to 1.9.1-r2. None of the boxes appear correctly and there is no text, making it completely unusable.

Reproducible: Always
Comment 1 Benj FitzPatrick 2013-01-14 16:50:16 UTC
Also in this list (only from the analysis option) is the IR Spectral Density Calculator.


Heat mapper also has issues when closing.
----------------------------------------------
invalid command name "::HeatMapper::Plot1::ReleaseAll"
invalid command name "::HeatMapper::Plot1::ReleaseAll"
    while executing
"[namespace current]::ReleaseAll"
    (procedure "::HeatMapper::Plot1::quit" line 5)
    invoked from within
"::HeatMapper::Plot1::quit"
    (command for "WM_DELETE_WINDOW" window manager protocol)
Comment 2 Justin Lecher gentoo-dev 2013-01-16 20:41:59 UTC
The readme says

 o Updated VMD to support Tcl 8.6 API changes.

could you please report this to upstream?
Comment 3 Benj FitzPatrick 2013-01-17 20:47:54 UTC
I posted this problem on the mailing list and will add any updates to this report.
Comment 4 Justin Lecher gentoo-dev 2013-01-17 20:52:47 UTC
thanks.
Comment 5 Benj FitzPatrick 2013-02-28 16:11:25 UTC
I received the below reply from one of the VMD devs, and it appears that 1.9.2 will be the first to fully suppork tcl/tk 8.6, and 1.9.1-r2 should still use 8.5.x.

...
The dependency for VMD 1.9.1 should indeed be Tcl/Tk 8.5.x, so
please feed that back to the Gentoo folks.

I should have 8.6.x sorted out so we're good with the VMD 1.9.2 release,
so it should be okay to point at Tcl/Tk 8.6.0 when we release it.

The Gentoo guys may have tested against a beta version of Tcl/Tk 8.6.
Some things changed in the final official 8.6.0 release since the last
beta I had tested, and so although I have been using betas for 8.6 for
some time, VMD 1.9.1 predates the final 8.6.0 release and therefore
there were a few loose ends I already had to fix in 1.9.2 in addition
to the one you pointed out.
Comment 6 Justin Lecher gentoo-dev 2013-03-01 08:23:47 UTC
+  01 Mar 2013; Justin Lecher <jlec@gentoo.org> vmd-1.9.1.ebuild,
+  vmd-1.9.1-r1.ebuild, vmd-1.9.1-r2.ebuild:
+  Fix tcl/tk API to version 8.5, #451824; Upstream says it will be fixed in
+  version 1.9.2
+