Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 451668 - media-sound/lash-0.5.4-r1 with sys-devel/gcc-4.7.2 - lash.c:203:19: error: storage size of ‘max_fds’ isn’t known
Summary: media-sound/lash-0.5.4-r1 with sys-devel/gcc-4.7.2 - lash.c:203:19: error: st...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Professional Audio Applications Maintainers
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks: gcc-4.7
  Show dependency tree
 
Reported: 2013-01-13 11:28 UTC by David Kredba
Modified: 2013-02-25 08:03 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Kredba 2013-01-13 11:28:50 UTC
-march=native -c -o liblash_la-comm_event.lo `test -f 'comm_event.c' || echo './'`comm_event.c
libtool: compile:  x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I.. -I.. -DLASH_BUILD -DHAVE_LASH -O2 -pipe -march=native -c client.c  -fPIC -DPIC -o .libs/liblash_la-client.o
lash.c: In function ‘lash_init’:
lash.c:203:19: error: storage size of ‘max_fds’ isn’t known
lash.c:204:5: error: unknown type name ‘rlim_t’
lash.c:206:15: error: ‘RLIMIT_NOFILE’ undeclared (first use in this function)
lash.c:206:15: note: each undeclared identifier is reported only once for each function it appears in
make[2]: *** [liblash_la-lash.lo] Error 1
make[2]: *** Waiting for unfinished jobs....
libtool: compile:  x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I.. -I.. -DLASH_BUILD -DHAVE_LASH -O2 -pipe -march=native -c comm_event.c  -fPIC -DPIC -o .libs/liblash_la-comm_event.o
make[2]: Leaving directory `/var/tmp/portage/media-sound/lash-0.5.4-r1/work/lash-0.5.4/liblash'

Reproducible: Always




Google found patch at http://permalink.gmane.org/gmane.linux.redhat.fedora.extras.cvs/822346,
to include #include <sys/resource.h> between existing #include <pthread.h> and #include <sys/types.h>.

It works for me.

Could you kindly please apply it?

Thank you in advance.
Comment 1 Nate Edel 2013-02-03 22:16:12 UTC
I've seen the same bug and have applied the same fix to my /usr/local/portage, would appreciate the addition up-stream.  Looks like it should be safe/harmless on older instances?
Comment 2 Samuli Suominen gentoo-dev 2013-02-25 08:03:52 UTC
fix in portage