Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 451510 - net-misc/networkmanager-0.9.4.0-r6 does not pass hostname to DHCP server
Summary: net-misc/networkmanager-0.9.4.0-r6 does not pass hostname to DHCP server
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-12 09:45 UTC by Erik Quaeghebeur
Modified: 2013-12-08 19:17 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Erik Quaeghebeur 2013-01-12 09:45:45 UTC
I have a (wifi) router (adsl modem). I connect with two computers, one a desktop, without NetworkManager, another a laptop, with NetworkManager 0.9.4.0-r6. For both, the hostname is set in /etc/conf.d/hostname, both have stock /etc/dhcpcd.conf and /etc/hosts files (in which the hostname does not appear). 

The router gets the hostname of the desktop, but not the one of the laptop.

Reproducible: Always

Actual Results:  
did not pass the hostname to the router 

Expected Results:  
pass the hostname to the router

The router log tells me (first line is desktop, second is laptop):

12.01.13 10:09:39 WLAN station registered. Name: <desktop hostname>, IP address: 192.168.178.32, MAC address: <snipped>, throughput: 54 MBit/s.

12.01.13 09:58:03 WLAN station registered. Name: -, IP address: 192.168.178.35, MAC address: <snipped>, throughput: 54 MBit/s.

I tried modifying /etc/dhcpcd.conf (adding the hostname or commenting the disabling of hostname-lookup) and /etc/NetworkManager/NetworkManager.conf (adding a hostname line to a new [keyfile] section), both suggestions I found in the forums, but to no avail.

I'd prefer a setup where routers can override hostnames if they wish, as the laptop is also used in corporate networks where this is sometimes required.

N.B.: My android phone also does not pass its hostname (but I don't it to, I don't think I even set its hostname).
Comment 1 Pavel Šimerda (pavlix) 2013-04-02 07:11:09 UTC
(In reply to comment #0)
> I have a (wifi) router (adsl modem). I connect with two computers, one a
> desktop, without NetworkManager, another a laptop, with NetworkManager
> 0.9.4.0-r6. For both, the hostname is set in /etc/conf.d/hostname, both have
> stock /etc/dhcpcd.conf and /etc/hosts files (in which the hostname does not
> appear). 

I'm using NetworkManager git master or 0.9.8 (hard masked in gentoo) but should be roughly the same with at least 0.9.6. NetworkManager developers don't use dhcpcd with NetworkManager. I advise anyone to use dhclient instead as it's much better tested or maintain dhcpcd support in NetworkManager himself.

With recent NetworkManager and dhclient, this doesn't happen to me.

> I tried modifying /etc/dhcpcd.conf (adding the hostname or commenting the
> disabling of hostname-lookup)

I don't even know whether /etc/dhcpcd.conf is honored or not when running from NetworkManager.

> and /etc/NetworkManager/NetworkManager.conf
> (adding a hostname line to a new [keyfile] section), both suggestions I
> found in the forums, but to no avail.

You can always use the upstream bugzilla. Link to the ebuild source online so that they can check that the problem is not in gentoo patches. But collaboration between Gentoo and NM upstream works pretty well.

> I'd prefer a setup where routers can override hostnames if they wish, as the
> laptop is also used in corporate networks where this is sometimes required.

I don't remember exactly how this is done. Posting to NetworkManager mailing list should get you a rather quick reply.

> N.B.: My android phone also does not pass its hostname (but I don't it to, I
> don't think I even set its hostname).
Comment 2 Pacho Ramos gentoo-dev 2013-06-16 12:05:34 UTC
What is the status of this with 0.9.8.2? Does it still fail with dhcpcd?
Comment 3 Erik Quaeghebeur 2013-06-16 13:01:48 UTC
(In reply to Pacho Ramos from comment #2)
> What is the status of this with 0.9.8.2? Does it still fail with dhcpcd?

I'm on 0.9.6.2, as 0.9.8.2 is not stable yet (masked even). On 0.9.6.2 the problem persists.

Do you wish me to test 0.9.8.2? (What are the incantations to backup my current NM, so that I cant revert without a network if 0.9.8.2 gives me problems?)
Comment 4 Pacho Ramos gentoo-dev 2013-06-16 13:41:08 UTC
I unmasked it some hours ago, you can of course backup your config files if you want (I didn't had any problems updating though :/)
Comment 5 Pacho Ramos gentoo-dev 2013-07-27 11:33:42 UTC
any updates with latest version?
Comment 6 Erik Quaeghebeur 2013-07-27 14:34:52 UTC
(In reply to Pacho Ramos from comment #5)
> any updates with latest version?

Sorry, I currently do not have the time to test, but it is on my todo list. I'll have a bit more time towards the end of August.
Comment 7 Erik Quaeghebeur 2013-12-08 16:18:37 UTC
(In reply to Pacho Ramos from comment #5)
> any updates with latest version?

This problem is still present with networkmanager-0.9.8.8.
Comment 8 Pacho Ramos gentoo-dev 2013-12-08 17:08:52 UTC
Can you report this to upstream then?
-> bugzilla.gnome.org
Comment 9 Erik Quaeghebeur 2013-12-08 19:17:13 UTC
(In reply to Pacho Ramos from comment #8)
> Can you report this to upstream then?
> -> bugzilla.gnome.org

https://bugzilla.gnome.org/show_bug.cgi?id=720077