Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 451380 - dev-lang/php-5.4.10 USE=phar - /bin/sh: line 1: 26317 Errore di segmentazione / / / make: *** [ext/phar/phar.php] Errore 139
Summary: dev-lang/php-5.4.10 USE=phar - /bin/sh: line 1: 26317 Errore di segmentazione...
Status: RESOLVED DUPLICATE of bug 449386
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: PHP Bugs
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-11 10:09 UTC by Michelangelo Scopelliti
Modified: 2013-01-11 17:21 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
complete build log (php-5.4.10:20130111-095817.log.gz,69.98 KB, application/x-gzip)
2013-01-11 10:10 UTC, Michelangelo Scopelliti
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michelangelo Scopelliti 2013-01-11 10:09:16 UTC
USE=phar causes a segfault during the generation of phar.php.
The problem was present for php-5.4.9. I've rebuilt the whole system, and there was no change.

Reproducible: Always

Steps to Reproduce:
1. emerge php
Actual Results:  
segfault.
from dmesg:traps: php[26317] general protection ip:7721c9 sp:7fffe7016f70 error:0 in php[400000+96a000]





Portage 2.2.0_alpha150 (default/linux/amd64/10.0, gcc-4.7.2, glibc-2.16.0, 3.7.1 x86_64)
=================================================================
System uname: Linux-3.7.1-x86_64-AMD_A8-3870_APU_with_Radeon-tm-_HD_Graphics-with-gentoo-2.2
Timestamp of tree: Fri, 11 Jan 2013 07:45:01 +0000
ld ld di GNU (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p42
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/cmake:           2.8.10.2-r1
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.6, 1.12.6
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.7.2
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo science kernelpanic
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA @EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/polkit-1/actions"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/var/portage/distfiles"
FCFLAGS="-march=native -O2 -pipe"
FEATURES="assume-digests binpkg-logs candy clean-logs compress-build-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch parallel-install preserve-libs protect-owned sandbox sfperms split-elog split-log strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-march=native -O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="it_IT.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j7"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/science /usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext SECURITY_HAZARD X a52 aac aalib acl adolc aften aio alisp alsa amd64 amr ao apache2 apng archive artworkextra atlas audiofile bazaar berkdb bidi bitmap blas bluetooth branding bs2b bzip2 cairo calendar caps cblas-external cdda cdio chm cjk cli clucene collada compact compressed-lumas conntrack consolekit context contrast contrib corefonts cracklib crypt cscope ctypes-python cups curl cvs cxx dbus declarative demosaic detex device-mapper devil dga dhcp dhcp-tools dia dirac discouraged djbfft djvu dri dts dv dvb dvd dvi dvi2tty dvipdfm ebook eigen emf encode epspdf excel exif extensions extra extra-tools extras faac facedetect ffmpeg fftw fits flac flatfile fltk fontconfig fontforge fortran fortran2003 fpx frei0r ftp fts3 fuse g3dvl games gbm gcj gd gdbm gdu geoip gif gimp git gl2ps glade glut gmp gnuplot gnutls go gold gpg gphoto2 gpm graphics graphicsmagick graphite graphviz gsm gstreamer gtk gtk3 gtkstyle gts gudev guile hdf hdf5 hdri heterogeneous hfs highlight hpn http humanities hwdb i18n iconv icu id3 id3tag idn imagemagick imaging imlib inkjar inotify ios ipv6 ipython ithreads jadetex java jbig jemalloc jpeg jpeg2k json kdrive keymap kpathsea ladspa lame lapack lasi latex lcms lensfun libass libcaca libevent libkms libnl libnotify libproxy libsamplerate libv4l llvm lpsol lqr lua luatex lynxkeymap lzma lzo mad math mathml matplotlib matroska mdev melt mem-scramble mercurial metalink metis metric midi minizip mjpeg mmap mms mmx mmxext mng modplug modules mount mp3 mp3rtp mp4 mpeg mpi mpi-threads mudflap multicall multilib multimedia multitarget musepack music musicbrainz mysql mysqli mysqlnd nat-pmp natspec nautilus ncat ncurses ndiff netlink nettle network network-cron networking newnet nlpsolver nls nodrm normalize nping nptl nsplugin ntfs numpy nut nuv objc objc++ objc-gc ocaml ocr odk offensive offlinehelp ofx ogg ogm openal openexr opengl openmp openvg opus osmesa pam pango passwdqc pcap pch pcre pcre16 pdf pdfannotextractor pdfimport pdo perl pgf phonon pkcs11 plotutils plugins png pnm policykit postgres postproc postscript pppd pstricks pth publishers pvr pyglet python python3 q16 q32 q64 q8 qt-faststart qt3support quicktime quvi rar raw readline reiserfs replaygain rle romio rpc rtaudio rtmp ruby scale0tilt scanner schroedinger science script sctp sdl sdlgfx secure-delete session smartcard smi smp sndfile soap sockets soundex sox speex spell spoof-source sql sqlite sqlite3 srt sse sse2 sse3 ssl startup-notification subversion suid svg syslog system-sqlite sysvipc szip t1lib taglib tbb tcl templates tex4ht tftp tga theora thin-splines threads thunar tidy tiff timezone tk tls tools transparent-proxy truetype twolame type3 udev udis86 udisks umfpack unicode unlock-notify urandom usb utils v4l v8 vaapi vala vcd vdr verse video vim vim-syntax vorbis vpx wav wavpack webdav webgl webp wmf wxwidgets x264 xa xanim xcb xcomposite xdg xetex xft xml xmlpatterns xmlreader xmlrpc xmlwriter xmp xorg xpm xps xscreensaver xsl xv xvfb xvid xvmc yuv4mpeg zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CURL_SSL="gnutls" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="nlpsolver pdfimport presenter-console presenter-minimizer scripting-beanshell wiki-publisher" LINGUAS="it en fr" OPENMPI_FABRICS="knem" PHP_TARGETS="php5-4" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" QEMU_SOFTMMU_TARGETS="arm i386 x86_64" QEMU_USER_TARGETS="arm i386 x86_64" RUBY_TARGETS="ruby19" SANE_BACKENDS="plustek" USERLAND="GNU" VIDEO_CARDS="radeon r600" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Michelangelo Scopelliti 2013-01-11 10:10:13 UTC
Created attachment 335154 [details]
complete build log
Comment 2 Ole Markus With (RETIRED) gentoo-dev 2013-01-11 17:21:21 UTC

*** This bug has been marked as a duplicate of bug 449386 ***