Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 451374 - dev-vcs/git: missing required_use for "gtk" use-flag
Summary: dev-vcs/git: missing required_use for "gtk" use-flag
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All All
: Normal normal (vote)
Assignee: Robin Johnson
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-11 09:40 UTC by i.Dark_Templar
Modified: 2013-07-09 09:02 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description i.Dark_Templar 2013-01-11 09:40:46 UTC
As "equery uses git" says, "gtk" use-flag should install gitview contrib tool. But, if use-flag "python" is disabled, this tool won't be installed. After reading ebuild, I've confirmed, that "gtk" use-flag only installs gitview contrib tool, and only if "python" use-flag is enabled. So, required use should be changed from:
REQUIRED_USE="
	cgi? ( perl )
	cvs? ( perl )
	subversion? ( perl )
	webdav? ( curl )
"
to:
REQUIRED_USE="
	cgi? ( perl )
	cvs? ( perl )
	subversion? ( perl )
	webdav? ( curl )
	gtk? ( python )
"

Reproducible: Always

Steps to Reproduce:
1. USE="-python gtk" emerge git
Actual Results:  
Emerge completes successfullty, gitview contrib tool is not installed.

Expected Results:  
Ebuild should exit with error, or at least warn that gitview is not installed.

I think it's a bug because "gtk" use-flag does nothing unless "python" use-flag is set.
I've read git version 1.7.12.4 and 1.8.1 ebuilds, but I guess other versions are affected too.
Comment 1 i.Dark_Templar 2013-01-11 14:25:14 UTC
After looking a bit, I guess all versions of git starting with 1.7.8.6 are affected.
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2013-07-09 08:42:02 UTC
+*git-1.8.3.2 (09 Jul 2013)
+
+  09 Jul 2013; Lars Wendler <polynomial-c@gentoo.org> +git-1.8.3.2.ebuild:
+  Non-maintainer commit: Version bump (bug #467856). Converted ebuild to EAPI-5
+  and python-single-r1 eclass. Added gtk -> python REQUIRED_USE (bug #451374).
+  Hopefully fixed test failure with USE=-perl (bug #470592). Added installation
+  of git-remote-hg (bug #465808) and git-remote-bzr with USE=python.
+