Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 451296 - media-sound/timidity++-2.14.0 get broken by Tk8.6 Tcl_Interp has no member result
Summary: media-sound/timidity++-2.14.0 get broken by Tk8.6 Tcl_Interp has no member re...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Sound Team
URL:
Whiteboard:
Keywords:
: 455398 456366 (view as bug list)
Depends on:
Blocks: tcltk-8.6
  Show dependency tree
 
Reported: 2013-01-10 21:24 UTC by Helmut Jarausch
Modified: 2013-02-10 06:55 UTC (History)
12 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,61.48 KB, text/plain)
2013-01-11 21:50 UTC, Mike MacDonald
Details
Patch to fix break with tcl/tk 8.6 (timidity-result.patch,324 bytes, patch)
2013-01-12 00:18 UTC, bigfoot
Details | Diff
Modified timidity-result patch (timidity-result.patch,324 bytes, patch)
2013-01-13 12:02 UTC, Andreas Proteus
Details | Diff
alternate patch for tcl/tk-8.6 (timidity++-2.14.0-result.patch,354 bytes, patch)
2013-01-29 09:42 UTC, Helmut Jarausch
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Helmut Jarausch 2013-01-10 21:24:00 UTC
media-sound/timidity++ is one more package which got broken by Tcl/Tk 8.6
tk_c.c:916:18: error: 'Tcl_Interp' has no member named 'result'
Comment 1 Mike MacDonald 2013-01-11 21:50:59 UTC
Created attachment 335254 [details]
build.log
Comment 2 bigfoot 2013-01-12 00:18:02 UTC
Created attachment 335272 [details, diff]
Patch to fix break with tcl/tk 8.6
Comment 3 bigfoot 2013-01-12 00:18:28 UTC
hfsutils has the same issue:
https://bugs.gentoo.org/show_bug.cgi?id=451112

Adding #define USE_INTERP_RESULT 1 to config.h after it's done configuring appears to solve the issue.

I attached a patch (pretty basic, but it works)
Comment 4 Carlos Silva 2013-01-12 02:59:50 UTC
Confirmed here. I have the same problem
Comment 5 Travis Hansen 2013-01-12 21:57:48 UTC
The patch didn't apply for me cleanly in post_src_prepare since config.h did not exist yet.  Changing the patch to config.h.in however did the trick.

Thanks!
Comment 6 bigfoot 2013-01-13 02:40:24 UTC
Ohh, good point.  I put it in the ebuild immediately after it was done configuring (although, I'm not sure if that would be the best place for it)

I'm glad config.h.in works, though!
Comment 7 Andreas Proteus 2013-01-13 12:02:34 UTC
Created attachment 335446 [details, diff]
Modified timidity-result patch

This modification worked for me.
It was applied at the end of  src_prepare()
Thank you for the tip.
Comment 8 tman 2013-01-28 21:46:21 UTC
(In reply to comment #7)
> Created attachment 335446 [details, diff] [details, diff]
> Modified timidity-result patch
> 
> This modification worked for me.
> It was applied at the end of  src_prepare()
> Thank you for the tip.

well patch ed but i got this error and i have no clue how to solve :(

de -I/usr/include/pango-1.0 -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/directfb -I/usr/include/libdrm -I/usr/include/qt4 -I/usr/include/qt4/QtGui -I/usr/include/qt4 -I/usr/include/qt4/QtCore -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libpng15 -I/usr/include/pango-1.0 -I/usr/include/harfbuzz -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/freetype2  -DAU_OSS -DAU_ALSA -DAU_NAS -DAU_JACK  -DAU_AO -DAU_VORBIS -I/usr/include -I/usr/include -DAU_FLAC -DAU_SPEEX  -march=corei7 -O2 -pipe -march=corei7 -O2 -pipe -pthread   -c xaw_c.c
In file included from ../timidity/readmidi.h:25:0,
                 from tk_c.c:57:
../timidity/reverb.h:34:0: warning: "EXTERN" redefined [enabled by default]
/usr/include/tcl.h:308:0: note: this is the location of the previous definition
tk_c.c: In function ‘v_eval’:
tk_c.c:916:18: error: ‘Tcl_Interp’ has no member named ‘result’
make[3]: *** [tk_c.o] Error 1
make[3]: *** Waiting for unfinished jobs....
make[3]: Leaving directory `/var/tmp/portage/media-sound/timidity++-2.14.0/work/TiMidity++-2.14.0/interface'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/media-sound/timidity++-2.14.0/work/TiMidity++-2.14.0/interface'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/media-sound/timidity++-2.14.0/work/TiMidity++-2.14.0'
make: *** [all] Error 2
 * ERROR: media-sound/timidity++-2.14.0 failed (compile phase):
 *   emake failed
 * 
 * If you need support, post the output of `emerge --info '=media-sound/timidity++-2.14.0'`,
 * the complete build log and the output of `emerge -pqv '=media-sound/timidity++-2.14.0'`.
 * The complete build log is located at '/var/tmp/portage/media-sound:timidity++-2.14.0:20130128-224413.log'.
 * For convenience, a symlink to the build log is located at '/var/tmp/portage/media-sound/timidity++-2.14.0/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-sound/timidity++-2.14.0/temp/environment'.
 * Working directory: '/var/tmp/portage/media-sound/timidity++-2.14.0/work/TiMidity++-2.14.0'
 * S: '/var/tmp/portage/media-sound/timidity++-2.14.0/work/TiMidity++-2.14.0'
Comment 9 Helmut Jarausch 2013-01-29 09:42:39 UTC
Created attachment 337200 [details, diff]
alternate patch for tcl/tk-8.6

The patch posted previously didn't work for me either.
Furthermore it tries to use a deprecated feature.
The alternate patch seems to be the right solution at least for
Tcl/Tk 8.6 and upwards.
Comment 10 Guy 2013-01-30 16:02:03 UTC
The alternative patch worked for me.

Thank you
Comment 11 Jeroen Roovers gentoo-dev 2013-02-05 11:54:09 UTC
*** Bug 455398 has been marked as a duplicate of this bug. ***
Comment 12 Rafał Mużyło 2013-02-10 04:56:29 UTC
*** Bug 456366 has been marked as a duplicate of this bug. ***
Comment 13 Samuli Suominen gentoo-dev 2013-02-10 06:55:15 UTC
(In reply to comment #9)
> Created attachment 337200 [details, diff] [details, diff]
> alternate patch for tcl/tk-8.6
> 
> The patch posted previously didn't work for me either.
> Furthermore it tries to use a deprecated feature.

thanks! everyone else too.

> The alternate patch seems to be the right solution at least for
> Tcl/Tk 8.6 and upwards.

that is why I've revbumped to -r1 and set the dependency at least to last from 8.5 series, hope this is enough

+*timidity++-2.14.0-r1 (10 Feb 2013)
+
+  10 Feb 2013; Samuli Suominen <ssuominen@gentoo.org>
+  +timidity++-2.14.0-r1.ebuild, +files/timidity++-2.14.0-tcltk86.patch:
+  Fix compability with dev-lang/tk >= 8.6.0 wrt #451296 by Helmut Jarausch and
+  others