Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 450952 - Legacy nvidia-drivers-304.64 and Kernel 3.7.1
Summary: Legacy nvidia-drivers-304.64 and Kernel 3.7.1
Status: RESOLVED DUPLICATE of bug 447566
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-08 22:12 UTC by Stefan Salewski
Modified: 2013-02-12 15:25 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Salewski 2013-01-08 22:12:25 UTC
People with older nvidia cards have to use the legacy nvidia-drivers-304.64, which does not work with (vanilla) 3.7.1 kernel. (emerge nvidia-drivers fails.)

This patch works fine for my AMD64 box:
>http://ogris.de/
>[2012-12-19] How to build NVidia drivers 304.64 for Linux 3.7.x on a 64-bit Gentoo box:

 

Reproducible: Always
Comment 1 Jeroen Roovers gentoo-dev 2013-01-09 12:33:59 UTC

*** This bug has been marked as a duplicate of bug 447566 ***
Comment 2 Stefan Salewski 2013-02-12 15:25:05 UTC
For kernel 3.7.6 (gentoo vanilla-sources) an additional patch for conftest.sh seems to be necessary, see

- -a -n "$SUBLEVEL" -a $SUBLEVEL -le 5 ]; then
+ -a -n "$SUBLEVEL" -a $SUBLEVEL -le 6 ]; then

https://forums.nvidia.com/default/topic/528955/nvidia-linux-x86_64-310-32-and-kernel-3-7-6/