Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 45086 - uim modules installing to the wrong dir under GTK 2.4
Summary: uim modules installing to the wrong dir under GTK 2.4
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: CJK Team
Depends on:
Reported: 2004-03-18 16:54 UTC by David Oftedal
Modified: 2004-03-21 13:32 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description David Oftedal 2004-03-18 16:54:35 UTC
When I tried to reinstall my input modules after installing GTK 2.4, they were still installing to the /usr/lib/gtk-2.0/2.2.0 directory instead of the correct 2.4.0. This behavior is not specified anywhere in the ebuild, and I don't have GTK 2.2.0 installed.

Reproducible: Always
Steps to Reproduce:
1. ACCEPT_KEYWORDS="~x86" emerge gtk+
2. ACCEPT_KEYWORDS="~x86" emerge uim
3. ls /usr/lib/gtk-2.0/2.2.0
4. ls /usr/lib/gtk-2.0/2.4.0

Actual Results:  
The input modules appeared in 2.2.0.

Expected Results:  
The input modules should have appeared in 2.4.0.
Comment 1 foser (RETIRED) gentoo-dev 2004-03-19 04:27:49 UTC
Not a gnome problem, but uim.

Should probably add a not about rebuild input modules to the gtk+ ebuild though.
Comment 2 Mamoru KOMACHI (RETIRED) gentoo-dev 2004-03-19 22:59:59 UTC
I told it to the upstream and he fixed it immediately. The next version will be available today or tomorrow, so I'll add it as soon as possible. If you cannot wait, you may want to try uim-svn ;)  Thanks for the report. 
Comment 3 Mamoru KOMACHI (RETIRED) gentoo-dev 2004-03-21 13:32:26 UTC
I extracted a patch from svn head and applied it to uim-0.3.2
yesterday night. The upstream released uim-0.3.3 today, so
I suppose the problem is fixed now. (both patched uim and
uim-0.3.3 compile & work fine on my laptop)