Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 450322 - sci-biology/mira- - libtool: Version mismatch error. This is libtool 2.4, but the definition of this LT_INIT comes from libtool 2.4.2.
Summary: sci-biology/mira- - libtool: Version mismatch error. This is libtool ...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Science Biology related packages
Depends on:
Reported: 2013-01-05 01:48 UTC by Martin Mokrejš
Modified: 2013-07-07 19:41 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

build.log (build.log,103.22 KB, text/plain)
2013-01-05 01:48 UTC, Martin Mokrejš

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Mokrejš 2013-01-05 01:48:58 UTC
Created attachment 334472 [details]

Somehow, the ebuild does not regenerate the files after patching, I think.

/bin/sh ../../libtool --tag=CXX   --mode=link x86_64-pc-linux-gnu-g++ -pthread -I/usr/lib64/include -DPUBLICQUIET -DAJ_Linux64 -O2 -pipe -march=nocona  -I/usr/include -O2  -I/usr/include -pthread -I/usr/lib64/include -L../io/ -L../util/ -L../errorhandling/ -L../mira -L../examine/ -L../EdIt/ -L../caf/ -L../knn_abi373 -L../knn_alf -L/usr/lib64 -Wl,-O1 -Wl,--as-needed -L/usr/lib  -L/usr/lib64 -lboost_thread-mt -lboost_regex-mt -lboost_system -o read_101 read_101.o -lmirasupport -lmiraerrorhandling  -lmirautil -lmiradptools -lmirafio -lm -lz -Wl,-O1 -Wl,--as-needed -L/usr/lib -L/usr/lib -lexpat -ltcmalloc_minimal
libtool: Version mismatch error.  This is libtool 2.4, but the
libtool: definition of this LT_INIT comes from libtool 2.4.2.
libtool: You should recreate aclocal.m4 with macros from libtool 2.4
libtool: and run autoconf again.
make[2]: *** [read_101] Error 63
make[2]: *** Waiting for unfinished jobs....
make[2]: Leaving directory `/var/tmp/portage/sci-biology/mira-'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/sci-biology/mira-'
make: *** [all-recursive] Error 1
 * ERROR: sci-biology/mira- failed (compile phase):
 *   emake failed

# emerge --info
Portage (default/linux/amd64/10.0, gcc-4.5.2, glibc-2.12.1-r3, x86_64)
System uname: Linux-
Timestamp of tree: Sat, 05 Jan 2013 00:00:01 +0000
ld GNU ld (GNU Binutils) 2.22
distcc 3.1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.2_p42
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.5.4-r4, 2.6.6-r1, 2.7.1, 3.1.3, 3.2.3-r2
dev-util/cmake:           2.8.5-r2
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.6.8
sys-apps/sandbox:         2.4
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.4_p6-r1, 1.5, 1.9.6-r3, 1.10.3, 1.11.1-r1
sys-devel/binutils:       2.22
sys-devel/gcc:            4.3.5, 4.4.4-r1, 4.5.2
sys-devel/gcc-config:     1.4.1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc:           2.12.1-r3
Repositories: gentoo science x-portage x-layman
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA dlj-1.1 sun-bcla-java-vm Oracle-BCLA-JavaSE"
CFLAGS="-O2 -pipe -march=nocona"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/openvpn/easy-rsa /var/bind /var/lib/hsqldb /var/qmail/alias /var/qmail/control /var/spool/torque"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.2/ext-active/ /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.2/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.2/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=nocona"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news nostrip parallel-fetch protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/science /usr/local/portage /var/lib/layman"
USE="X alsa amd64 amr apache apache2 berkdb bzip2 cairo cgi cli cracklib crypt cups cxx dbus device-mapper dri encode ffmpeg flac fontconfig fortran gd gdbm gnutls hal iconv id3tag innodb ipv6 java jce jpeg jpg kde ladspa laptop mad mmx modules mpi mpich2 multilib mysql ncurses nfs nls nptl nptlonly nsplugin ogg opengl openmp openssl pam pcre perl php png policykit python qt3support qt4 readline server session sndfile sse sse2 ssl suexec svg syslog tcpd threads tiff truetype unicode usb wavpack xml xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en cs cz" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 1 Justin Lecher (RETIRED) gentoo-dev 2013-02-17 09:09:47 UTC
Unreproducable here. Does this always happen?
Comment 2 Martin Mokrejš 2013-02-22 00:19:21 UTC
I re-tried and still happens with on same host.

Also happens with on that host.

I even tried 3.9.9 but hit some other error earlier.
Comment 3 Martin Mokrejš 2013-02-22 00:26:39 UTC
Upgrade from libtool-2.4 to 2.4.2 helped. ;-) Just introduce version deps in the ebuild. And I just asked upstream to introduce a version check in configure.
Comment 4 Martin Mokrejš 2013-02-22 00:40:07 UTC
I just throwed the two ebuilds into sci overlay to promote testing. ;-) Had to change URL to fetch from sourceforge instead of gentoo mirror, of course, and the is only available as tar.gz instead of tar.bz2.

+*mira- (22 Feb 2013)
+*mira-3.9.9 (22 Feb 2013)
+  22 Feb 2013; Martin Mokrejs <>
+  +files/mira-, +mira-,
+  +mira-3.9.9.ebuild:
+  sci-biology/mira: current stable and development version bumps
Comment 5 Justin Lecher (RETIRED) gentoo-dev 2013-02-22 07:11:36 UTC
Cool thanks for the bump.

Could you please fix following errors in the buildsystem?

* Compiler optimisation flags used ................. -O3 -funroll-loops
* boost libs are added to LDFLAGS instead of LIBS or BOOST_LIBS
Comment 6 Martin Mokrejš 2013-02-22 10:36:13 UTC
(In reply to comment #5)
> Cool thanks for the bump.
> Could you please fix following errors in the buildsystem?
> * Compiler optimisation flags used ................. -O3 -funroll-loops
> * boost libs are added to LDFLAGS instead of LIBS or BOOST_LIBS

I pointed author of mira to this bug report so I hope we will get an upstream patch soon. ;-) Or I look into it in a week a so.
Comment 7 Martin Mokrejš 2013-03-04 15:33:04 UTC
On Feb 22, 2013, at 1:26 , Martin Mokrejs <> wrote:
> And, maybe you would like to introduce some sanity check in configure
> for user's libtool version to be >= of your own version used to create
> the files in the tar ball:

Thanks a lot for pointing that out, I added a check in the 3.9.x branch.

Won't be back ported to 3.4.x though :-)


So, the ebuild for 3.4.x needs to require a libtool >=2.4.2.

Will ask Bastien what happened with the boost LDFLAGS vs. LIBS handling.
Comment 8 Justin Lecher (RETIRED) gentoo-dev 2013-07-07 19:41:58 UTC
+*mira-3.9.18 (07 Jul 2013)
+  07 Jul 2013; Justin Lecher <> +mira-3.9.18.ebuild:
+  Version BUmp; fixed compilation with dev-libs/boost-1.53.0 and some libtool
+  versions, #450322; thanks Martin Mokrejs for all his work