Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 450088 - dev-vcs/git-1.8.1: svn-fe doesn't link to libintl, even when it should
Summary: dev-vcs/git-1.8.1: svn-fe doesn't link to libintl, even when it should
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo/Alt
Classification: Unclassified
Component: Prefix Support (show other bugs)
Hardware: All OS X
: Normal normal (vote)
Assignee: Robin Johnson
URL:
Whiteboard:
Keywords:
: 452044 456098 510804 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-01-04 01:28 UTC by Charles Davis
Modified: 2017-12-02 20:03 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Fix svn-fe Makefile for macosx (fix_svn-fe_Makefile.txt,598 bytes, patch)
2013-01-31 06:44 UTC, Tomohiko Himura
Details | Diff
use libintl on darwin (git-1.8.1.2.ebuild.patch,472 bytes, patch)
2013-02-19 20:08 UTC, Christoph Junghans
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Charles Davis 2013-01-04 01:28:13 UTC
When the subversion USE flag is enabled, the ebuild for the git package will build svn-fe, a tool to turn svn dumps into fast import streams. Unfortunately, its Makefile assumes either that libgit doesn't use gettext or that, if it does, it's provided in libc. On some systems, like Mac OS, libc doesn't have gettext. So, when libgit needs gettext, svn-fe fails to link because it doesn't link to libintl.

This probably needs to be reported upstream.

Reproducible: Always

Steps to Reproduce:
1. USE=subversion emerge git

Actual Results:  
Build almost finishes, but dies because svn-fe fails to link with:
    LINK svn-fe
Undefined symbols for architecture i386:
  "_libintl_ngettext", referenced from:
      _show_date_relative in libgit.a(date.o)
  "_libintl_gettext", referenced from:
      _show_date_relative in libgit.a(date.o)
      _warn_on_inaccessible in libgit.a(wrapper.o)
      _xgetpwuid_self in libgit.a(wrapper.o)
ld: symbol(s) not found for architecture i386
collect2: ld returned 1 exit status
make: *** [svn-fe] Error 1

Expected Results:  
Git should build and merge successfully.

$ emerge -pqv git
[ebuild     U ] dev-vcs/git-1.8.1 [1.7.12.4] USE="blksha1 curl doc gpg iconv nls pcre perl python subversion threads tk webdav -cgi -cvs -emacs -gnome-keyring% -gtk -highlight (-ppcsha1) {-test} -xinetd"

$ emerge --info

Portage 2.2.01.21476-prefix (prefix/darwin/macos/10.6/x86, gcc-4.2.1, unavailable, 10.8.0 i386)
=================================================================
System uname: Darwin-10.8.0-i386-32bit
Timestamp of tree: Thu, 03 Jan 2013 19:10:49 +0000
distcc 3.1-toolwhip.1 i386-apple-darwin10.0 [disabled]
ccache version 3.1.8 [disabled]
app-shells/bash:      4.2_p39-r1::gentoo_prefix
dev-lang/python:      2.7.3-r2::gentoo_prefix, 3.3.0::gentoo_prefix
dev-util/ccache:      3.1.8::gentoo_prefix
dev-util/cmake:       2.8.9::gentoo_prefix
dev-util/pkgconfig:   0.27.1::gentoo_prefix
sys-devel/autoconf:   2.69::gentoo_prefix
sys-devel/automake:   1.12.4::gentoo_prefix
sys-devel/gcc-config: 1.8-r00.1::gentoo_prefix
sys-devel/libtool:    2.4.2::gentoo_prefix
sys-devel/make:       3.82-r4::gentoo_prefix
Repositories: gentoo_prefix
ACCEPT_KEYWORDS="~x86-macos"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-apple-darwin10"
CFLAGS="-O2 -pipe -march=core2"
CHOST="i686-apple-darwin10"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=core2"
DISTDIR="/Users/chip/Gentoo/usr/portage/distfiles"
FCFLAGS=""
FEATURES="assume-digests binpkg-logs collision-protect config-protect-if-modified distlocks ebuild-locks fixlafiles force-prefix merge-sync news nostrip parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-dead_strip_dylibs"
PKGDIR="/Users/chip/Gentoo/usr/portage/packages"
PORTAGE_CONFIGROOT="/Users/chip/Gentoo/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/Users/chip/Gentoo/var/tmp"
PORTDIR="/Users/chip/Gentoo/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.prefix.freens.org/gentoo-portage-prefix"
USE="X aqua bash-completion berkdb bzip2 cairo coreaudio cracklib crypt curl cxx dbus doc exceptions expat extensions fontconfig gdbm gmp gnutls gpg gzip iconv icu ipv6 jbig jpeg libssh2 lzma lzo mmx mmxext mng modules mysql ncurses nls objc objc++ pch pcre perl png prefix python qt3support readline ruby sasl sql sqlite sqlite3 sse sse2 ssl subversion threads tiff tk truetype unicode uuid vim vim-syntax x86-macos xinerama xml xpm xv zlib" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="ptp2" ELIBC="Darwin" GPSD_PROTOCOLS="garmin garmintxt gpsclock" INPUT_DEVICES="keyboard mouse" KERNEL="Darwin" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby18 ruby19" SANE_BACKENDS="apple" USERLAND="GNU"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, MAKEOPTS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Tomohiko Himura 2013-01-31 06:44:33 UTC
Created attachment 337380 [details, diff]
Fix svn-fe Makefile for macosx

This patch works for me.
Comment 2 Tomohiko Himura 2013-01-31 06:46:18 UTC
*** Bug 452044 has been marked as a duplicate of this bug. ***
Comment 3 Christoph Junghans gentoo-dev 2013-02-19 18:51:22 UTC
*** Bug 456098 has been marked as a duplicate of this bug. ***
Comment 4 Christoph Junghans gentoo-dev 2013-02-19 20:08:17 UTC
Created attachment 339418 [details, diff]
use libintl on darwin

Here is a slighly improved version of the patch.
Comment 5 Oleh 2013-04-18 04:19:58 UTC
Failure happens git with subversion USE flag not only on prefix, on atom based and xeon too. The problem is more generic.
Comment 6 Lars Wendler (Polynomial-C) gentoo-dev 2014-02-04 08:45:48 UTC
Is the patch still needed for any version of dev-vcs/git currently being in the portage tree?
Comment 7 Christoph Junghans gentoo-dev 2014-05-19 21:25:47 UTC
*** Bug 510804 has been marked as a duplicate of this bug. ***
Comment 8 Christoph Junghans gentoo-dev 2014-05-19 21:27:06 UTC
(In reply to Lars Wendler (Polynomial-C) from comment #6)
> Is the patch still needed for any version of dev-vcs/git currently being in
> the portage tree?
Yes, problem is still present in git-1.9.3 (bug #510804).
Comment 9 Fabian Groffen gentoo-dev 2017-12-02 20:03:14 UTC
this compiles fine currently