Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 449996 - media-tv/xbmc-pvr-addons ebuild for XBMC Frodo pvr addons
Summary: media-tv/xbmc-pvr-addons ebuild for XBMC Frodo pvr addons
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Gentoo VDR Project
URL:
Whiteboard:
Keywords: EBUILD
: 455204 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-01-03 14:20 UTC by Timo Rothenpieler
Modified: 2018-04-23 10:52 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
media-tv/xbmc-pvr-addons ebuild (xbmc-pvr-addons-9999.ebuild,760 bytes, text/plain)
2013-01-03 14:21 UTC, Timo Rothenpieler
Details
media-tv/xbmc-pvr-addons-9999.ebuild (xbmc-pvr-addons-9999.ebuild,728 bytes, text/plain)
2013-01-08 11:33 UTC, Timo Rothenpieler
Details
git version of vdr vnsiserver plugin for xbmc frodo (12.x) (vdr-vnsiserver-12.9999.ebuild,1.01 KB, text/plain)
2013-09-30 08:03 UTC, Marc Perrudin
Details
vdr-vnsiserver-12.9999.ebuild (vdr-vnsiserver-12.9999.ebuild,1.01 KB, text/plain)
2013-09-30 08:06 UTC, Marc Perrudin
Details
xbmc-addon-pvr-12.9999.ebuild (xbmc-addon-pvr-12.9999.ebuild,854 bytes, text/plain)
2013-09-30 08:23 UTC, Marc Perrudin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timo Rothenpieler 2013-01-03 14:20:26 UTC
As XBMC Frodo RCs are already in portage, this ebuild adds the default PVR Addons needed to take advantage of the new PVR functions.

Reproducible: Always
Comment 1 Timo Rothenpieler 2013-01-03 14:21:06 UTC
Created attachment 334184 [details]
media-tv/xbmc-pvr-addons ebuild
Comment 2 Timo Rothenpieler 2013-01-08 11:33:00 UTC
Created attachment 334780 [details]
media-tv/xbmc-pvr-addons-9999.ebuild
Comment 3 Lucian Muresan 2013-02-02 23:33:04 UTC
These addons actually rather belong to the media-plugins category, where hd_brummy, the VDR maintainer already provides xbmc-addon-xvdr-9999.ebuild (just one such PVR addon which once was forked off the VNSI addon in this package), both in main portage and in the vdr-devel overlay. He also provides a media-plugins/xbmc-addon-pvr-9999.ebuild very similar attachment 334780 [details]. An enhanced variant of this ebuild, which I wrote without knowing of this one or of hd_brummy's, just originated vrom the one for XVDR, you can find in bug 455204 with the possibility to select the PVR clients to build, by USE flags. It is also hosted in my overlay for some time, at https://github.com/lucianm/gen2ovl-googoo2
Comment 4 SpanKY gentoo-dev 2013-02-18 19:36:43 UTC
*** Bug 455204 has been marked as a duplicate of this bug. ***
Comment 5 Marc Perrudin 2013-09-30 08:03:53 UTC
Created attachment 359770 [details]
git version of vdr vnsiserver plugin for xbmc frodo (12.x)

An update for this bug based on the ebuild from vdr-devel overlay (vdr-vnsiserver-0.9.0_p20130105.ebuild), the current stable version of xbmc (frodo 12.x) doesn't works with the ebuild in vdr-devel (0.0.1_p20130110). xbmc crashes after some time and I have to delete the .xbmc directory to start xbmc again after that).

The git version (9999) is for the devel version (13). This ebuild use the frodo branch available.

The plugin now has the protocol version appended to its name so it needs to be enabled (vnsiserver3). I don't have the skill to change this.

Regards.
Comment 6 Marc Perrudin 2013-09-30 08:06:47 UTC
Created attachment 359772 [details]
vdr-vnsiserver-12.9999.ebuild

git version of vdr vnsiserver plugin for xbmc frodo (12.x)
Comment 7 Marc Perrudin 2013-09-30 08:23:29 UTC
Created attachment 359776 [details]
xbmc-addon-pvr-12.9999.ebuild

Same thing for xbmc part, git version of xbmc vnsiserver plugin for xbmc frodo (12.x)

@hd_brummy : Do you plan to add the ebuild(s) of the official xbmc addons for pvr in gentoo in addition to xvdr ? At least an unstable ebuild(s) for the current stable version of xbmc and vdr.

Regards.
Comment 8 Joerg Bornkessel gentoo-dev 2014-05-25 19:32:13 UTC
all 3 ebuilds are still in the tree or overlay vdr-devel

only one diffrent is in vdr-vnsiserver ebuild, we do check out the master tree, not the frodo tree
@Mark, let me know, if you really need still the (old) frodo tree

@all
please keep in mind, -9999.ebuild.crap is still for short testing for changes in the git/svn/cvs tree, not for using in rock stable install ;)

so please, feel free to contakt me if you have problems with xbmc and a not correspondending plugin/addon
helpfull would be, tell me the xbmc version and mabe your tested (git/svn/cvs)version from the plugin/addon.
i will take then a snapshot and will add it unmasked to the tree, helpfull for all other users in the universe ;)

also please keep in mind, i dont have a xbmc install,
if you ask for snapshots, they should be really tested from you!
Problems should be reported to the xbmc addon/plugin maintainer, not to gentoo...
Comment 9 Xavier Miller (RETIRED) gentoo-dev 2017-01-04 20:50:13 UTC
Hi!

Is this addon ebuild OK for KODI 17?

I use the addons from the kodi overlay, but they are not yet updated.
(I'm using FLAC and PVR modules there).

Thanks ;)