Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 449526 - net-im/pidgin-2.10.6 fails to compile with USE="eds" and gnome-extra/evolution-data-server-3.6
Summary: net-im/pidgin-2.10.6 fails to compile with USE="eds" and gnome-extra/evolutio...
Status: RESOLVED DUPLICATE of bug 434212
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo net-im Herd
URL: https://developer.pidgin.im/ticket/15353
Whiteboard:
Keywords:
: 449556 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-01-01 00:26 UTC by Sven E.
Modified: 2013-03-19 06:52 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sven E. 2013-01-01 00:26:41 UTC
net-im/pidgin-2.10.6 fails to compile with eds useflag.

Seem it does a faulty header import (maybe a deprecated import for that matter)


Reproducible: Always

Steps to Reproduce:
emerge pdigin with +eds and eds v3.6 installed
Actual Results:  
compile failure

Expected Results:  
clean build

In file included from gevolution.h:28:0,
                 from assoc-buddy.c:29:
/usr/include/evolution-data-server-3.6/libebook/e-book.h:12:2: error: #error "Only <libebook/libebook.h> should be included directly."

So pidigin includes e-book.h while it should only include libebook.h

Work for upstream I guess.
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2013-01-01 11:31:40 UTC
*** Bug 449556 has been marked as a duplicate of this bug. ***
Comment 2 Andrew John Hughes 2013-01-03 23:52:42 UTC
The header issue is easily fixed.  The real error is:

gevo-util.c: In function 'gevo_load_addressbook':
gevo-util.c:134:3: error: implicit declaration of function 'e_book_new_system_addressbook' [-Werror=implicit-function-declaration]
gevo-util.c:134:9: warning: assignment makes pointer from integer without a cast [enabled by default]
gevo-util.c:136:3: error: implicit declaration of function 'e_book_new_from_uri' [-Werror=implicit-function-declaration]
gevo-util.c:136:9: warning: assignment makes pointer from integer without a cast [enabled by default]
cc1: some warnings being treated as errors

        if (uri == NULL)
                *book = e_book_new_system_addressbook(error);
        else
            	*book = e_book_new_from_uri(uri, error);

e_book_new_from_uri and e_book_new_system_addressbook no longer exist.  The entire sources system has been re-worked as part of 3.6:

http://gnome-evolution-general.1774414.n4.nabble.com/What-s-New-in-Evolution-3-6-td4655789.html

and you'd need calls to:

http://developer.gnome.org/libebook/stable/EBookClient.html#e-book-client-new

with appropriate ESource instances as far as I can see.

Indeed, upstream work is needed.
Comment 3 Ooblick 2013-01-05 11:44:15 UTC
Looks like there is an upstream ticket for this issue: https://developer.pidgin.im/ticket/15353
Comment 4 renato gallo 2013-01-10 07:32:31 UTC
same here

 emerge --info
Portage 2.1.11.38 (default/linux/amd64/10.0, gcc-4.6.3, glibc-2.16.0, 3.7.1-rc1 x86_64)
=================================================================
System uname: Linux-3.7.1-rc1-x86_64-Intel-R-_Atom-TM-_CPU_D525_@_1.80GHz-with-gentoo-2.2
Timestamp of tree: Tue, 08 Jan 2013 03:00:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p42
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r3, 3.1.5, 3.2.3-r2
dev-util/cmake:           2.8.10.2-r1
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.2
sys-apps/openrc:          9999
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6, 1.12.6
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.5.4, 4.6.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo multimedia sabayon sunrise java-overlay zugaina bgo-overlay
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /usr/share/polkit-1/actions /usr/share/themes/oxygen-gtk/gtk-2.0 /var/lib/hsqldb"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=native"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.switch.ch/ftp/mirror/gentoo/ ftp://mirror.switch.ch/mirror/gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/multimedia /var/lib/layman/sabayon /var/lib/layman/sunrise /var/lib/layman/java-overlay /var/lib/layman/zugaina /var/lib/layman/bgo-overlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="20msframes 3dnow X a52 aac aacskeys aalib abyss ac accessibility acl action_modeswitch addns adns ads afp akonadi alsa amd64 amr analitza anti-cascading ao apng ar archive artworkextra assistant atmo attica authdaemond authfile avx ban bashcompletion bazaar berkdb bidi bigtables bittorrent bluetooth bluray bonobo bzip2 cairo caps cardreader_db2com cardreader_internal cardreader_mp35 cardreader_phoenix cardreader_sc8in1 cardreader_smargo cardreader_stapi case cblasexternal ccache cdda cddb cdr ch chm cjk clamav cli clucene commonlisp compat connectionsharing consolekit contrib corefonts coverage cpudetection cracklib crypt csp ctrls cuda cue cups curl customoptimization cvs cxx dbus dcc_video dconf declarative deflate designerplugin desktopglobe devicemapper dga dhcpcd dirac directfb djbfft djvu dk dmx double-precision doublecheck dri dts dtvla dv dvb dvd dvdr eapsim ebook edd editor eds ee emacs encode es_laguiatv es_miguiatv eu_epg examples exec exif expat extra extraengine extras faac facedetect fam fat fbcon festival ffmpeg fftw fi firefox-bookmarks fits flac flickr flite floppy fluidsynth fontconfig fontforge fortran fpx fr freetds frei0r fuse g3dvl gadu galago gbox gcdmaster gcode gconf gcrypt gd gdal gdbm gdu ggi gif gimp git gl2ps glade gles gles2 gme gmp gnome gnome-keyring gnome-online-accounts gnomekeyring google-gadgets gphoto2 gpm gps gps_source_gpsd graphics_opengl graphite graphviz groupwise gs gsf gsm gstreamer gtk gtk3 gudev gui_sdl guile gyroscopic hardware-carrier hdri hr httpd huro hwdb hyperestraier ical iconv icu id3tag ident idn ieee1394 ifsession ilbc imagemagick indi inotify introspection iodbc ios iplayer iptc ipv6 irda irdeto is it jadetex java javascript jbig jemalloc jingle jpeg jpeg2k json kate kde kdrive kerberos keymap kigscripting kipi kismet kpathsea lame lapack laptop latex latin1 lb lcd lcms ldap led libass libcaca libffi libkms libnotify libproxy libs libtiger libv4l2 libwww live lm_sensors log loghistory lqr lua lzma lzo m4lib-png mad madwifi mapnik matroska maxidx128 mdnsresponder-compat meanwhile mercurial midi minizip mktemp mms mmx mng mod modemmanager modplug modules monitor motif mp3 mpeg mpi mpx msn mtp mudflap multicall multilib multimedia musepack musicbrainz mysql mythtv na_dd na_dtv na_icons nas nautilus ncurses nelma nettle network networkcron networking networkmanager nfs nis nls nokia nptl nsplugin nss ntlm_unsupported_patch ntp ocr odbc odk offlinehelp ofono ogg okular openal opencl openexr opengl openldap openmp openvpn optimisememory optimizedqmake oscar otr pam pam_ssh pango passwdqc pbxt pcap pch pcmcia pcre pcsc pcsc-lite pcsclite pdf perl phonon pic pkcs11 plasma playlist plotutils png policykit postgres postscript ppp pppd privateheaders profiler profiling projectm protocol_camd33 protocol_camd35 protocol_camd35_tcp protocol_cccam protocol_constcw protocol_gbox protocol_newcamd protocol_pandora protocol_radegast protocol_serial ps pt pth pvr python python2 python3 q32 q8 qalculate qimageblitz qq qscintilla qt3support qt4 qthelp quota qwt radius raster ratio rdesktop re reader_bulcrypt reader_conax reader_cryptoworks reader_dre reader_irdeto reader_nagra reader_seca reader_tongfang reader_viaccess reader_videoguard readline readme remote-access remoteaccess remoteosd resolvconf rewrite rle romio rss rtmp rtsp ruby run-as-root samba sample scanner schroedinger scim script scripts sdk sdl sdl-image securedelete semantic-desktop sendto serial session sftp shaper shine shout simage sitemisc skins skype slp smartcard smbsharemodes smbtav2 sms socialweb softquota solver soundex soup source speech speex spell sql sqlite srp srtp sse sse2 ssh1 ssl stapi startup-notification startupnotification stream subversion svg swat swig syslog systemsqlite taglib tcl tcpd tdbtest test-programs testbed testprograms theora thinsplines threads thumbnail tidy tiff tk tools toporouter trace tracker transmitter truetype tslib tv_check tv_combiner tv_pick_cgi twolame udev udisks uk_bleb uk_rt unicode unit-mm unlocknotify upnp urandom usb utils v4l v4l2 vaapi vala vcd vcdx vdpau video vimsyntax vlc vlm vmware_guest_freebsd vmware_guest_linux vmware_guest_netware vmware_guest_solaris vmware_guest_winPre2k vmware_guest_windows vnc vorbis vpnc vpx vroot wavpack webdav webdav-neon webgl webif webkit webp webpresence wifi wimax winbind winpopup wma-fixed wmf wps wxwidgets x264 xa xattr xcb xcomposite xemacs xetex xine xinerama xinetd xml xmlpatterns xmltv xmp xpm xrender xscreensaver xtradb xv xvfb xvid yahoo zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="xmlsec traker socialweb pulseaudio ptp2 adc65 agfa_cl20 aox ax203 barbie canon casio_qv clicksmart310 digigr8 digita dimagev dimera3500 directory enigma13 fuji gsmart300 hp215 iclick jamcam jd11 jl2005a jl2005c kodak_dc120 kodak_dc210 kodak_dc240 kodak_dc3200 kodak_ez200 konica konica_qm150 largan lg_gsm mars mustek panasonic_coolshot panasonic_dc1000 panasonic_dc1580 panasonic_l859 pccam300 pccam600 polaroid_pdc320 polaroid_pdc640 polaroid_pdc700 ricoh ricoh_g3 samsung sierra sipix_blink sipix_blink2 sipix_web2 smal sonix sony_dscf1 sony_dscf55 soundvision spca50x sq905 st2205 stv0674 stv0680 sx330z template topfield toshiba_pdrm11" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CURL_SSL="nss" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="xmlsec presenter-console presenter-minimizer nlpsolver scripting-beanshell scripting-javascript wiki-publisher" LINGUAS="it" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy nvidia v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 5 Nils Andresen 2013-01-10 19:25:56 UTC
seems to be related to Bug#434212 ...
Comment 6 Lars Wendler (Polynomial-C) gentoo-dev 2013-03-19 06:52:10 UTC

*** This bug has been marked as a duplicate of bug 434212 ***