Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 449348 - sci-geosciences/qgis-1.7.4 depens on removed <dev-python/PyQt4-4.9[X,sql,svg] <dev-python/sip-4.13
Summary: sci-geosciences/qgis-1.7.4 depens on removed <dev-python/PyQt4-4.9[X,sql,svg]...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Sci-geo Project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-30 20:53 UTC by donc_oe
Modified: 2013-02-11 02:39 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description donc_oe 2012-12-30 20:53:45 UTC
the ebuild for sci-geosciences/qgis-1.7.4 is requesting pyqt4 lower than "<dev-python/PyQt4-4.9[X,sql,svg]" but this is not available in portage tree.

Reproducible: Always

Steps to Reproduce:
emerge sci-geosciences/qgis-1.7.4
Actual Results:  
!!! The following update has been skipped due to unsatisfied dependencies:

sci-geosciences/qgis:0

emerge: there are no ebuilds to satisfy "<dev-python/PyQt4-4.9[X,sql,svg]".
(dependency required by "sci-geosciences/qgis-1.7.4[python]" [ebuild])


I would suggest to push qgis forward to version 1.8.0 which would fix this issue. See: https://bugs.gentoo.org/show_bug.cgi?id=421093
Comment 1 Jeroen Roovers gentoo-dev 2012-12-31 15:49:19 UTC
(In reply to comment #0)
> I would suggest to push qgis forward to version 1.8.0 which would fix this
> issue. See: https://bugs.gentoo.org/show_bug.cgi?id=421093

Adding a new ebuild doesn't fix the broken ebuilds.
Comment 2 Jean-Claude Repetto 2013-01-03 09:56:28 UTC
No, but since qgis-1.7.4 is obsolete, it can be removed from the portage tree.
Comment 3 Julian Ospald 2013-02-11 02:39:19 UTC
+*qgis-1.8.0 (11 Feb 2013)
+
+  11 Feb 2013; Julian Ospald <hasufell@gentoo.org> +qgis-1.8.0.ebuild,
+  +files/qgis-1.8.0-no-python-pyc.patch:
+  version bump wrt #421093, remove broken wrt #449348