Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 449298 - =app-text/texlive-2012: please stabilize
Summary: =app-text/texlive-2012: please stabilize
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: TeX project
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on: 399781 406045 428350 446528 465748 466700
Blocks: 412499
  Show dependency tree
 
Reported: 2012-12-30 13:12 UTC by poletti.marco
Modified: 2013-04-25 21:30 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
list (tllist,10.52 KB, text/plain)
2013-04-12 10:20 UTC, Alexis Ballier
Details
new list (list,10.62 KB, text/plain)
2013-04-16 09:33 UTC, Alexis Ballier
Details

Note You need to log in before you can comment on or make changes to this bug.
Description poletti.marco 2012-12-30 13:12:37 UTC
Please stabilize =app-text/texlive-2012 and related ebuilds.

Reproducible: Always
Comment 1 Alexis Ballier gentoo-dev 2013-04-12 10:20:30 UTC
Created attachment 345356 [details]
list

list, grabbed from gnome-overlay tools
Comment 2 Alexis Ballier gentoo-dev 2013-04-12 10:21:34 UTC
ok, it should be good to go now, arches please go ahead, see attached list.
Comment 3 Agostino Sarubbo gentoo-dev 2013-04-13 07:31:28 UTC
(In reply to comment #2)
> ok, it should be good to go now, arches please go ahead, see attached list.

This list is not fine for repoman. Please recheck it.
Comment 4 Alexis Ballier gentoo-dev 2013-04-13 17:07:20 UTC
(In reply to comment #3)
> (In reply to comment #2)
> > ok, it should be good to go now, arches please go ahead, see attached list.
> 
> This list is not fine for repoman. Please recheck it.

you mean I shouldn't trust the script :)

what are the errors ? I thought I included all (tex or myself maintained) app-text/texlive{,-core} deps
Comment 5 Agostino Sarubbo gentoo-dev 2013-04-16 09:25:38 UTC
(In reply to comment #4)
> you mean I shouldn't trust the script :)
> 
> what are the errors ? I thought I included all (tex or myself maintained)
> app-text/texlive{,-core} deps

I see different error per arch. For amd64 atm I see:

  dependency.bad                9
   app-text/texlive/texlive-2012.ebuild: RDEPEND: amd64(default/linux/amd64/13.0) ['app-text/epspdf']
   app-text/texlive/texlive-2012.ebuild: RDEPEND: amd64(default/linux/amd64/13.0/desktop) ['app-text/epspdf']
   app-text/texlive/texlive-2012.ebuild: RDEPEND: amd64(default/linux/amd64/13.0/desktop/gnome) ['app-text/epspdf']
   app-text/texlive/texlive-2012.ebuild: RDEPEND: amd64(default/linux/amd64/13.0/desktop/kde) ['app-text/epspdf']
   app-text/texlive/texlive-2012.ebuild: RDEPEND: amd64(default/linux/amd64/13.0/developer) ['app-text/epspdf']
   app-text/texlive/texlive-2012.ebuild: RDEPEND: amd64(hardened/linux/amd64) ['app-text/epspdf']
   app-text/texlive/texlive-2012.ebuild: RDEPEND: amd64(hardened/linux/amd64/no-multilib) ['app-text/epspdf']
   app-text/texlive/texlive-2012.ebuild: RDEPEND: amd64(hardened/linux/amd64/no-multilib/selinux) ['app-text/epspdf']
   app-text/texlive/texlive-2012.ebuild: RDEPEND: amd64(hardened/linux/amd64/selinux) ['app-text/epspdf']
Comment 6 Alexis Ballier gentoo-dev 2013-04-16 09:33:13 UTC
Created attachment 345666 [details]
new list

yep, sorry, I forgot this one... it was long overdue (from tl-2011-r1 but not from current stable tl-2011...)
Comment 7 Agostino Sarubbo gentoo-dev 2013-04-16 10:51:38 UTC
(In reply to comment #6)
> Created attachment 345666 [details]
> new list
> 
> yep, sorry, I forgot this one... it was long overdue (from tl-2011-r1 but
> not from current stable tl-2011...)

Amd64 sounds good now. What about bug 465748 ?
Comment 8 Jeroen Roovers gentoo-dev 2013-04-17 15:46:08 UTC
Stable for HPPA.
Comment 9 Alexis Ballier gentoo-dev 2013-04-17 17:15:38 UTC
(In reply to comment #7)
> What about bug 465748 ?

Well, I probably can patch it to increase the buffer size but since dev-libs/icu has the same code and this program is not installed but rather only used to generate some other files: do we really care about this ?
Comment 10 Agostino Sarubbo gentoo-dev 2013-04-17 19:52:48 UTC
(In reply to comment #9)
> (In reply to comment #7)
> > What about bug 465748 ?
> 
> Well, I probably can patch it to increase the buffer size but since
> dev-libs/icu has the same code and this program is not installed but rather
> only used to generate some other files: do we really care about this ?

If this is trivial I'd like to see it fixed before go ahead
Comment 11 Agostino Sarubbo gentoo-dev 2013-04-18 13:54:57 UTC
amd64 stable
Comment 12 Agostino Sarubbo gentoo-dev 2013-04-18 14:09:50 UTC
x86 stable
Comment 13 Agostino Sarubbo gentoo-dev 2013-04-18 17:07:39 UTC
ppc stable
Comment 14 Agostino Sarubbo gentoo-dev 2013-04-18 21:38:10 UTC
ppc64 stable
Comment 15 Agostino Sarubbo gentoo-dev 2013-04-19 20:46:51 UTC
ia64 stable
Comment 16 Agostino Sarubbo gentoo-dev 2013-04-20 20:09:37 UTC
alpha stable
Comment 17 Agostino Sarubbo gentoo-dev 2013-04-21 12:19:41 UTC
arm stable
Comment 18 Agostino Sarubbo gentoo-dev 2013-04-21 22:37:53 UTC
sparc stable
Comment 19 Agostino Sarubbo gentoo-dev 2013-04-22 08:08:01 UTC
s390 stable
Comment 20 Agostino Sarubbo gentoo-dev 2013-04-25 21:30:02 UTC
sh stable. Last arch, closing