Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 449232 - [science overlay] sci-libs/cholmod-2.0.1: pkg-config fails to find lapack libraries installed from science overlay
Summary: [science overlay] sci-libs/cholmod-2.0.1: pkg-config fails to find lapack lib...
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Science Related Packages
URL:
Whiteboard: about:blank
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-29 19:40 UTC by kaszynek
Modified: 2014-10-19 03:41 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kaszynek 2012-12-29 19:40:04 UTC
Cholmod doesn't build due to dependency error in configure stage.

Reproducible: Always

Steps to Reproduce:
1. Try to emerge cholmod



config log:
http://bpaste.net/show/67143/

emerge --info
Portage 2.2.0_alpha149 (default/linux/amd64/10.0, gcc-4.5.4, glibc-2.16.0, 3.6.2-gentoo x86_64)
=================================================================
System uname: Linux-3.6.2-gentoo-x86_64-Intel-R-_Core-TM-_i5-2400_CPU_@_3.10GHz-with-gentoo-2.2
Timestamp of tree: Thu, 27 Dec 2012 18:15:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
distcc 3.1 x86_64-pc-linux-gnu [disabled]
ccache version 3.1.8 [enabled]
app-shells/bash:          4.2_p39-r1
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.6.8, 2.7.3-r3, 3.1.4-r3, 3.2.3-r2
dev-util/ccache:          3.1.8
dev-util/cmake:           2.8.10.2
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6, 1.12.6
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.5.4, 4.6.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo alice science my_local_overlay
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.0/conf /usr/share/polkit-1/actions /usr/share/themes/oxygen-gtk/gtk-2.0 /var/lib/hsqldb"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=native -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--quiet-build=y"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync metadata-transfer news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.vectranet.pl/gentoo/ http://gentoo.mirror.pw.edu.pl/ http://gentoo.prz.rzeszow.pl http://gentoo.po.opole.pl ftp://ftp.vectranet.pl/gentoo/ ftp://gentoo.po.opole.pl "
LANG="pl_PL.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/alice /var/lib/layman/science /usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="64bit X a52 aac abyss acl acpi alsa amd64 animgif ant apache2 apng audiofile automount avahi bash-completion bazaar berkdb binary-drivers boost branding bzip2 cairo caps cdr chm cleartype cli client colordiff consolekit corefonts cpio cracklib cron crypt csharp css ctype cue cups cupsddk curl curlwrappers cvs cxx cycles dbus declarative device-mapper dhcpcd dot dri dts dv dvb dvd dvdr eclipse edit egl embedded encode examples exif expat extra extras fam fat fbcon fbcondecor fbsplash ffmpeg firefox flac flash flv fontconfig fortran ftp fuse g3dvl gadu gd gdbm gdu gedit gflags gif git glib glibc-compat20 glitz glut gmath gmp gnutls gpm grub gstreamer gtk gudev gzip html hwdb icons iconv icu id3 id3tag ieee1394 imap intl ioctl ipv6 irc jadetex java java6 javascript jpeg kde kipi kpathsea kvm lastfm latex lcdfilter libnotify libsamplerate libssh2 lm_sensors logrotate lua lua-cairo lua-imlib lzma lzo mad matroska matrox mdnsresponder-compat melt mikmod minizip mmap mmx mng mod_python modules mozilla mp3 mp3rtp mp3tunes mp4 mpeg mplayer mudflap multilib musepack mysql mysqli mysqlnd ncurses nfs nls nptl nsplugin ntfs objc objc++ objc-gc ogg openal openexr opengl openmp openssl openvg oss pcre pdf pdo perl phonon php plasma png policykit ppds pppd private-headers pulseaudio python python2 python3 qml qt3support qt4 rar readline samba sdl semantic-desktop server session slp smbclient sound source sql sqlite sqlite3 sse sse2 ssh ssl subversion svg tcpd tex theora threads threadsafe tk truetype tv udev unicode upnp usb v4l v4l2 vdpau vorbis wav webkit winetools winetriks wma wmf wxwidgets x264 x86emu xcb xcomposite xft xml xmp xosd xpm xv xvid xvmc youtube zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="pl en" PHP_TARGETS="php5-4" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 kaszynek 2012-12-29 19:46:30 UTC
With USE="-supernodal" it builds correctly
Comment 2 kaszynek 2012-12-29 19:47:26 UTC
Same error for sci-libs/arpack-3.1.2 in my case.
Comment 3 Rafał Mużyło 2012-12-30 22:36:01 UTC
Which lapack implementation are you using and where does it come from ?

Also, don't use pastebins for bugzilla reports.
Comment 4 kaszynek 2012-12-31 09:15:14 UTC
Ok, my fault... It came from science overlay.
I didn't noticed that :/
Comment 5 Sébastien Fabbro (RETIRED) gentoo-dev 2013-01-04 22:16:55 UTC
so do you confirm this failure even with lapack from the science overlay? i can't reproduce it here.
please post the result of "pkg-config --libs lapack"
thanks.
Comment 6 kaszynek 2013-01-29 16:07:28 UTC
The problem with lapack disappeared (I don't know why, it builds correctly even without -supernodal". But same problem with arpack still exists.

I've got:

[I] virtual/lapack
     Available versions:  3.0 3.1 (~)3.3[1] {doc}

and when I want to emerge arpack:
[I] sci-libs/arpack
     Available versions:  0.96-r3 (~)3.1.2 {doc examples mpi static-libs}
     Installed versions:  3.1.2(13:38:52 19.10.2012)(examples -doc -mpi -static-libs)

i get same error message: configure: error: Cannot find LAPACK libraries

pkg-config doesn't find lapack:

pkg-config --libs lapack
Package lapack was not found in the pkg-config search path.
Perhaps you should add the directory containing `lapack.pc'
to the PKG_CONFIG_PATH environment variable
No package 'lapack' found
Comment 7 kaszynek 2013-01-29 16:08:46 UTC
I meant cholmod in first sentence.
Comment 8 kaszynek 2013-01-29 16:12:24 UTC
Ok, cholmod (with lapack from science overlay) still generates that error in:

USE="lapack" emerge -1 cholmod
Comment 9 François Bissey 2013-01-29 17:25:05 UTC
What does "eselect lapack list" says?
Comment 10 kaszynek 2013-01-29 17:35:36 UTC
Available providers for lapack:
  [1]   reference
Comment 11 kaszynek 2013-01-29 17:38:56 UTC
Ok, so I have reemerged lapack-reference and it probably created symlink. Now arpack compiles fine.
Comment 12 kaszynek 2013-01-29 17:42:37 UTC
So, the last version of lapack was same as the new one:
Installed versions:  3.4.2[1](22:52:26 20.12.2012)(-static-libs -test -xblas)
current:
Installed versions:  3.4.2[1](18:37:33 29.01.2013)(-static-libs -test -xblas)
But after emerge i have something selected in lapack list:

Available providers for lapack:
  [1]   reference *
Comment 13 François Bissey 2013-01-29 19:26:55 UTC
Yes, that's normal. And you shouldn't be able to compile any ebuild depending on lapack if no lapack implementation is eselected first. So as far as I am concerned the behavior was expected as long as nothing was eselected.
Comment 14 Denis Dupeyron gentoo-dev 2014-01-29 19:59:43 UTC
Same here trying to emerge cholmod-2.1.2 except I have reference lapack eselected. I tried unsetting it and then setting it again but it didn't help. I'm using eselect-1.4-r100 from the sci overlay.

Denis.
Comment 15 Sébastien Fabbro (RETIRED) gentoo-dev 2014-02-03 17:59:33 UTC
+  03 Feb 2014; Sébastien Fabbro <bicatali@gentoo.org> -cholmod-1.7.4.ebuild,
+  -cholmod-2.0.1.ebuild, -files/cholmod-1.7.4-debug.patch:
+  Removed old
+

if with cholmod-2.1.2 those bugs persist, feel free to re-open
Comment 16 Denis Dupeyron gentoo-dev 2014-02-07 21:40:25 UTC
> if with cholmod-2.1.2 those bugs persist, feel free to re-open

It does, see comment 14. I just reverified it.

Denis.
Comment 17 Mark Wright gentoo-dev 2014-10-19 03:41:32 UTC
With sci-libs/lapack-reference-9999::science

# eselect lapack show
reference
# 

cholmod-2.1.2 with USE=lapack builds fine for me.

[ebuild   R   ~] sci-libs/cholmod-2.1.2  USE="doc lapack -cuda -metis -minimal -static-libs" 0 KiB

The build.log and config.log may give some hints if it still fails.