I'm an ibus-table user, filing a bug the first time in my gentoo career.
After I updated gnome-light on my laptop from 3.4 to 3.6 today(12-29-2012),
i found that the latest app-i18n/ibus-table-1.3.9 was unable to run properly, which was built upon app-i18n/ibus-1.4.99 that is a part of dependencies of gnome-light-3.6.
When I was launching ibus-setup, the error showed like this:
~ $ ibus-setup
Traceback (most recent call last):
File "/usr/share/ibus-table/engine/main.py", line 25, in <module>
ImportError: No module named ibus
The problem is reproducible. Probably there's version mismatch between ibus-1.4.99 and ibus-table-1.3.9, i think.
I've noticed that there is the latest version ibus-table-1.4.99, and it should help.
If someone kindly bump the latest ibus-table-1.4.99 , that would be nice!
Happy New Year to you all~
Hello all ~
I've worked it out!
After testing the packages time and time again, finally i noticed that the old app-i18n/ibus-table-1.3.9 only works properly when app-i18n/ibus-1.4.99 ' s "deprecated" USE flag enabled.
The "deprecated" USE flag triggers ibus-1.4.99's "--python-library" compiling option, which is OFF by default.
But surprisingly, the flag isn't in the dependency tree of ibus-table-1.3.9, probably because that it's newly added for the new ibus-1.4.99 ,while not existing in the older versions. However, the brand new ibus-1.4.99 is required by gnome 3.6.
So tired after two-days' test... Fortunately, it has been resolved..
Please reopen, as the issue persists.
There is an ibus-table-220.127.116.1121112.tar.gz package available on the ibus page. Probably that version should be added to portage (in addition to fixing the useflags as wanglvyun described).
can you test again as we bump ibus to 1.5.1?
we can either choose "deprecated" and "gtk3 introspection"
(app-i18n/ibus-1.5.1::gentoo, installed) pulled in by
>=app-i18n/ibus-1.4.99[dconf,gtk3,introspection] required by (gnome-base/gnome-shell-3.6.2-r1::gentoo, installed)
but gnome-shell pull "gtk3 introspection" in, so in this case "deprecated" won't usable
(In reply to comment #4)
> can you test again as we bump ibus to 1.5.1?
> we can either choose "deprecated" and "gtk3 introspection"
> (app-i18n/ibus-1.5.1::gentoo, installed) pulled in by
> >=app-i18n/ibus-1.4.99[dconf,gtk3,introspection] required by
> (gnome-base/gnome-shell-3.6.2-r1::gentoo, installed)
> but gnome-shell pull "gtk3 introspection" in, so in this case "deprecated"
> won't usable
Thanks for your reply, but a bit confused...
Why can't we enable both "deprecated" and "gtk3 introspection" of ibus? As ibus-table only work properly with ibus "deprecated" enabled.
What i've observed is that each of them, the three USE flags, doesn't conflict with one another.
My opinion, though maybe thoughtless, is:
submit a tiny modification of the ibus-table ebuild, in which ibus-table depends ibus[deprecated], thus the problem should be solved.
We already have ibus-1.5.1 and ibus-table-1.5.0 in the tree.
It seems this bug is no longer problem?
(In reply to comment #6)
> We already have ibus-1.5.1 and ibus-table-1.5.0 in the tree.
> It seems this bug is no longer problem?
yes, test completed and all have been proved to be correct