Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 449104 - The variable OOO_FORCE_DESKTOP=gnome don't work anymore with Libreoffice and Openbox
Summary: The variable OOO_FORCE_DESKTOP=gnome don't work anymore with Libreoffice and ...
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Office Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-28 21:56 UTC by Henrique Dias
Modified: 2014-12-28 21:32 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info report (emerge-info.txt,4.26 KB, text/plain)
2012-12-28 21:58 UTC, Henrique Dias
Details
Libreoffice without gnome theme. (Libreoffice.png,71.01 KB, image/png)
2012-12-29 21:28 UTC, Henrique Dias
Details
Openoffice with gnome theme. (Openoffice.png,72.22 KB, image/png)
2012-12-29 21:35 UTC, Henrique Dias
Details
strace.log (strace.log.gz,210.87 KB, application/x-gzip)
2012-12-30 16:53 UTC, Henrique Dias
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Henrique Dias 2012-12-28 21:56:41 UTC
After upgrade the gnome from 3.4.1 to 3.6.2 version the variable OOO_FORCE_DESKTOP=gnome don't work anymore. Libreoffice-bin (3.6.4.3) now use the default theme instead of using the gnome theme. I use Openbox as a stand-alone window manager with gnome applications.

Reproducible: Always

Steps to Reproduce:
1. export OOO_FORCE_DESKTOP=gnome
2. soffice
3.
Actual Results:  
Show the libreoffice default theme.

Expected Results:  
Show the gnome theme.
Comment 1 Henrique Dias 2012-12-28 21:58:06 UTC
Created attachment 333636 [details]
emerge --info report

emerge --info report
Comment 2 Tomáš Chvátal (RETIRED) gentoo-dev 2012-12-29 09:14:34 UTC
Try:

SAL_USE_VCL_PLUGIN=gtk lowriter
Comment 3 Henrique Dias 2012-12-29 09:39:59 UTC
(In reply to comment #2)
> Try:
> 
> SAL_USE_VCL_PLUGIN=gtk lowriter

Thank you for your suggestion. I tried what you suggested but it did not work.

This OOO_FORCE_DESKTOP=gnome work with gnome 3.4. Something has changed between gnome 3.4 and 3.6.
Comment 4 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-12-29 09:49:37 UTC
For what it's worth, "OOO_FORCE_DESKTOP=kde soffice" and "OOO_FORCE_DESKTOP=gnome soffice" both work as expected under gnome-3.6: the first one gives a kde-style UI, the second one gives a gnome-style UI.

I suspect that whatever is causing this problem has to do with your openbox setup, and whether you are using a login manager (gdm/kdm/lightdm/etc.) or are trying to launching your X session manually from the console (which is hard to do correctly for the modern desktop).
Comment 5 Henrique Dias 2012-12-29 10:05:00 UTC
(In reply to comment #4)
> For what it's worth, "OOO_FORCE_DESKTOP=kde soffice" and
> "OOO_FORCE_DESKTOP=gnome soffice" both work as expected under gnome-3.6: the
> first one gives a kde-style UI, the second one gives a gnome-style UI.
> 
> I suspect that whatever is causing this problem has to do with your openbox
> setup, and whether you are using a login manager (gdm/kdm/lightdm/etc.) or
> are trying to launching your X session manually from the console (which is
> hard to do correctly for the modern desktop).

These are my installed packages:
x11-wm/openbox-3.5.0_p20121006
x11-misc/lightdm-1.4.0

With gnome 3.4 "OOO_FORCE_DESKTOP=gnome soffice" work fine.
Comment 6 Henrique Dias 2012-12-29 21:28:34 UTC
Created attachment 333710 [details]
Libreoffice without gnome theme.

The attach file show the Libreoffice without gnome theme after running
"OOO_FORCE_DESKTOP=gnome soffice" command.
Comment 7 Henrique Dias 2012-12-29 21:35:25 UTC
Created attachment 333712 [details]
Openoffice with gnome theme.

To rule out the problem, I installed the 3.6 Openoffice version.
The attach file show the Openoffice with gnome theme after running
"OOO_FORCE_DESKTOP=gnome soffice" command.

Conclusion: The OOO_FORCE_DESKTOP variable work with Openoffice, but not work with Libreoffice.
Comment 8 Tomáš Chvátal (RETIRED) gentoo-dev 2012-12-30 11:04:29 UTC
The SAL_USE_VCL_PLUGIN=gtk must work

If that does not work you can try to strace it because it fails to load some object and thus fallback to the generic display.
Comment 9 Henrique Dias 2012-12-30 12:17:45 UTC
(In reply to comment #8)
> The SAL_USE_VCL_PLUGIN=gtk must work
> 
> If that does not work you can try to strace it because it fails to load some
> object and thus fallback to the generic display.

strace don't work.
$ SAL_USE_VCL_PLUGIN=gtk soffice --strace
Error: Can't find the tool "strace", --strace option will be ignored.

But backtrace option work:
$ SAL_USE_VCL_PLUGIN=gtk soffice --backtrace
$ more gdbtrace.log
warning: Currently logging to gdbtrace.log.  Turn the logging off and on to make
 the new setting effective.
warning: Could not load shared library symbols for linux-vdso.so.1.
Do you need "set solib-search-path" or "set sysroot"?
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
[New Thread 0x7fffecb91700 (LWP 15976)]
[New Thread 0x7fffe958e700 (LWP 15977)]
[New Thread 0x7fffe8d8d700 (LWP 15978)]
[New Thread 0x7fffdbfff700 (LWP 15980)]
[New Thread 0x7fffdb370700 (LWP 15981)]
...
Comment 10 Tomáš Chvátal (RETIRED) gentoo-dev 2012-12-30 12:49:53 UTC
I ment it other way around. :-)

Install strace, and run export THEVAR=bla ; strace soffice.bin
Comment 11 Henrique Dias 2012-12-30 16:53:23 UTC
Created attachment 333786 [details]
strace.log

$ SAL_USE_VCL_PLUGIN=gtk loffice --strace
Comment 12 Andreas K. Hüttel gentoo-dev 2014-10-24 20:28:51 UTC
Hmm, I can't find any obvious problem in the log. 

Do you still have this issue?
Comment 13 Andreas K. Hüttel gentoo-dev 2014-12-28 21:32:04 UTC
(In reply to Andreas K. Hüttel from comment #12)
> Hmm, I can't find any obvious problem in the log. 
> 
> Do you still have this issue?

No response.