Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 449032 - www-apps/ampache-3.5.* needs additional dependency < dev-lang/php-5.4
Summary: www-apps/ampache-3.5.* needs additional dependency < dev-lang/php-5.4
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Server (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Kristian Fiskerstrand (RETIRED)
Depends on: 520792
  Show dependency tree
Reported: 2012-12-28 12:54 UTC by Russell Knighton
Modified: 2016-01-08 17:17 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Russell Knighton 2012-12-28 12:54:43 UTC
The current 3.5.* series of ampache is not tested with php 5.4, and definitely versions greater the 5.4.3 no longer work (ampache just display a blank page).

3.6 will work (and for now, anyone that must use/insists to use php >5.4.3 will need to use the alpha release of 3.6, which can be obtained using the live ebuild found in bug #397987).

Until such time, I suggest a dependency be added to the ampache 3.5.* ebuilds that enforces a php version less than 5.4.

Reproducible: Always
Comment 1 Ian Abbott 2012-12-28 21:05:57 UTC
With php 5.4.9,ampache-3.5.4's web install.php fails with the error

Fatal error: Call-time pass-by-reference has been removed in /var/www/host/htdocs/ampache/lib/class/vauth.class.php on line 580

(where 'host' is the webapp-config -h parameter and 'ampache' is the webapp-config -d parameter).
Comment 2 Carter Young 2013-02-28 22:10:50 UTC
See Forum Post:

I helped this person accomplish what this bug is verifying.  Through his research, he found:
Comment 3 Stephen Shkardoon 2013-03-01 02:50:25 UTC
(In reply to comment #2)
> See Forum Post:
> I helped this person accomplish what this bug is verifying.  Through his
> research, he found:
> reference-easy-fix-available

While it's an easy fix, manually patching software on the Gentoo side doesn't seem like a particularly good idea, especially given most larger projects will have many many different lines to change, and if something does break, Gentoo developers probably don't have the time to deal with it.
Better to force users to upgrade than to patch the sources on the Gentoo side, I think.
Comment 4 Róbert Čerňanský 2014-03-04 19:04:03 UTC
Fix the dependency please.  Ampache 3.5.3-r1 works fine with php-5.3.27.  It does not work with 5.5.4; it fails with the symptoms and error described in this bug.
Comment 5 Kristian Fiskerstrand (RETIRED) gentoo-dev 2016-01-08 17:17:03 UTC
Plesae re-open if issue persists in 3.8.1