Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 448894 - app-mobilephone/gnome-phone-manager-0.68 : Only <libebook/libebook.h> should be included directly
Summary: app-mobilephone/gnome-phone-manager-0.68 : Only <libebook/libebook.h> should ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: eds-3.6
  Show dependency tree
 
Reported: 2012-12-27 17:25 UTC by Helmut Jarausch
Modified: 2013-04-07 07:52 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Helmut Jarausch 2012-12-27 17:25:53 UTC
app-mobilephone/gnome-phone-manager-0.68 fails to build :
/usr/include/evolution-data-server-3.6/libebook/e-contact.h:10:2: error: #error "Only <libebook/libebook.h> should be included directly."
Comment 1 milan hodoscek 2013-03-08 08:42:59 UTC
The same happens to me too. I tried to fix some of those includes, but it didn't go very far :-(
Here is emerge info:

Portage 2.1.11.52 (default/linux/amd64/13.0, gcc-4.7.2, glibc-2.16.0, 3.8.0-gentoo x86_64)
=================================================================
System uname: Linux-3.8.0-gentoo-x86_64-Intel-R-_Core-TM-_i7-3770K_CPU_@_3.50GHz-with-gentoo-2.2
KiB Mem:    16114676 total,   5809100 free
KiB Swap:   58604540 total,  58604540 free
Timestamp of tree: Fri, 08 Mar 2013 04:00:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p42
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/cmake:           2.8.10.2-r1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.13.1
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.6.3, 4.7.2-r1
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r5::gnome
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo gnome science local
Installed sets: @enlightenment
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=corei7"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/polkit-1/actions /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=corei7"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--quiet-build=n --with-bdeps=y"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news nostrip parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LC_ALL="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/gnome /var/lib/layman/science /usr/local/portage"
SYNC="rsync://a/portage"
USE="X a52 aac aalib acpi akode alsa amarok amd64 amr amrnb amrr amrwb animgif ansi apache2 apng applet autoipd avahi bash-completion berkdb bitmapfonts bl bluetooth branding breakme bzip2 cairo canna cdaudio cdb cdda cddb cdio cdr cdrom cdsound chm cjk cli clucene clutter consolekit context cracklib crypt cups curl cviewer cvs cxx daap dbus dconf declarative demosaic detex device-mapper dga dirac divx dri dts dv dvd dvdnav dvdread dvi dvi2tty dvipdfm emacs embedded emerald emovix encode epiphany exif exim extensions extra extras fax ffmpeg fftw firefox fits flac fontconfig foomaticdb fortran fping frei0r fts3 fuse g3dvl gcj gd gdbm gdu gimp gimpprint git gkrellm glib glibc-compat20 glitz glut gmedia gmm gnome gnuplot gnutls gphoto2 gpm graphics gstreamer gstreamer010 gstreamer10 gtk gtk3 gudev gzip gzip-el h323 hpijs humanities hwdb hwinfo iconv icu imagemagick introspection ipv6 jack java javascript jbig jpeg jpeg2k kde kdenlive kdepim keymap kpathsea ksolver lame latex latex3 lcms lua lua-cairo luatex lzma mad matplotlib matroska mdnsresponder-compat melt minizip mjpeg mmx mng modules mozilla mp3 mp4 mp4live mpeg mpeg2 mplayer mudflap multilib multiuser musepack music musicbrainz mysql nautilus ncurses nemesi networkmanager new-hpcups nls nptl nsplugin ogg oggvorbis omega openbabel opencl openexr opengl openmp pam pcntl pcre pdf pdo perl phonon pipechan plasma player plotutils png policykit posix ppds print ps pstricks publishers pulseaudio python python3 q16 q32 qt3support qt4 raw readline realmedia reiserfs replytolist rtc scanner schroedinger science scipy screen script scripting scripts scripttools sdl secure-delete semantic-desktop sendto serial session sip smp sna sndfile sockets socks5 sox spamassassin speex spell sql sqlite sqlite3 sse sse2 ssl static-libs subtitles subversion svg svgz t1lib tagwriting tcl tcltk tcpd tetex tex4ht tga theora threads tiff tk tools tracker transcode translator truetype type1 udev unicode usb uxa v4l2 vaapi vcd vdpau vdr vhook vorbis vorbis-psy vpx wav wavpack webkit webm wma wmf wmp wordperfect wxgtk1 x264 xcb xcomposite xetex xft xindy xinetd xiph xml xmp xpm xrandr xterm xulrunner xv xvfb xvid xvmc yv12 zip zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="all" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CURL_SSL="nss" ELIBC="glibc" ENLIGHTENMENT_MODULES="backlight battery clock comp conf-applications conf-dialogs conf-display conf-edgebindings conf-interaction conf-intl conf-keybindings conf-menus conf-paths conf-performance conf-randr conf-shelves conf-theme conf-window-manipulation conf-window-remembers connman cpufreq dropshadow everything fileman fileman-opinfo gadman ibar ibox illume2 mixer msgbus notification pager quickaccess start syscon systray tasks temperature tiling winlist wizard xkbswitch access shot" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="mouse keyboard evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="us" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby19" USERLAND="GNU" VIDEO_CARDS="vesa intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 2 Pacho Ramos gentoo-dev 2013-03-29 14:38:18 UTC
This is really broken because upstream dead, fedora still uses a git with some custom patches (expecting upstream reappears some day)... but looks they won't resurrect and this is probably a candidate for removal
Comment 3 Gilles Dartiguelongue gentoo-dev 2013-03-29 23:40:48 UTC
We have patches in overlay for that, thanks.
We just need to generate a snapshot or try this 0.69 release that was released a few days ago.
Comment 4 Pacho Ramos gentoo-dev 2013-03-30 15:04:38 UTC
I tested 0.69 and also failed, have you tried overlay patch with that version? :/
Comment 5 Gilles Dartiguelongue gentoo-dev 2013-03-30 16:55:54 UTC
I wrote/commited it, yes.
Comment 6 Pacho Ramos gentoo-dev 2013-03-31 12:20:44 UTC
In that case, fine :D
Comment 7 Pacho Ramos gentoo-dev 2013-04-07 07:52:43 UTC
+*gnome-phone-manager-0.69 (07 Apr 2013)
+
+  07 Apr 2013; Pacho Ramos <pacho@gentoo.org>
+  +files/0001-Adapt-to-Evolution-Data-Server-API-changes.patch,
+  +gnome-phone-manager-0.69.ebuild:
+  Version bump, also fixes building with eds-3.6
+