Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 448790 - sys-fs/lvm2 - Please don't depend on udev when USE="+static -udev". (was: static flag requires +udev)
Summary: sys-fs/lvm2 - Please don't depend on udev when USE="+static -udev". (was: sta...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Robin Johnson
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks:
 
Reported: 2012-12-27 07:56 UTC by grey dot
Modified: 2013-06-19 16:06 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description grey dot 2012-12-27 07:56:10 UTC
Error occurs if static flag is enabled and udev flag is not.

Reproducible: Always

Steps to Reproduce:
1. USE="static -udev" emerge lvm2
Actual Results:  
The following USE changes are necessary to proceed:
#required by sys-fs/lvm2-2.02.97-r1[static], required by @selected, required by @world (argument)
>=virtual/udev-196 static-libs


Expected Results:  
lvm2 merged
Comment 1 grey dot 2012-12-27 08:01:28 UTC
This fixes the bug

> diff -up lvm2-2.02.97-r1.ebuild lvm2-2.02.97-r2.ebuild 
--- lvm2-2.02.97-r1.ebuild	2012-12-18 13:31:30.000000000 +0000
+++ lvm2-2.02.97-r2.ebuild	2012-12-27 07:54:50.000000000 +0000
@@ -39,7 +39,7 @@ RDEPEND="${RDEPEND}
 DEPEND="${DEPEND_COMMON}
 		virtual/pkgconfig
 		>=sys-devel/binutils-2.20.1-r1
-		static? ( virtual/udev[static-libs] )"
+		static? ( udev? ( virtual/udev[static-libs] ) )"
 
 S="${WORKDIR}/${PN/lvm/LVM}.${PV}"
Comment 2 Samuli Suominen gentoo-dev 2012-12-27 14:36:38 UTC
What error? Attach the full build.log to this bug, thanks.
Comment 3 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2012-12-27 16:17:24 UTC
The description could have been more clear.

There is no build log, the error is under "Actual Results":

> The following USE changes are necessary to proceed:
> #required by sys-fs/lvm2-2.02.97-r1[static], required by @selected, required by @world (argument)
> >=virtual/udev-196 static-libs

He has USE="+static -udev" set thus he doesn't want udev, yet emerge proposes an USE change that suggests it would add udev; he wants to emerge lvm2 without emerging udev. This only happens with USE="+static", since only then udev is introduced as a dependency.

To solve this unwanted dependency problem, he proposes a patch that would make lvm2 not emerge udev when USE="-udev" (regardless of how the static USE flag is set).
Comment 4 grey dot 2012-12-27 16:38:24 UTC
(In reply to comment #3)
> The description could have been more clear.
> 
> There is no build log, the error is under "Actual Results":
> 
> > The following USE changes are necessary to proceed:
> > #required by sys-fs/lvm2-2.02.97-r1[static], required by @selected, required by @world (argument)
> > >=virtual/udev-196 static-libs
> 
> He has USE="+static -udev" set thus he doesn't want udev, yet emerge
> proposes an USE change that suggests it would add udev; he wants to emerge
> lvm2 without emerging udev. This only happens with USE="+static", since only
> then udev is introduced as a dependency.
> 
> To solve this unwanted dependency problem, he proposes a patch that would
> make lvm2 not emerge udev when USE="-udev" (regardless of how the static USE
> flag is set).

Yeah, thanks for clarification. I just wanted to write the same.
Comment 5 grey dot 2013-02-10 16:07:22 UTC
any update?
Comment 6 Lars Wendler (Polynomial-C) gentoo-dev 2013-06-19 13:52:30 UTC
+  19 Jun 2013; Lars Wendler <polynomial-c@gentoo.org> lvm2-2.02.95-r4.ebuild,
+  lvm2-2.02.97.ebuild, lvm2-2.02.97-r1.ebuild, lvm2-2.02.98.ebuild:
+  non-maintainer commit: Fixed dependency for static builds with "-udev" USE
+  flag (bug #448790).
+