Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 448780 - =dev-ruby/webmock-1.7.4 - Many tests failed.
Summary: =dev-ruby/webmock-1.7.4 - Many tests failed.
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Ruby Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-27 06:51 UTC by Jonathan Lovelace
Modified: 2015-04-26 19:07 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log showing failing tests (dev-ruby:webmock-1.7.4:20121226-201702.log,236.14 KB, text/plain)
2012-12-27 07:26 UTC, Jonathan Lovelace
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Lovelace 2012-12-27 06:51:40 UTC
When trying to build =dev-ruby/webmock-1.7.4, many, many tests fail.

Reproducible: Always

Steps to Reproduce:
1. FEATURES=test emerge -1 dev-ruby/webmock
Actual Results:  
Many, many tests fail

Expected Results:  
Tests pass.

I had the thought that these failures might be a ruby18-only, but when I began to investigate I ran into so many test failures on so many versions of its dependencies that I had to abandon the idea.

I'll attach a build log momentarily.
Emerge --info:
Portage 2.1.11.31 (hardened/linux/amd64, gcc-4.5.4, glibc-2.15-r2, 3.5.4-hardened-r1 x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.5.4-hardened-r1-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T6670_@_2.20GHz-with-gentoo-2.1
Timestamp of tree: Wed, 26 Dec 2012 17:15:01 +0000
ld GNU ld (GNU Binutils) 2.21.1
distcc 3.1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.6
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.4
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: seden sunrise local eclipse g-cpan hackport_laptop gpypi gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=core2 -mtune=core2"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /usr/share/maven-bin-2.2/conf /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=core2 -mtune=core2"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y"
FCFLAGS="-O2 -pipe -march=core2 -mtune=core2"
FEATURES="assume-digests binpkg-logs candy collision-protect compress-build-logs config-protect-if-modified distlocks ebuild-locks fakeroot fixlafiles merge-sync news parallel-fetch parallel-install preserve-libs protect-owned sandbox sfperms strict test unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync webrsync-gpg"
FFLAGS="-O2 -pipe -march=core2 -mtune=core2"
GENTOO_MIRRORS="http://mirrors.rit.edu/gentoo/ http://distfiles.gentoo.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j2 -l5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/seden /usr/portage/local/layman/sunrise /usr/local/portage /usr/portage/local/layman/eclipse /usr/portage/local/layman/g-cpan /usr/portage/local/layman/hackport /usr/portage/local/layman/gpypi /usr/portage"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="X acl alsa amd64 bash-completion berkdb bluetooth bzip2 caps cracklib crypt cxx dri gdbm gpm hardened iconv ipv6 jpeg justify libnotify lm_sensors mmx modules mudflap multilib ncurses nls nptl ogg openmp pam pax_kernel pcre png policykit pppd readline session speex sse sse2 sse3 ssl ssse3 startup-notification tcpd theora truetype udev unicode urandom vorbis zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="all" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer pdfimport" LINGUAS="en en_US" NETBEANS_MODULES="cnd harness ide java nb javafx" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel fbdev i915" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

dev-ruby/webmock-1.6.4 was built with the following:
USE="(multilib) -doc (-test)" RUBY_TARGETS="ruby18 -jruby -ree18 -ruby19"
CFLAGS="-O2 -pipe -mtune=core2"
CXXFLAGS="-O2 -pipe -mtune=core2"
Comment 1 Jonathan Lovelace 2012-12-27 07:26:17 UTC
Created attachment 333442 [details]
Build log showing failing tests
Comment 2 Hans de Graaff gentoo-dev 2012-12-27 17:48:06 UTC
Does the machine that you are testing on have network connectivity?

Which version of patron do you have installed?
Comment 3 Jonathan Lovelace 2012-12-27 17:54:39 UTC
Yes, the machine has network connectivity.

dev-ruby/patron was not previously installed, so version 0.4.18.
Comment 4 Hans de Graaff gentoo-dev 2015-04-26 19:07:07 UTC
I think these failures are due to rspec:3 being installed. webmock uses rspec:2 but calls it in a way that is not compatible with our rspec installation, and thus rspec:3 is used anyway when present.

This is now fixed in webmock-1.20.3.