Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 448772 - [gnome-overlay] x11-libs/gtk+-9999 fails to build due to failed patch "gtk+-3.3.18-fallback-theme.patch "
Summary: [gnome-overlay] x11-libs/gtk+-9999 fails to build due to failed patch "gtk+...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-27 05:54 UTC by Jekyll Wu
Modified: 2014-04-27 22:30 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
patch.out (gtk+-3.3.18-fallback-theme.patch.out,5.79 KB, text/plain)
2012-12-27 05:55 UTC, Jekyll Wu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jekyll Wu 2012-12-27 05:54:18 UTC
>>> Emerging (1 of 1) x11-libs/gtk+-9999 from gnome
>>> Unpacking source...
GIT update -->
   repository:               git://git.gnome.org/gtk+
   at the commit:            20c12b057062ad58bcf60a24157a95c6f36287fc
   branch:                   master
   storage directory:        "/mnt/personal/distfiles/egit-src/gtk+"
   checkout type:            bare repository
Cloning into '/tmp/portage/x11-libs/gtk+-9999/work/gtk+-9999'...
done.
Checking out files: 100% (3215/3215), done.
Branch branch-master set up to track remote branch master from origin.
Switched to a new branch 'branch-master'
>>> Unpacked to /tmp/portage/x11-libs/gtk+-9999/work/gtk+-9999
>>> Source unpacked in /tmp/portage/x11-libs/gtk+-9999/work
>>> Preparing source in /tmp/portage/x11-libs/gtk+-9999/work/gtk+-9999 ...
 * Applying gtk+-3.3.18-fallback-theme.patch ...

 * Failed Patch: gtk+-3.3.18-fallback-theme.patch !
 *  ( /var/lib/layman/gnome/x11-libs/gtk+/files/gtk+-3.3.18-fallback-theme.patch )


Reproducible: Always
Comment 1 Jekyll Wu 2012-12-27 05:55:29 UTC
Created attachment 333434 [details]
patch.out
Comment 2 Gilles Dartiguelongue gentoo-dev 2014-04-27 22:30:24 UTC
live ebuilds is a best effort work. If you want to use them, you should be in a condition that allows you to provide patches to fix the ebuild if it ever fails.

Closing as fixed since the ebuilds have been updated a couple of time since the opening of this report but no update was provided.