Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 448316 - app-emulation/spice: error BadMatch request X_SetInputFocus
Summary: app-emulation/spice: error BadMatch request X_SetInputFocus
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Tiziano Müller (RETIRED)
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks:
 
Reported: 2012-12-23 16:58 UTC by Alex Efros
Modified: 2015-08-16 18:01 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
fix BadMatch error by removing XSetInputFocus() call (spice-badmatch.patch,557 bytes, patch)
2012-12-23 16:58 UTC, Alex Efros
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Efros 2012-12-23 16:58:50 UTC
Created attachment 333146 [details, diff]
fix BadMatch error by removing XSetInputFocus() call

This bug described at https://bugs.freedesktop.org/show_bug.cgi?id=36601

I'm also using fluxbox:

    $ spicec -h 127.0.0.1 -p 5900
    Error: x error on display :0 error BadMatch (invalid parameter attributes) minor 0 request X_SetInputFocus

This issue happens both on current 0.11.3 and latest 0.12.0.

The "patch" attached.
Comment 1 Doug Goldstein gentoo-dev 2013-06-04 21:58:41 UTC
Upstream recommends you try remote-viewer from the virt-viewer package instead since spicy is not supported by them.
Comment 2 Matthias Maier gentoo-dev 2015-08-16 18:01:48 UTC
Upstream will not fix this issue - I don't see a way to make this patch compatible with the intended behavior.