Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 448294 - app-emulation/virtualbox-4.2.6: cannot open shared object libstdc++.so.6
Summary: app-emulation/virtualbox-4.2.6: cannot open shared object libstdc++.so.6
Status: RESOLVED WORKSFORME
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-23 12:34 UTC by Juergen Rose
Modified: 2013-10-02 14:31 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
/var/tmp/portage/app-emulation/virtualbox-4.2.6/temp/build.log (build.log,254.09 KB, text/plain)
2012-12-23 12:34 UTC, Juergen Rose
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Juergen Rose 2012-12-23 12:34:40 UTC
Created attachment 333114 [details]
/var/tmp/portage/app-emulation/virtualbox-4.2.6/temp/build.log

'emerge virtualbox' fails with:

...
  Generating Java glue files from XIDL 
filesplitter: Out of 198 files: 198 rewritten, 0 unchanged. (/var/tmp/portage/app-emulation/virtualbox-4.2.6/work/VirtualBox-4.2.6/out/linux.amd64/release/obj/vboxjxpcom-gen/jxpcomgen/java/glue/)
  xpidl   XPCOM - {C}/src/libs/xpcom18a4/xpcom/base/nsIConsoleListener.idl
  xpidl   XPCOM - {C}/src/libs/xpcom18a4/xpcom/base/nsIConsoleMessage.idl
...
  INST    tstVMStructRC => {C}/out/linux.amd64/release/bin/tstVMStructRC
  GEN     {T}/VMM/tstVMStructRC.h
/var/tmp/portage/app-emulation/virtualbox-4.2.6/work/VirtualBox-4.2.6/out/linux.amd64/release/bin/tstVMStructRC: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory
kmk: *** [/var/tmp/portage/app-emulation/virtualbox-4.2.6/work/VirtualBox-4.2.6/out/linux.amd64/release/obj/VMM/tstVMStructRC.h] Error 127



But /usr/lib64/gcc/x86_64-pc-linux-gnu/4.6.3/libstdc++.so.6 exists and I can't find any problenms connected with /usr/lib64/gcc/x86_64-pc-linux-gnu/4.6.3/libstdc++.so.6:

root@dog:/root(10)# gcc-config -l
 [1] x86_64-pc-linux-gnu-4.6.3 *
root@dog:/root(11)# ll /usr/lib64/gcc/x86_64-pc-linux-gnu/4.6.3/libstdc++.so.6*
lrwxrwxrwx 1 root root     19 Nov 22 08:35 /usr/lib64/gcc/x86_64-pc-linux-gnu/4.6.3/libstdc++.so.6 -> libstdc++.so.6.0.16*
-rwxr-xr-x 1 root root 978952 Nov 22 08:35 /usr/lib64/gcc/x86_64-pc-linux-gnu/4.6.3/libstdc++.so.6.0.16*
root@dog:/root(12)# ldd  /usr/lib64/gcc/x86_64-pc-linux-gnu/4.6.3/libstdc++.so.6.0.16
        linux-vdso.so.1 (0x00007fff5f1ff000)
        libm.so.6 => /lib64/libm.so.6 (0x00007f921ffe8000)
        libc.so.6 => /lib64/libc.so.6 (0x00007f921fc3f000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f9220641000)
        libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007f921fa28000)





'revdep-rebuild' does not help.


root@dog:/root(14)# emerge --info '=app-emulation/virtualbox-4.2.6'
Portage 2.1.11.38 (default/linux/amd64/10.0, gcc-4.6.3, glibc-2.16.0, 3.6.10-gentoo x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.6.10-gentoo-x86_64-Intel-R-_Core-TM-2_Duo_CPU_E7300_@_2.66GHz-with-gentoo-2.2
Timestamp of tree: Sun, 23 Dec 2012 06:00:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p39-r1
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/cmake:           2.8.10.2
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6, 1.12.6
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo lisp science sunrise voyageur x-portage x-cpan x-g-octave
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA PUEL Intel-SDP dlj-1.1 skype-eula skype-4.0.0.7-copyright googleearth AdobeFlash-10.3 cadsoft Oracle-BCLA-JavaSE MakeMKV-EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /usr/share/polkit-1/actions /var/lib/hsqldb"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/lisp /var/lib/layman/science /var/lib/layman/sunrise /var/lib/layman/voyageur /usr/local/portage /var/lib/cpan /var/lib/g-octave"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="64bit R X Xaw3d a52 aac acl acpi admin afs alsa amd64 ao apache2 apng applet archive arpack asf aspell assistant atlas audacious audiofile automap automount bash-completion berkdb blas blast bluetooth bluray boo boost bzip2 cairo cdda cddb cdf cdio cdparanoia cdr cg cgi chm cli consolekit cracklib crypt css cuda cups curl cxx daap db dbi dbm dbus declarative designer devhelp device-mapper dga dia dirac djvu doc dot dri ds2490 ds9097 ds9097u dts dv dvb dvd dvdr dvi dynamicplugin eds egl elf emacs emboss emf encode epiphany evo examples exif expat extensions extra extras faac faad ffmpeg fftw firefox fits flac fltk fontconfig foomaticdb fortran fortran95 fpx fts3 fuse g3dvl gcj gd gdal gdbm gdu gedit geoip geolocation geos gfortran gif gimp git glade glib glpk gml gmp gnome gnome-keyring gnome-print gnuplot gnutls gold gphoto2 gpm grammar graphics graphtft graphviz grass gsl gsm gstreamer gtk gtk3 gudev guile harness hddtemp hdf hdf5 hdri html http httpd hvm hwdb iconv icq icu id3 id3tag ide imagemagick imap inotify ipod ipv6 irda ithreads jabber jadetex java jbig john jpeg jpeg2k kate kdepim kdrive kerberos keymap kpathsea kqemu kvm ladspa lame lapack latex lcms ldap lensfun libffi libkms libnotify libsamplerate lirc live lm_sensors lua lzo mad madwifi mail maildir mapnik math matroska matrox media-library mercurial mikmod mmx mmxext mng modules mono motif mozilla mp3 mp4 mpeg mpi mplayer mtp mudflap multilib musepack musicbrainz mysql mysqli nautilus ncurses netcdf netpbm network networking nfs nls nntp nptl nsplugin ntfs ntp numpy nvidia obex objc ocaml ocr octave odbc ofa ogdi ogg openexr opengl openmp overview pae pam pcre pda pdf perl plotutils plugins png podcast policykit portaudio posix postgres postscript pppd preview-latex proj projectm projectx pstricks pulseaudio python python-bindings q16 q32 qemu qhull qt3support qt4 quicktime raw readline reiserfs reports rle romio rpc rrdcgi rrdtool sage samba sasl schroedinger science sdk sdl secure-delete semantic-desktop server session shout sip slang slp smart smbclient smp sms sndfile snmp soap sockets soup sox speex spell sql sqlite sse sse2 ssl ssse3 subtitles subversion sudo suexec svg svm swig szip t1lib tcl tcpd tex tex4ht texmacs tgif theora thesaurus threads thunderbird tidy tiff tk tools truetype udev unicode usb userlocales utempter vaapi video virtualbox visio vorbis wav webdav webdav-serf webkit wifi wmf wxwidgets x264 xa xattr xcb xemacs xetex xext xft xine xml xmlreader xmlrpc xpm xv xvid xvmc yaml youtube zlib zvbi" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_core authn_dbm authn_default authn_file authz_core authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgid dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info lbmethod_byrequests log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif slotmem_shm so socache_shmcb speling status unique_id unixd userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="canon fuji ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CURL_SSL="nss" DRACUT_MODULES="caps lvm mdraid syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de fr ru" NETBEANS_MODULES="apisupport cnd dlight enterprise ergonomics groovy gsf harness ide identity j2ee java mobility nb php profiler ruby websvccommon xml" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" QEMU_SOFTMMU_TARGETS="arm i386 x86_64" QEMU_USER_TARGETS="arm i386 x86_64" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nouveau vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON



root@dog:/root(15)# emerge -pqv '=app-emulation/virtualbox-4.2.6'
[ebuild     U ] app-emulation/virtualbox-4.2.6 [4.2.4-r1] USE="additions alsa doc extensions java opengl pam pulseaudio python qt4 sdk -headless -vboxwebsrv -vnc" 
[ebuild     U ] app-emulation/virtualbox-extpack-oracle-4.2.6 [4.2.4]
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2012-12-23 13:58:25 UTC
This looks like a general problem with your installation. I doubt virtualbox is the only package being affected by this.

Maybe trying to re-enable your current compiler helps:

  gcc-config 1 && source /etc/profile

Then try to emerge virtualbox once again.
Comment 2 Juergen Rose 2012-12-23 14:58:18 UTC
>> gcc-config 1 && source /etc/profile
I did this and additional revdep-rebuild, but I still have the same error.

I am now doing 'emerge -uvDNe system' and waiting that 765 packages are reemerged.
Comment 3 Juergen Rose 2012-12-24 10:19:17 UTC
'emerge -uvDNe system' stopped anytime in the night after several hundred of packages and because the line was cancelled. I can not say where it stopped, at least gcc was not reemerged. After this 'emerge virtualbox' failed with the same error. Then I reemerged gcc-4.6.3. After this also 'emerge virtualbox' was succesfull.
Comment 4 Ben Kohler gentoo-dev 2013-10-02 14:31:33 UTC
It sounds like this was just some local gcc damage, please reopen if you are still being affected by this.

Thanks!