Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 448024 - dev-libs/cloog-ppl-0.15.10 fails with >=dev-libs/ppl-1.0
Summary: dev-libs/cloog-ppl-0.15.10 fails with >=dev-libs/ppl-1.0
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords: PATCH
: 529202 541898 (view as bug list)
Depends on: gcc-4.8-stable
Blocks: 446698
  Show dependency tree
 
Reported: 2012-12-20 22:33 UTC by Jimmy.Jazz
Modified: 2015-09-20 22:47 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
patch for ppl versions over 0.10 (cloog-ppl-0.15.10-ppl_not_found.patch,449 bytes, patch)
2012-12-20 22:34 UTC, Jimmy.Jazz
Details | Diff
Patch against toolchain.eclass (drop-pre-4.8-graphite-support.patch,2.08 KB, patch)
2015-02-19 00:11 UTC, Anthony Basile
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jimmy.Jazz 2012-12-20 22:33:25 UTC
configure.in is unable to find ppl over 0.10

Reproducible: Always

Steps to Reproduce:
1.
2.emerge -a1v cloog-ppl
3.



apply patch cloog-ppl-0.15.10-ppl_not_found.patch
Comment 1 Jimmy.Jazz 2012-12-20 22:34:24 UTC
Created attachment 332852 [details, diff]
patch for ppl versions over 0.10
Comment 2 Ryan Hill (RETIRED) gentoo-dev 2013-01-07 00:30:36 UTC
I don't know if cloog-ppl will even work with ppl-1.0.  We have to do some testing first.
Comment 3 SpanKY gentoo-dev 2014-11-04 04:13:46 UTC
i think we're going to drop cloog-ppl entirely now that gcc-4.8+ supports the main cloog package
Comment 4 Jeroen Roovers gentoo-dev 2014-11-14 13:31:04 UTC
*** Bug 529202 has been marked as a duplicate of this bug. ***
Comment 5 Tony Vroon gentoo-dev 2015-01-20 10:36:21 UTC
With GCC 4.9 now ~arch, has the time come to mask it for removal?
Comment 6 Joshua Kinard gentoo-dev 2015-01-25 13:18:57 UTC
(In reply to Tony Vroon from comment #5)
> With GCC 4.9 now ~arch, has the time come to mask it for removal?

The problem with this is cross-toolchains older than 4.9 (like gcc-4.7.4, which I am stuck on for MIPS due to PR61538, which upstream is ignoring) will dep on cloog-ppl if USE graphite.

The proposed patch appears to work.  At least, it compiles.  There is this warning, however:

 * This package has a configure.in file which has long been deprecated.  Please
 * update it to use configure.ac instead as newer versions of autotools will die
 * when it finds this file.  See https://bugs.gentoo.org/426262 for details.

Which the patch touches, so that will have to be dealt with for the long term.
Comment 7 SpanKY gentoo-dev 2015-02-15 19:07:22 UTC
(In reply to Tony Vroon from comment #5)

i think the critical part is that gcc-4.8 is stable pretty much everywhere.  so we can unwind graphite support from <=gcc-4.7.
Comment 8 Anthony Basile gentoo-dev 2015-02-16 13:22:32 UTC
(In reply to Joshua Kinard from comment #6)
> (In reply to Tony Vroon from comment #5)
> > With GCC 4.9 now ~arch, has the time come to mask it for removal?
> 
> The problem with this is cross-toolchains older than 4.9 (like gcc-4.7.4,
> which I am stuck on for MIPS due to PR61538, which upstream is ignoring)
> will dep on cloog-ppl if USE graphite.
> 

Do you need graphite?  Removing it from <=4.7 also cleans up the toolchain.eclass a bit.
Comment 9 Joshua Kinard gentoo-dev 2015-02-16 15:43:12 UTC
(In reply to Anthony Basile from comment #8)
> (In reply to Joshua Kinard from comment #6)
> > (In reply to Tony Vroon from comment #5)
> > > With GCC 4.9 now ~arch, has the time come to mask it for removal?
> > 
> > The problem with this is cross-toolchains older than 4.9 (like gcc-4.7.4,
> > which I am stuck on for MIPS due to PR61538, which upstream is ignoring)
> > will dep on cloog-ppl if USE graphite.
> > 
> 
> Do you need graphite?  Removing it from <=4.7 also cleans up the
> toolchain.eclass a bit.

Doubtful.  Never really tried it, and not really inclined.  Probably better to save that and LTO testing for 4.9, when I can get that to run on these SGI platforms.
Comment 10 Ryan Hill (RETIRED) gentoo-dev 2015-02-17 22:17:47 UTC
We would remove USE=graphite from <=4.7 like we did for 4.5 previously.
Comment 11 Joshua Kinard gentoo-dev 2015-02-18 14:10:09 UTC
With the revelation that PR61538 was unknowingly addressed upstream, this means I'm not stuck on 4.7 with these MIPS systems anymore.  I'll be kickstarting a stage build using 4.9.2 shortly just to make sure there aren't any more problems.  Whatever you guys want to do to 4.7 now, go ahead!
Comment 12 Anthony Basile gentoo-dev 2015-02-19 00:11:43 UTC
Created attachment 396912 [details, diff]
Patch against toolchain.eclass

This patch drops pre 4.8 support for graphite and nicely cleans up the whole cloog-ppl mess.
Comment 13 Ryan Hill (RETIRED) gentoo-dev 2015-02-19 06:21:46 UTC
Comment on attachment 396912 [details, diff]
Patch against toolchain.eclass

>+	# graphite was added in 4.4 but we only support it in 4.8+ due to external
>+	# library issues.
>+	confgcc+=( $(use_with graphite cloog) )
>+	use graphite && confgcc+=( --disable-isl-version-check )

I believe this will call `use_with` on versions where graphite isn't in IUSE which is undefined behaviour wrt. PMS.  It also makes an automagic dependency.  It needs to be explicitly disabled for 4.4-4.7.

We might as well support 5.0 while we're at it.  5.0 drops the dependency on cloog and just requires isl-0.14 (actually 0.12.2 but 0.14 is recommended). Something like (untested):

	if tc_version_is_at_least 5.0 ; then
		confgcc+=( $(use_with graphite isl) )
		use graphite && confgcc+=( --disable-isl-version-check )
	elif tc_version_is_at_least 4.8 ; then
		confgcc+=( $(use_with graphite cloog) )
		confgcc+=( $(use_with graphite isl) )
		use graphite && confgcc+=( --disable-isl-version-check )
	elif tc_version_is_at_least 4.4 ; then
		confgcc+=( --without-cloog )
		confgcc+=( --without-ppl )
	fi

(Plus the required RDEPEND bits.) Bleh. At least the include paths are gone.
Comment 14 SpanKY gentoo-dev 2015-03-17 04:56:02 UTC
*** Bug 541898 has been marked as a duplicate of this bug. ***
Comment 15 SpanKY gentoo-dev 2015-03-17 05:24:47 UTC
i've pushed this now that merges all of our versions:
http://sources.gentoo.org/eclass/toolchain.eclass?r1=1.655&r2=1.656
Comment 16 SpanKY gentoo-dev 2015-03-17 05:27:15 UTC
Commit message: Block cloog-ppl as we are punting it
http://sources.gentoo.org/dev-libs/ppl/ppl-1.1.ebuild?r1=1.3&r2=1.4
Comment 18 SpanKY gentoo-dev 2015-09-20 22:47:17 UTC
cloog-ppl itself is now dropped as well:
http://gitweb.gentoo.org/repo/gentoo.git/commit/?id=b813ba983b1784bf746fdc62284067a5f9394b36