Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 447920 - net-analyzer/check_mk - Nagios / Icinga general purpose plugin to retrieve data
Summary: net-analyzer/check_mk - Nagios / Icinga general purpose plugin to retrieve data
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: Other Linux
: Normal normal with 1 vote (vote)
Assignee: Default Assignee for New Packages
URL:
Whiteboard:
Keywords: EBUILD, PATCH
: 432184 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-12-20 09:27 UTC by Timo Eissler
Modified: 2014-07-17 23:10 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
check_mk-1.2.0_p3.ebuild (check_mk-1.2.0_p3.ebuild,4.83 KB, text/plain)
2012-12-20 09:27 UTC, Timo Eissler
Details
files/check_mk-1.2.0p3-setup.sh.patch (check_mk-1.2.0p3-setup.sh.patch,630 bytes, text/plain)
2012-12-20 09:28 UTC, Timo Eissler
Details
check_mk-1.2.0_p3.ebuild (check_mk-1.2.0_p3.ebuild,9.60 KB, text/plain)
2012-12-22 13:08 UTC, Timo Eissler
Details
files/check_mk-1.2.0p3-setup.sh.patch (check_mk-1.2.0p3-setup.sh.patch,1.22 KB, patch)
2012-12-22 13:08 UTC, Timo Eissler
Details | Diff
check_mk-1.2.2p1-setup.sh.patch (check_mk-1.2.2p1-setup.sh.patch,1.17 KB, patch)
2013-05-24 16:47 UTC, Timo Eissler
Details | Diff
check_mk-1.2.2_p1.ebuild (check_mk-1.2.2_p1.ebuild,10.72 KB, text/plain)
2013-05-24 16:49 UTC, Timo Eissler
Details
check_mk-1.2.2_p1.ebuild (check_mk-1.2.2_p1.ebuild,10.70 KB, text/plain)
2013-06-03 15:12 UTC, Timo Eissler
Details
check_mk-1.2.2p1-setup.sh.patch (check_mk-1.2.2p1-setup.sh.patch,1.46 KB, patch)
2013-07-02 14:32 UTC, Marcel Pennewiß
Details | Diff
check_mk-1.2.4_p2.ebuild (check_mk-1.2.4_p2.ebuild,10.55 KB, text/plain)
2014-05-09 16:09 UTC, Marcel Pennewiß
Details
check_mk-1.2.4_p3.ebuild (check_mk-1.2.4_p3.ebuild,9.71 KB, text/plain)
2014-06-27 18:43 UTC, Timo Eissler
Details
check_mk-1.2.4p3-setup.sh.patch (check_mk-1.2.4p3-setup.sh.patch,1.88 KB, patch)
2014-06-27 18:43 UTC, Timo Eissler
Details | Diff
metadata.xml (metadata.xml,1.42 KB, text/xml)
2014-06-30 18:59 UTC, Timo Eissler
Details
check_mk-1.2.4_p4.ebuild (check_mk-1.2.4_p4.ebuild,10.10 KB, text/plain)
2014-06-30 19:00 UTC, Timo Eissler
Details
check_mk-1.2.4_p5.ebuild (check_mk-1.2.4_p5.ebuild,10.13 KB, text/plain)
2014-07-06 14:01 UTC, Timo Eissler
Details
patch against 1.2.4_p5 (check_mk-1.2.4_p5.ebuild.diff,3.18 KB, patch)
2014-07-09 09:12 UTC, Yixun Lan
Details | Diff
check_mk-1.2.4_p5-r1.ebuild (check_mk-1.2.4_p5-r1.ebuild,9.55 KB, text/plain)
2014-07-15 17:20 UTC, Timo Eissler
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timo Eissler 2012-12-20 09:27:51 UTC
Created attachment 332764 [details]
check_mk-1.2.0_p3.ebuild

I created a ebuild for check_mk, because the existing ebuild (https://bugs.gentoo.org/show_bug.cgi?id=432184) only has the capability to install the check_mk agent and not the complete check_mk package.

So this is the first version of my ebuild for check_mk 1.2.0p3.
As this is my first complex ebuild please review it and give me feedback.
Comment 1 Timo Eissler 2012-12-20 09:28:52 UTC
Created attachment 332766 [details]
files/check_mk-1.2.0p3-setup.sh.patch

The patch for the check_mk setup.sh script.
Comment 2 Timo Eissler 2012-12-22 13:08:10 UTC
Created attachment 333036 [details]
check_mk-1.2.0_p3.ebuild

new version of the ebuild
Comment 3 Timo Eissler 2012-12-22 13:08:38 UTC
Created attachment 333038 [details, diff]
files/check_mk-1.2.0p3-setup.sh.patch

new version of the patch
Comment 4 Sergey Popov gentoo-dev 2012-12-24 09:55:34 UTC
*** Bug 432184 has been marked as a duplicate of this bug. ***
Comment 5 Stephan Kupfer 2013-01-11 16:04:26 UTC
Would be nice if it goes upstream! :)
Ebuild works for me. Thx!
Comment 6 Timo Eissler 2013-05-24 16:47:47 UTC
Created attachment 349080 [details, diff]
check_mk-1.2.2p1-setup.sh.patch
Comment 7 Timo Eissler 2013-05-24 16:48:39 UTC
Comment on attachment 349080 [details, diff]
check_mk-1.2.2p1-setup.sh.patch

The patch for the check_mk setup.sh script.
Comment 8 Timo Eissler 2013-05-24 16:49:35 UTC
Created attachment 349082 [details]
check_mk-1.2.2_p1.ebuild

Ebuild for the new stable version 1.2.2p1 of check_mk.
Comment 9 Timo Eissler 2013-05-24 16:54:58 UTC
If anyone of the Gentoo developers would assist me, i would provide support and updates for this ebuild as good as i can.

I already thought about becoming a Gentoo developer, but i'm not sure if i have enough time to do this.
Comment 10 Marcel Pennewiß 2013-06-02 16:37:15 UTC
Some of your useflags-checks are not correct and always checks for use-flag "apache_status".
Comment 11 Timo Eissler 2013-06-03 15:12:15 UTC
Created attachment 349974 [details]
check_mk-1.2.2_p1.ebuild
Comment 12 Timo Eissler 2013-06-03 15:12:48 UTC
Comment on attachment 349974 [details]
check_mk-1.2.2_p1.ebuild

Fixed wrong use flag checks.
Comment 13 Marcel Pennewiß 2013-07-02 14:32:37 UTC
Created attachment 352456 [details, diff]
check_mk-1.2.2p1-setup.sh.patch

creation of auth.serials out of the sandbox causes an ACCESS VIOLATION error. Updated patch fixes this problem. I'll report this upstream.
Comment 14 Marcel Pennewiß 2014-05-09 16:09:57 UTC
Created attachment 376622 [details]
check_mk-1.2.4_p2.ebuild

Version bump, patch of version 1.2.2p1 is upstream now
Comment 15 Timo Eissler 2014-06-27 18:43:06 UTC
Created attachment 379798 [details]
check_mk-1.2.4_p3.ebuild

Added completely rewritten ebuild for check_mk 1.2.4p3
Comment 16 Timo Eissler 2014-06-27 18:43:51 UTC
Created attachment 379800 [details, diff]
check_mk-1.2.4p3-setup.sh.patch

Patch for setup.sh from check_mk 1.2.4p3
Comment 17 Yixun Lan gentoo-dev 2014-06-30 04:21:32 UTC
a) update EAPI to latest version, now it's 5
b) update to python-r1 [1]
c) upstream release p4, possible to upgrade to that version?
d) cd, cp, rm, cat, sed, emake in src_compile() -> need "|| die"
e) need metadata.xml. eg, for IUSE descriptions and other stuff

[1] http://www.gentoo.org/proj/en/Python/python-r1/dev-guide.xml
Comment 18 Timo Eissler 2014-06-30 18:59:50 UTC
Created attachment 380002 [details]
metadata.xml
Comment 19 Timo Eissler 2014-06-30 19:00:19 UTC
Created attachment 380006 [details]
check_mk-1.2.4_p4.ebuild
Comment 20 Timo Eissler 2014-07-06 14:01:34 UTC
Created attachment 380304 [details]
check_mk-1.2.4_p5.ebuild

version bump
Comment 21 Yixun Lan gentoo-dev 2014-07-09 08:44:12 UTC
>>> Verifying ebuild manifests
>>> Emerging (1 of 3) www-apache/mod_python-3.3.1-r1::gentoo
>>> Installing (1 of 3) www-apache/mod_python-3.3.1-r1
>>> Emerging (2 of 3) net-analyzer/nagios-core-3.3.1::gentoo
>>> Installing (2 of 3) net-analyzer/nagios-core-3.3.1
>>> Emerging (3 of 3) net-analyzer/check_mk-1.2.4_p5::gentoo
>>> Failed to emerge net-analyzer/check_mk-1.2.4_p5, Log file:
>>>  '/var/tmp/portage/net-analyzer/check_mk-1.2.4_p5/temp/build.log'
 * Package:    net-analyzer/check_mk-1.2.4_p5
 * Repository: gentoo
 * Maintainer: morlix@morlix.de proxy-maint@gentoo.org
 * USE:        abi_x86_64 amd64 elibc_glibc kernel_linux userland_GNU
 * FEATURES:   fakeroot preserve-libs sandbox userpriv usersandbox
 * Applying check_mk-1.2.4p3-setup.sh.patch ...
 [ ok ]
/bin/sh: line 0: type: diet: not found
WARNING: your binary is not portable. Please compile 
with dietlibc on 32-Bit to get portable statically 
linked binary.

Compiling with normal gcc...
Fine. Typing 'make install' as root now will install into /usr/bin
install: cannot stat ‘etc/icinga/check_mk.d/check_mk_templates.cfg’: No such file or directory
!!! doins: etc/icinga/check_mk.d/check_mk_templates.cfg does not exist
 * ERROR: net-analyzer/check_mk-1.2.4_p5::gentoo failed (install phase):
 *   doins failed
 * 
 * If you need support, post the output of `emerge --info '=net-analyzer/check_mk-1.2.4_p5::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=net-analyzer/check_mk-1.2.4_p5::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/net-analyzer/check_mk-1.2.4_p5/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-analyzer/check_mk-1.2.4_p5/temp/environment'.
 * Working directory: '/var/tmp/portage/net-analyzer/check_mk-1.2.4_p5/work/check_mk-1.2.4p5'
 * S: '/var/tmp/portage/net-analyzer/check_mk-1.2.4_p5/work/check_mk-1.2.4p5'
 * QA Notice: file does not exist:



# emerge -pv net-analyzer/check_mk                                                                  

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] net-analyzer/check_mk-1.2.4_p5  USE="-agent-only -apache_status -dmi_sysinfo -livestatus -logwatch -mysql -nfsexports -oracle -postgres -smart -wato -xinetd -zypper" 0 kB
Comment 22 Yixun Lan gentoo-dev 2014-07-09 09:12:29 UTC
Created attachment 380474 [details, diff]
patch against 1.2.4_p5

1) converge "has_version net-analyzer/nagios-core" usage
 I noticed for "nagios" user, some path using "/var" while "icinga" use "/var/lib", can we centralize this? (eg, ${nagpipe, check_result_path, nagios_status_file, rrd_path}

2) livecheck USE is not used in this ebuild?
Comment 23 Timo Eissler 2014-07-15 17:20:17 UTC
Created attachment 380764 [details]
check_mk-1.2.4_p5-r1.ebuild

Sorry for the late answer.

1) I converged the ones where it is possible, but the ones you already mentioned can't be converged because these are the paths the icinga and nagios ebuild developers use

2) livecheck support has beend removed from upstream
Comment 24 Yixun Lan gentoo-dev 2014-07-17 23:10:54 UTC
+*check_mk-1.2.4_p5 (17 Jul 2014)
+
+  17 Jul 2014; Yixun Lan <dlan@gentoo.org> +check_mk-1.2.4_p5.ebuild,
+  +files/check_mk-1.2.4p3-setup.sh.patch, +metadata.xml:
+  bug 447920, initial version added, proxy for @Timo Eissler


thanks for contributing.