Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 447862 - kde-base/plasma-desktop resource leak into x11-base/xorg-server
Summary: kde-base/plasma-desktop resource leak into x11-base/xorg-server
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL: https://bugs.kde.org/show_bug.cgi?id=...
Whiteboard: fixed in 4.10.4
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-19 18:25 UTC by Till Schäfer
Modified: 2013-07-22 22:41 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch for pixmap leak (plasma-workspace_4.10.4-r1_pixmapleak.patch,1.46 KB, patch)
2013-07-03 00:47 UTC, BobbyK
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Till Schäfer 2012-12-19 18:25:46 UTC
i am using x11-drivers/xf86-video-ati-7.0.0 with x11-base/xorg-server-1.13.0-r1 on a server with a ati ES1000 graphics card. when running the server for a month or so it becomes unresponsive because the X memory usage goes up to several gigabytes and uses 100% CPU. 

please give me advice in what additional information you need.


Reproducible: Always




# emerge --info
Portage 2.2.0_alpha149 (default/linux/amd64/10.0, gcc-4.5.4, glibc-2.15-r3, 3.0.35-gentoo x86_64)
=================================================================
System uname: Linux-3.0.35-gentoo-x86_64-Intel-R-_Xeon-R-_CPU_E5335_@_2.00GHz-with-gentoo-2.1
Timestamp of tree: Sun, 16 Dec 2012 15:00:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=core2 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps=y --autounmask-write --jobs --load-average=5.0"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="acl amd64 bash-completion berkdb bzip2 cli consolekit cracklib crypt cups cxx dbus dri fortran gdbm glib glibc gpm iconv ipv4 ipv6 mmx mmxext modules mudflap multilib ncurses nls nptl openmp pam pcre policykit pppd readline session sse sse2 sse3 sse4_1 ssl ssse3 syslog tcpd threads udev unicode vim-syntax zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


# lspci
00:00.0 Host bridge: Intel Corporation 5000P Chipset Memory Controller Hub (rev 92)
00:02.0 PCI bridge: Intel Corporation 5000 Series Chipset PCI Express x4 Port 2 (rev 92)
00:03.0 PCI bridge: Intel Corporation 5000 Series Chipset PCI Express x4 Port 3 (rev 92)
00:04.0 PCI bridge: Intel Corporation 5000 Series Chipset PCI Express x4 Port 4 (rev 92)
00:05.0 PCI bridge: Intel Corporation 5000 Series Chipset PCI Express x4 Port 5 (rev 92)
00:06.0 PCI bridge: Intel Corporation 5000 Series Chipset PCI Express x8 Port 6-7 (rev 92)
00:07.0 PCI bridge: Intel Corporation 5000 Series Chipset PCI Express x4 Port 7 (rev 92)
00:10.0 Host bridge: Intel Corporation 5000 Series Chipset FSB Registers (rev 92)
00:10.1 Host bridge: Intel Corporation 5000 Series Chipset FSB Registers (rev 92)
00:10.2 Host bridge: Intel Corporation 5000 Series Chipset FSB Registers (rev 92)
00:11.0 Host bridge: Intel Corporation 5000 Series Chipset Reserved Registers (rev 92)
00:13.0 Host bridge: Intel Corporation 5000 Series Chipset Reserved Registers (rev 92)
00:15.0 Host bridge: Intel Corporation 5000 Series Chipset FBD Registers (rev 92)
00:16.0 Host bridge: Intel Corporation 5000 Series Chipset FBD Registers (rev 92)
00:1c.0 PCI bridge: Intel Corporation 631xESB/632xESB/3100 Chipset PCI Express Root Port 1 (rev 09)
00:1d.0 USB controller: Intel Corporation 631xESB/632xESB/3100 Chipset UHCI USB Controller #1 (rev 09)
00:1d.1 USB controller: Intel Corporation 631xESB/632xESB/3100 Chipset UHCI USB Controller #2 (rev 09)
00:1d.2 USB controller: Intel Corporation 631xESB/632xESB/3100 Chipset UHCI USB Controller #3 (rev 09)
00:1d.3 USB controller: Intel Corporation 631xESB/632xESB/3100 Chipset UHCI USB Controller #4 (rev 09)
00:1d.7 USB controller: Intel Corporation 631xESB/632xESB/3100 Chipset EHCI USB2 Controller (rev 09)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev d9)
00:1f.0 ISA bridge: Intel Corporation 631xESB/632xESB/3100 Chipset LPC Interface Controller (rev 09)
00:1f.2 IDE interface: Intel Corporation 631xESB/632xESB/3100 Chipset SATA IDE Controller (rev 09)
02:00.0 PCI bridge: Broadcom EPB PCI-Express to PCI-X Bridge (rev c3)
03:00.0 Ethernet controller: Broadcom Corporation NetXtreme II BCM5708 Gigabit Ethernet (rev 12)
04:00.0 PCI bridge: Intel Corporation 6311ESB/6321ESB PCI Express Upstream Port (rev 01)
04:00.3 PCI bridge: Intel Corporation 6311ESB/6321ESB PCI Express to PCI-X Bridge (rev 01)
05:00.0 PCI bridge: Intel Corporation 6311ESB/6321ESB PCI Express Downstream Port E1 (rev 01)
05:01.0 PCI bridge: Intel Corporation 6311ESB/6321ESB PCI Express Downstream Port E2 (rev 01)
0a:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5721 Gigabit Ethernet PCI Express (rev 21)
0b:00.0 PCI bridge: Intel Corporation 6702PXH PCI Express-to-PCI Bridge A (rev 09)
0c:08.0 SCSI storage controller: LSI Logic / Symbios Logic SAS1068 PCI-X Fusion-MPT SAS (rev 01)
0e:0d.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI ES1000 (rev 02)
Comment 1 Chí-Thanh Christopher Nguyễn gentoo-dev 2012-12-20 19:24:27 UTC
You can check with xrestop whether an application causes X server memory usage to increase so much.

If not, it would be good if you report this upstream at https://bugs.freedesktop.org/ (if no report already exits) and provide the link here.
Comment 2 BobbyK 2012-12-25 17:28:21 UTC
Beware of xrestop and xorg-server 1.13:

https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/1060059

...
Comment 3 BobbyK 2012-12-25 17:31:50 UTC
(In reply to comment #2)
> Beware of xrestop and xorg-server 1.13:
> 
> https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/1060059
> 
> ...

Apologies

https://bugs.freedesktop.org/show_bug.cgi?id=57448

is a little more useful.
Comment 4 Chí-Thanh Christopher Nguyễn gentoo-dev 2012-12-25 17:32:59 UTC
The xrestop crash issue is fixed in 1.13.1.
Comment 5 Till Schäfer 2013-01-03 13:26:06 UTC
thanks for the xrestop info. I am still on this, but it is a productive system and therefore it could take some time until i am able to investigate further.
Comment 6 Till Schäfer 2013-04-16 13:02:58 UTC
i narrowed it durther down and found a kde bug https://bugs.kde.org/show_bug.cgi?id=314919 which was the cause of this memroy leak. 

therefore iam closing this bug.
Comment 7 Chí-Thanh Christopher Nguyễn gentoo-dev 2013-04-16 13:07:13 UTC
It's still a valid bug, just not in xorg-server.
Comment 8 BobbyK 2013-07-03 00:47:40 UTC
Created attachment 352492 [details, diff]
Patch for pixmap leak

Upsteam have committed a fix for https://bugs.kde.org/show_bug.cgi?id=314919.  The attached is built from this and appears to work (at least it did when I placed it in /etc/portage/patches/kde-base/plasma-workspace-4.10.4-r1/ and re-emerge plasma-workspace).
Comment 9 Michael Palimaka (kensington) gentoo-dev 2013-07-03 07:42:49 UTC
Thanks, fixed in CVS.

+  03 Jul 2013; Michael Palimaka <kensington@gentoo.org>
+  +files/plasma-workspace-4.10.5-leak.patch, +plasma-workspace-4.10.5-r1.ebuild:
+  Backport patch from upstream to solve a memory leak issue, wrt bug #447862.
Comment 10 Johannes Huber gentoo-dev 2013-07-03 20:49:13 UTC
One upstream comment says its not totaly fixed.
Comment 11 BobbyK 2013-07-04 02:20:12 UTC
(In reply to Johannes Huber from comment #10)
> One upstream comment says its not totaly fixed.

Saw that, though I suspect that there are multiple leaks, and while the one identified in the bug "plasma-desktop is leaking memory in X if some icon in system tray is changing" is fixed, some others remain.  To my mind an incomplete fix is better than no fix at all, especially as the incomplete fix addresses issues that arise from merely running an app out of the system tray.
Comment 12 Andreas K. Hüttel gentoo-dev 2013-07-22 22:41:21 UTC
Well it makes not much sense to keep this open unless we get more specific. 

If you find another specific issue please open a new bug.

(This is a bug about as specific as "The Linux kernel needs some CPU time.")