Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 447746 - [PATCH] media-libs/mlt-0.8.2 builds with -DARCH_X86_64 even though CHOST=i686-pc-linux-gnu and fails - composite_line_yuv_sse2_simple.c:29:5: error: can't find a register in class ‘GENERAL_REGS’ while reloading ‘asm’
Summary: [PATCH] media-libs/mlt-0.8.2 builds with -DARCH_X86_64 even though CHOST=i686...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords: PATCH
: 516776 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-12-18 17:14 UTC by Matěj Laitl
Modified: 2016-01-01 15:26 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,92.66 KB, text/plain)
2012-12-18 17:14 UTC, Matěj Laitl
Details
build.log (file_447746.txt,62.38 KB, text/plain)
2014-08-11 21:42 UTC, Luis Ferreira
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matěj Laitl 2012-12-18 17:14:55 UTC
Created attachment 332672 [details]
build.log

Hi,
mlt-0.8.2 is another package which doesn's seem to respect passed host and does its own auto-detection. My hardware is x86_64 capable and kernel is x86_64, but all userspace is i686.

emerge --info '=media-libs/mlt-0.8.2'
Portage 2.2.0_alpha149 (default/linux/x86/10.0/desktop/kde, gcc-4.5.4, glibc-2.15-r3, 3.4.11-gentoo x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.4.11-gentoo-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T7300_@_2.00GHz-with-gentoo-2.1
Timestamp of tree: Mon, 17 Dec 2012 18:30:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo local strohel java-overlay hasufell gamerlay
Installed sets: @gentoo-sources-3.X.y
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA dlj-1.1 Oracle-BCLA-JavaSE skype-eula AdobeFlash-10.3 cadsoft googleearth"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=core2 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0 /usr/share/themes/oxygen-gtk/gtk-3.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=core2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask-write"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="http://ftp.fi.muni.cz/pub/linux/gentoo/"
LANG="cs_CZ.utf8"
LC_ALL="cs_CZ.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /var/lib/layman/strohel /var/lib/layman/java-overlay /var/lib/layman/hasufell /var/lib/layman/gamerlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amr apng avahi bash-completion berkdb bluetooth branding bzip2 cairo caps cdda cddb cdr cli clucene consolekit cracklib crypt css cups curl cxx dbus declarative devil dhcpcd dri dts dvd dvdr embedded emboss enca encode exif fam fat ffmpeg firefox flac fontconfig fortran g3dvl games gdbm gif git gpm gstreamer gtk iconv id3tag inotify ipod java jpeg kde kipi lame lastfm lcms libass libnotify libsamplerate lm_sensors lzma lzo mad matroska mikmod minizip mjpeg mmap mmx mmxext mng mod modemmanager modules mp3 mp4 mpeg mudflap musepack musicbrainz ncurses network networkmanager nls nptl nsplugin ntfs ofa ogg opengl openmp pam pango pch pcre pdf phonon plasma png policykit ppds pppd pulseaudio qt3support qt4 quicktime readline rtc rtsp samba scanner schroedinger sdl semantic-desktop session smp sna sndfile snmp spell sqlite sse sse2 sse3 ssl ssse3 startup-notification stream svg syslog taglib theora threads thumbnail tiff truetype udev udisks unicode upower usb vorbis wifi win32codecs wmf wxwidgets x264 x86 xcb xcomposite xinerama xml xscreensaver xv xvid xvmc zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="cs en en_GB" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="i965 intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

emerge -pqv '=media-libs/mlt-0.8.2'
[ebuild     U ] media-libs/mlt-0.8.2 [0.7.8] USE="ffmpeg gtk kde libsamplerate melt mmx qt4 quicktime sdl sse sse2 vorbis xml -compressed-lumas -debug -dv -frei0r -jack -lua -python -rtaudio -ruby -swfdec -vdpau -xine"
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2012-12-18 17:20:08 UTC
Shouldn't you be setting CTARGET in this case?
Comment 2 Matěj Laitl 2012-12-18 17:25:16 UTC
(In reply to comment #1)
> Shouldn't you be setting CTARGET in this case?

No. This is not cross-compiling, this is building i686 binary using i686 compiler on a i686 system. My arch is x86. Everything's building fine for years except from a couple of packages that like to do their own naive automagic probing and which have been fixed in the mean time.
Comment 3 Matěj Laitl 2012-12-23 16:36:31 UTC
Following ebuild patch solves the issue for me. (it should be perhaps applied to all mlt vetsions newer that 0.8.2)

--- a/mlt-0.8.2.ebuild  2012-11-20 21:31:20.000000000 +0100
+++ b/mlt-0.8.2.ebuild  2012-12-23 17:30:19.926964152 +0100
@@ -77,9 +77,13 @@
 
 src_configure() {
        tc-export CC CXX
+       local targetarch=${CTARGET:-${CHOST}}
+       targetarch=${targetarch%%-*}
 
+       # pass target-arch to circuvent autodetection and prevent bug 447746
        local myconf="--enable-gpl
                --enable-motion-est
+               --target-arch=${targetarch}
                $(use_enable debug)
                $(use_enable dv)
                $(use_enable sse)
Comment 4 Matěj Laitl 2012-12-23 16:39:35 UTC
Just to note, the root problem is mlt's configure calling $(uname -m) to determine target architecture (well, the variable is motly unused, only used to set boolean $amd64), which is not a good way a determine target arch especially when Gentoo already passes --host=i686-pc-linux-gnu to it.
Comment 5 Luke-Jr 2012-12-24 10:27:50 UTC
I can confirm this bug. It should probably be reported upstream for long-term fixing.
Comment 6 Alexis Ballier gentoo-dev 2013-07-12 13:06:30 UTC
should be fixed in 0.9.0; i dont think it should be reported upstream since there's not much they can do if we dont inform the build system what to build for, which should now be correctly done.
Comment 7 Luke-Jr 2013-09-05 14:50:38 UTC
This is still broken for 0.8.2 stable...
Comment 8 Jeroen Roovers (RETIRED) gentoo-dev 2014-07-10 00:20:47 UTC
*** Bug 516776 has been marked as a duplicate of this bug. ***
Comment 9 Luis Ferreira 2014-08-11 21:42:12 UTC
Created attachment 382692 [details]
build.log

emerge --info '=media-libs/mlt-0.8.2::gentoo'
Portage 2.2.8-r1 (default/linux/amd64/13.0/no-multilib, gcc-4.7.3, glibc-2.19-r1, 3.14.14-gentoo x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.14.14-gentoo-x86_64-Intel-R-_Core-TM-_i7_CPU_860_@_2.80GHz-with-gentoo-2.2
KiB Mem:     6084964 total,    825416 free
KiB Swap:    6144824 total,   6144664 free
Timestamp of tree: Mon, 11 Aug 2014 20:45:01 +0000
ld GNU ld (Gentoo 2.23.2 p1.0) 2.23.2
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.6.8-r3, 2.7.7, 3.2.5-r6, 3.3.5-r1
dev-util/cmake:           2.8.12.2-r1
dev-util/pkgconfig:       0.28-r1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.4_p6-r1, 1.7.9-r2, 1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.6, 1.12.6, 1.13.4
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.6.4, 4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.13 (virtual/os-headers)
sys-libs/glibc:           2.19-r1
Repositories: gentoo betelgeuse betagarden sunrise zugaina science gentoo-el quarks_gentoo_hardened_overlay anyc-overlay seden g-ctan House
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.dei.uc.pt/pub/linux/gentoo/ http://cesium.di.uminho.pt/pub/gentoo/ http://ftp.dei.uc.pt/pub/linux/gentoo/ ftp://gentoo.imj.fr/pub/gentoo/ http://130.59.10.35/ftp/mirror/gentoo/ ftp://cesium.di.uminho.pt/pub/gentoo/ "
LANG="pt_PT.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9 -l9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/betelgeuse /var/lib/layman/betagarden /var/lib/layman/sunrise /var/lib/layman/zugaina /var/lib/layman/science /var/lib/layman/gentoo-el /var/lib/layman/quarks /var/lib/layman/anyc /var/lib/layman/seden /usr/local/portage /var/lib/layman"
SYNC="rsync://ftp.rnl.ist.utl.pt/gentoo-portage"
USE="R X a52 aac aacplus aalib acl acpi action_modeswitch addressbook adns adplug aften akonadi alsa amd64 amr analitza apbs apng archive ares arpack aspell ass atmo attica audiofile autoipd autotrace avahi avcodec avformat avx bash-completion berkdb binfilter bluetooth bs2b bzip2 cairo cdda cddax cddb cdio cleartype cli clucene consolekit context corefonts cover cpudetection cracklib crypt csharp cue cups curl cxx dap dbi dbus dc1394 declarative demosaic designer-plugin detex device-mapper dirac djvu double-precision dri dts dv dvd dvi2tty dvipdfm ebook eigen embedded enca encode epspdf equalizer exif expat expoblending extra faac faad facedetect fam fame fbosd ffmpeg fftw fits flac flash fluidsynth fontconfig fortran fortran2003 fortran95 fpx frei0r ftdi ftp fuse g3dvl games gcj gd gdbm geoip geolocation geos gflags gfortran gif gimp gmath gme gml gmxmopac7 gnuplot gnutls gpac gphoto2 gps graphics graphite graphviz grass growl gsl gstreamer gtk gudev guile hdf5 hdri hpcups humanities hunspell hwdb ical iconv icu id3tag idn ieee1394 imagemagick indi inkjar inotify int64 introspection ipod ipv6 jack jadetex java javascript jbig jemalloc jpeg jpeg2k kate kde keymap kig-scripting kipi kpathsea ladspa lame lapack lash lastfm latex latex3 lcms lensfun lfd libass libcaca libnl libnotify libsamplerate libssh2 libsysfs libtar libtiger libv4l libv4l2 libvisual live lm_sensors lorcon lqr lua luatex lyrics lzma lzo mad matroska mdnsresponder-compat melt metapost metis midi minizip mjpeg mms mmx mmxext mng modplug modules mopac7 motif mp3 mp3tunes mp4 mpeg mpg123 mpi mplayer mpqc mpris mtp multimedia musepack music musicbrainz mysql ncurses netcdf network networking nlpsolver nls nptl nsplugin nss numpy nuv ocr octave odbc ogdi ogg okular omega omxil opal openal openbabel opencl openexr opengl openipmi openmp opus pam pango panorama pcre pdf pdfannotextractor pdfimport perl pgf phonon plasma plotutils png policykit portaudio postproc postscript ppds projectm protobuf pstricks publishers pulseaudio python q32 q64 qimageblitz qt3support qt4 quad quicktime rar raw readline real realtime redeyes romio rpc rtf rtmp rtsp ruby rups sasl scale0tilt scanner schroedinger science scrobbler sdl sdl-image semantic-desktop session sftp shaders shine shout sid sift skins smi smime smp sms smtp sndfile snmp soundtouch sox spatialite speex spell sql sqlite sse sse2 sse3 sse4 sse4a ssl ssse3 subtitles subversion svg swig switcher symlink szip taglib tbb tcpd tesseract tex4ht texi2html tga theora thin-splines threads thumbnail tidy tiff tk toolame tordns truetype twolame type3 udev unicode unwind upnp usb v4l v4l2 vaapi vamp vcdinfo vcdx vdpau video videoslideshow vkontakte vlm vmd vorbis vpx wavpack webkit webp wma wma-fixed wmf wxwidgets x264 xanim xcomposite xetex xindy xine xml xmp xosd xpm xvid xvmc yaz zeroconf zip zlib zvbi" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="sony_dscf55" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CURL_SSL="openssl" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev wacom keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="pt en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5 php5-3 php5-2" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19" USERLAND="GNU" VIDEO_CARDS="vesa nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

media-libs/mlt-0.8.2 was built with the following:
USE="dv ffmpeg frei0r gtk jack kde libsamplerate lua melt mmx python qt4 quicktime ruby sdl sse sse2 vdpau vorbis xine xml -compressed-lumas -debug -rtaudio -swfdec"
Comment 10 Michael Palimaka (kensington) gentoo-dev 2016-01-01 15:26:12 UTC
0.9.0 is stable now