Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 447694 - media-sound/pulseaudio-2.99.3 USE=-system-wide - * Starting D-BUS system messagebus ... Unknown username "pulse" in message bus configuration file
Summary: media-sound/pulseaudio-2.99.3 USE=-system-wide - * Starting D-BUS system mess...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
: 481504 (view as bug list)
Depends on:
Reported: 2012-12-18 10:30 UTC by Francesco Turco
Modified: 2016-05-21 13:32 UTC (History)
10 users (show)

See Also:
Package list:
Runtime testing required: ---

Updated ebuild to fix the non-system-wide dbus usage (pulseaudio-4.0-r1.ebuild,8.41 KB, text/plain)
2014-01-01 20:53 UTC, Oldrich Jedlicka
Patch to remove installation of dbus configuration in non-system-wide mode (pulseaudio-4.0-non-system-wide.patch,429 bytes, patch)
2014-01-01 20:54 UTC, Oldrich Jedlicka
Details | Diff
patch of the original ebuild - to see the changes (pulseaudio-4.0-r1.ebuild.patch,811 bytes, patch)
2014-01-01 20:57 UTC, Oldrich Jedlicka
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Francesco Turco 2012-12-18 10:30:37 UTC
At boot time I get the following error message when the dbus init script starts:

* Starting D-BUS system messagebus ...
Unknown username "pulse" in message bus configuration file

It seems this is because of file /etc/dbus-1/system.d/pulseaudio-system.conf, belonging to the pulseaudio package. In fact if I remove it, the warning message at boot vanishes. A comment in this file says:

> System-wide PulseAudio runs as 'pulse' user. This fragment is not necessary for user PulseAudio instances.

I know very little about pulseaudio, and I don't know what system-wide means in this case, but it seems that since version 2.99.3 pulseaudio ebuild doesn't create the "pulse" user if the system-wide USE flag is not set. On my system, it is not set by default. So as far as I understand when the USE system-wide is not set, pulseaudio should not install the pulseaudio-system.conf file.

I noticed today pulseaudio-3.0 ebuild has been released. I've not tried it since my next sync is scheduled for Saturday 22, but if you want me to try that version I'll do that.

Reproducible: Always

$ emerge -pv pulseaudio dbus

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] sys-apps/dbus-1.6.8-r1  USE="X -debug -doc (-selinux) -static-libs -systemd {-test}" 0 kB
[ebuild   R    ] media-sound/pulseaudio-2.99.3  USE="X alsa asyncns bluetooth caps dbus gdbm glib gnome gtk orc ssl tcpd udev webrtc-aec -avahi -doc -equalizer -ipv6 -jack -libsamplerate -lirc (-oss) -realtime (-system-wide) (-systemd) {-test} -xen" 0 kB

Total: 2 packages (2 reinstalls), Size of downloads: 0 kB


$ emerge --info
Portage (default/linux/amd64/10.0/desktop/gnome, gcc-4.6.3, glibc-2.16.0, 3.7.0-gentoo x86_64)
System uname: Linux-3.7.0-gentoo-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T7250_@_2.00GHz-with-gentoo-2.2
Timestamp of tree: Sun, 16 Dec 2012 14:15:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p39-r1
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.6
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.5
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo x-portage
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-O2 -pipe -march=core2"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=core2"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli colord consolekit cracklib crypt cxx dbus dri dts dvd dvdr eds emboss encode evo exif fam firefox flac gdbm gif gnome gnome-keyring gnome-online-accounts gstreamer gtk iconv ieee1394 jpeg lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg mudflap multilib nautilus ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds pppd pulseaudio qt3support readline sdl session socialweb sse sse2 sse3 ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis webkit x264 xcb xml xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" QEMU_SOFTMMU_TARGETS="x86_64 i386" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 1 Balint SZENTE 2013-01-05 17:09:14 UTC
The same happens for me as well with media-sound/pulseaudio-3.0

The /etc/dbus-1/system.d/pulseaudio-system.conf file should not be installed with USE="-system-wide" according to the comment in the .conf file.
Comment 2 Oleh 2013-06-13 03:01:22 UTC
the build system is somehow broken, pulse, pulse-access groups supposed to be created only if system-wide flag used. This flag is profile masked, despite this /etc/dbus-1/system.d/pulseaudio-system.conf is installed. Removing 'if use systemd-wide' in ebuild, makes dbus behave normally. Obviosuly it looks like wrong fix.
Comment 3 Coacher 2013-08-18 01:35:37 UTC
*** Bug 481504 has been marked as a duplicate of this bug. ***
Comment 4 Coacher 2013-08-18 01:37:16 UTC
Still an issue with pulseaudio-4.0. Devs please look into this, it should be trivial to fix.
Comment 5 Oldrich Jedlicka 2014-01-01 20:53:25 UTC
Created attachment 366714 [details]
Updated ebuild to fix the non-system-wide dbus usage
Comment 6 Oldrich Jedlicka 2014-01-01 20:54:21 UTC
Created attachment 366716 [details, diff]
Patch to remove installation of dbus configuration in non-system-wide mode
Comment 7 Oldrich Jedlicka 2014-01-01 20:57:13 UTC
Created attachment 366718 [details, diff]
patch of the original ebuild - to see the changes
Comment 8 Oldrich Jedlicka 2014-01-01 21:01:46 UTC
I faced the same problem, so I tried to provide a fix - see attachments. I used the latest multilib ebuild and tested it on amd64 (only 64bit version - not multilib actually).
Comment 9 Vikraman (RETIRED) gentoo-dev 2014-01-22 22:24:49 UTC
use system-wide || rm "${ED}"/etc/dbus-1/system.d/pulseaudio-system.conf

If nobody objects, I will commit it.
Comment 10 Oldrich Jedlicka 2014-01-23 20:29:26 UTC
(In reply to Vikraman from comment #9)
> use system-wide || rm "${ED}"/etc/dbus-1/system.d/pulseaudio-system.conf

That looks good.

Please also remove line "# Create the state directory" and the following one (see my patch) - it just does nothing and is only confusing (remainder from previous ebuild versions).
Comment 11 Oleh 2014-02-16 13:46:18 UTC
any updates on this?
Comment 12 Pacho Ramos gentoo-dev 2014-02-16 21:20:53 UTC
Fixed in 4.99.4
Comment 13 Oleh 2014-02-16 23:12:42 UTC
sorry, but this only 4.99.4 version, which is not fixed for older (and stable) ebuilds, this bug is still valid for these.
Comment 14 Alexandre Rostovtsev (RETIRED) gentoo-dev 2014-02-21 14:58:21 UTC
(In reply to Oleg from comment #13)
> sorry, but this only 4.99.4 version, which is not fixed for older (and
> stable) ebuilds, this bug is still valid for these.

Of course. Like almost all bugfixes in Gentoo. The issue gets fixed in the latest ~arch ebuild, and some time later the latest ~arch ebuild will be marked as stable.

If you want the latest bugfixes without waiting - and the latest bugs too! - then set unstable ACCEPT_KEYWORDS in your make.conf
Comment 15 Oleh 2014-02-21 15:16:29 UTC
Sorry, this is unacceptable policy, also there is no such policy in Gentoo that forcing user to switch to unstable branch, just because it's fixed only for unstable ebuilds. Stable pusleaudio and stable dbus is affected by this bug and it's clear fix for these.
Comment 16 Alexandre Rostovtsev (RETIRED) gentoo-dev 2014-02-21 15:33:57 UTC
(In reply to Oleg from comment #15)
> Sorry, this is unacceptable policy, also there is no such policy in Gentoo
> that forcing user to switch to unstable branch, just because it's fixed only
> for unstable ebuilds. Stable pusleaudio and stable dbus is affected by this
> bug and it's clear fix for these.

Nobody is forcing you to switch to unstable. But there *is* a policy that stable ebuilds normally get only cosmetic/stylistic changes (and preferably even those are kept to a minimum). Bugs are fixed in ~arch. Lots of ~arch users immediately install the new ebuild, and if the bugfix was wrong or made things worse, they will report the problem. Some days or weeks later, when the maintainer is confident that the time is right, he asks for an unstable ebuild with the fix to be stabilized, and the stabilization process is handled by arch teams. This has always been the process. In fact, this is reason why stable and unstable keywords exist.

I apologize for delivering this lecture, but since you seem to be a developer for a Gentoo-derived distro, I think it's important to clear up any misconceptions you might have about the Gentoo development process works.
Comment 17 Alexandre Rostovtsev (RETIRED) gentoo-dev 2014-02-21 15:41:50 UTC
(In reply to Alexandre Rostovtsev from comment #16)
> stable ebuilds normally get only cosmetic/stylistic changes

Better wording: changes which clearly will not affect what gets installed/modified on the user's filesystem.
Comment 18 Oleh 2014-02-21 16:51:44 UTC
users don't need any lectures, i know what Gentoo policy about stable is, and it's horribly wrong policy. No commentso this. Should I mention that Gentoo is deliberately cheating on system-wide usage, when it's clearly said NOT to use by upstream. If Gentoo does so, please, make it working on ALL ebuilds.