Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 447408 - sys-devel/llvm-3.1r2 - X86ELFWriterInfo.cpp:85:1: interner Compiler-Fehler: Speicherzugriffsfehler
Summary: sys-devel/llvm-3.1r2 - X86ELFWriterInfo.cpp:85:1: interner Compiler-Fehler: S...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Bernard Cafarelli
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-16 01:54 UTC by piotr5
Modified: 2014-01-30 19:18 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log.bz2 (build.log.bz2,25.59 KB, application/x-bzip)
2012-12-16 01:54 UTC, piotr5
Details

Note You need to log in before you can comment on or make changes to this bug.
Description piotr5 2012-12-16 01:54:50 UTC
Created attachment 332432 [details]
build.log.bz2

everytime I try to compile xorg on my dell duo (atom processor) using stage3-x32-x32-20121210.tar.bz2 with x32 eselect-ed the compilation fails with a memory-access error while compiling X86ELFWriterInfo.cpp:85:1 in virtual long int llvm::X86ELFWriterInfo::getDefaultAddendForRelTy(unsigned int, long int) const
attached build-log

-pqv says
[ebuild  N    ] sys-devel/llvm-3.1-r2  USE="libffi -debug -gold -multitarget -ocaml {-test} -udis86 -vim-syntax"

output of --info
Portage 2.1.11.31 (default/linux/amd64/10.0/x32, gcc-4.7.1, glibc-2.16.0, 3.5.7-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.5.7-gentoo-x86_64-Intel-R-_Atom-TM-_CPU_N550_@_1.50GHz-with-gentoo-2.1
Timestamp of tree: Sat, 15 Dec 2012 13:15:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.68
sys-devel/automake:       1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.7.1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnux32"
CFLAGS="-march=native -O2"
CHOST="x86_64-pc-linux-gnux32"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs collision-protect config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://gentoo.inode.at/source http://gentoo.inode.at http://gentoo.lagis.at/ http://distfiles.gentoo.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LANG="de_DE.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync1.at.gentoo.org/gentoo-portage"
USE="X acl acpi alsa amd64 apng berkdb bindist bluetooth bzip2 cli cracklib crypt cryptsetup cups cxx dbus dri fortran gdbm gnome gnutls gpm gstreamer gtk iconv introspection ipv6 jpeg libnotify lm_sensors mclib mmx modules mp3 mudflap multilib ncurses networkmanager nls nptl odbc offensive openmp pam pcre png policykit pppd pulseaudio readline sensord session spell sse sse2 sse3 ssl ssse3 tcpd truetype udev unicode usb wifi xcomposite zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics mutouch" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_GB de pl ru" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, MAKEOPTS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 piotr5 2012-12-17 03:50:12 UTC
reported upstream at http://gcc.gnu.org/bugzilla/show_bug.cgi?id=55714
Comment 2 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2012-12-17 07:01:52 UTC
Please add an English build log.

Use `LC_ALL=C emerge -1 =sys-devel/llvm-3.1-r2` to produce one.
Comment 3 Jeroen Roovers gentoo-dev 2012-12-17 20:20:44 UTC
Looks like you ran out of RAM.
Comment 4 piotr5 2012-12-22 12:30:47 UTC
no, it isn't a problem with memory. debugging clearly shows the pointer is NULL and therefore pagefault. upstream they claim it's a duplicate of the reopened http://gcc.gnu.org/bugzilla/show_bug.cgi?id=43631 and is only a problem when using CXXFLAGS="-march=atom -O2" and therefore not as critical as I thought. and I've found a workaround: forcing -Os is enough, I hope.
Comment 5 Bernard Cafarelli gentoo-dev 2013-06-10 22:11:04 UTC
Looks like this was finally fixed?
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=43631#c25
Comment 6 Bernard Cafarelli gentoo-dev 2014-01-30 19:18:18 UTC
Marking fixed as per upstream bug