Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 447356 - app-emulation/virtualbox-modules-4.2.4 with kernel 3.7 - modprobe: FATAL: Error inserting vboxdrv (/lib/modules/3.7.0-gentoo/misc/vboxdrv.ko): Required key not available
Summary: app-emulation/virtualbox-modules-4.2.4 with kernel 3.7 - modprobe: FATAL: Err...
Status: RESOLVED DUPLICATE of bug 447352
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-15 13:28 UTC by Stefan Trenker
Modified: 2013-10-03 19:49 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Trenker 2012-12-15 13:28:46 UTC
app-emulation/virtualbox-modules-4.2.4 fail to load on 3.7 kernel with

CONFIG_MODULE_SIG=y
CONFIG_MODULE_SIG_FORCE=y

gucky linux # modprobe vboxdrv 
FATAL: Error inserting vboxdrv (/lib/modules/3.7.0-gentoo/misc/vboxdrv.ko): Required key not available


this happens with other ebuilds which create kernel modules as well (see Bug 426406)
Comment 1 Stefan Trenker 2012-12-15 13:30:51 UTC
sorry, I meant bug 447352
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2012-12-23 18:14:33 UTC
This is something I won't be able to test in the near future. Unless someone else is coming up with a sane solution it will take a while until I can take care of this bug.
Comment 3 Sergey Dobrov 2013-02-14 10:01:16 UTC
This is my workaround solution: 

for x in /lib/modules/`uname -r`/misc/vbox*.ko; do sudo perl /usr/src/linux/scripts/sign-file /usr/src/linux/signing_key.priv /usr/src/linux/signing_key.x509 $x; done
Comment 4 Ben Kohler gentoo-dev 2013-10-03 19:49:27 UTC
I don't think there is any reason for a virtualbox-specific bug to remain open here, this issue affects all packages providing external modules and will (hopefully) be fixed at the linux-mod.eclass level.

*** This bug has been marked as a duplicate of bug 447352 ***