Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 447110 - app-misc/livecd-tools - net-setup fails to set up wlan wpa2
Summary: app-misc/livecd-tools - net-setup fails to set up wlan wpa2
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Release Media
Classification: Unclassified
Component: LiveCD/DVD (show other bugs)
Hardware: AMD64 Linux
: Normal trivial (vote)
Assignee: Gentoo LiveCD Package Maintainers
URL:
Whiteboard:
Keywords: PATCH
: 493498 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-12-13 14:22 UTC by Aki Salminen
Modified: 2018-08-21 15:50 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
net-setup-wpa-psk.patch (net-setup-wpa-psk.patch,2.02 KB, patch)
2015-05-29 02:09 UTC, Brian Evans
Details | Diff
net-setup-wpa-psk.patch (net-setup-wpa-psk.patch,4.33 KB, patch)
2015-05-29 02:15 UTC, Brian Evans
Details | Diff
net-setup-wpa-psk.patch (net-setup-wpa-psk.patch,2.30 KB, patch)
2015-05-29 02:25 UTC, Brian Evans
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Aki Salminen 2012-12-13 14:22:30 UTC
Was unable to setup wlan with net-setup. Creating and setting up wpa_supplicant.conf manually worked as usual. Might be good idea that net-setup would set up also wpa or would say that it's only for wep etc.

I would even say that net-setup could be removed as it did create confusion not any solutions or usable output ( for me ).

install-amd64-minimal-20121210.iso
Comment 1 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2013-12-28 04:21:49 UTC
Do we have any tool that can take care of the configuration of wpa?
Comment 2 Fernando (likewhoa) 2013-12-28 18:53:45 UTC
(In reply to Jorge Manuel B. S. Vicetto from comment #1)
> Do we have any tool that can take care of the configuration of wpa?

no we don't and what I decided to do on the livedvd was to use wicd-curses which is pretty straightforward. I guess we should really get wpa* support in net-setup.
Comment 3 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2014-06-26 21:22:00 UTC
*** Bug 493498 has been marked as a duplicate of this bug. ***
Comment 4 Brian Evans Gentoo Infrastructure gentoo-dev 2015-05-29 02:09:30 UTC
Created attachment 404232 [details, diff]
net-setup-wpa-psk.patch

Here is a quick little patch I whipped up to add WPA{,2}-PSK support to net-setup
Comment 5 Brian Evans Gentoo Infrastructure gentoo-dev 2015-05-29 02:15:25 UTC
Created attachment 404234 [details, diff]
net-setup-wpa-psk.patch

Whoops, obvious bugs that the setup is never saved to conf.d/net
Comment 6 Brian Evans Gentoo Infrastructure gentoo-dev 2015-05-29 02:25:16 UTC
Created attachment 404236 [details, diff]
net-setup-wpa-psk.patch

Try #3.. this time i didn't double the patch
Comment 7 Brian Evans Gentoo Infrastructure gentoo-dev 2017-01-10 21:57:51 UTC
Patch committed to livecd-tools git with initial review from jmbsvicetto
Comment 8 Jeroen Roovers gentoo-dev 2017-10-22 18:17:48 UTC
(In reply to Brian Evans from comment #7)
> Patch committed to livecd-tools git with initial review from jmbsvicetto

I see no reference to a commit denoting the fix.
Comment 9 Ben Kohler gentoo-dev 2018-08-21 15:50:49 UTC
wpa2-ready net-setup is shipping on our installcds for a while now