Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 446998 - >=x11-libs/wxGTK-2.9.4.1 unmask request
Summary: >=x11-libs/wxGTK-2.9.4.1 unmask request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo wxWidgets Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 237912 281543 395837 446996
  Show dependency tree
 
Reported: 2012-12-12 13:19 UTC by Nikoli
Modified: 2013-03-16 20:29 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nikoli 2012-12-12 13:19:05 UTC
Please unmask >=x11-libs/wxGTK-2.9.4.1, it is required for aegisub-3.
From upstream announce:
"While this is still officially a development release because some API details are still not frozen, we believe that 2.9.4 can be used in production environment, especially for the new projects for which (small) changes in behaviour since 2.8 are not a problem."

As i understand, unmasking will not break anything  in stable and ~.
Comment 1 Ryan Hill (RETIRED) gentoo-dev 2012-12-30 20:43:35 UTC
leio: you previously opposed this so I'll let you decide :p
Comment 2 Mart Raudsepp gentoo-dev 2013-01-20 16:10:28 UTC
I don't want to decide :(

If I have to, then:

I'm fine with unmasking, under the following strong suggestions to maintainers:

* Do not plan on being able to stabilize an ebuild revision depending on wxGTK:2.9
* If the package works relatively as good with 2.8 than with 2.9, use 2.8

i.e, only per-use wxGTK:2.9 when there's really no other choice, like with new packages in fresh new projects that have decided to target wxWidgets-3.0 directly and not support 2.8 at all (as a stable better program timeline coincides with the hoped schedule of wxWidgets or so)
Comment 3 Nikoli 2013-01-25 11:23:07 UTC
Ryan, so will you unmask? Seems nobody is against.
Comment 4 Julian Ospald 2013-03-16 19:07:26 UTC
why did you change the title?
Comment 5 Ryan Hill (RETIRED) gentoo-dev 2013-03-16 19:10:53 UTC
Because yours was wrong.
Comment 7 Julian Ospald 2013-03-16 19:15:02 UTC
ehm, does that mean you masked 2.9.3.1?
Comment 8 Julian Ospald 2013-03-16 19:35:57 UTC
if not, then you were wrong :P

anway, the reason I nitpick about this is:
https://github.com/lodle/Desurium/issues/288

so I'd appreciate if 2.9.3.1 stays in portage for a while, because I am planning to support/import desurium

it seems they might switch to wxGTK-3.0 once it gets out instead of fixing the code for 2.9.4
Comment 9 Ryan Hill (RETIRED) gentoo-dev 2013-03-16 20:29:05 UTC
There were three bugs already depending on this, at least one of which required >=2.9.4.1.  Pay attention to what you're doing.

(In reply to comment #7)
> ehm, does that mean you masked 2.9.3.1?

No, look at what I did.  The mask was on >=2.9.

> so I'd appreciate if 2.9.3.1 stays in portage for a while, because I am
> planning to support/import desurium

That's good to know, I'll keep it around then.

> it seems they might switch to wxGTK-3.0 once it gets out instead of fixing
> the code for 2.9.4

Well, I've been waiting for 3.0 to come out for 7 years now.  :p