Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 446940 - media-sound/shell-fm-0.8-r1 - Invalid HTTP: HTTP/1.0 403 Forbidden from: http://ws.audioscrobbler.com/radio
Summary: media-sound/shell-fm-0.8-r1 - Invalid HTTP: HTTP/1.0 403 Forbidden from: ht...
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Sound Team
URL: https://github.com/jkramer/shell-fm
Whiteboard: Pending removal: 2016-02-05
Keywords: PMASKED
Depends on:
Blocks:
 
Reported: 2012-12-12 02:18 UTC by Naveen Goswamy
Modified: 2016-02-20 17:47 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Naveen Goswamy 2012-12-12 02:18:08 UTC
I get this when trying to run shell-fm...


Shell.FM v0.7, (C) 2006-2010 by Jonas Kramer
Published under the terms of the GNU General Public License (GPL).

Press ? for help.

Invalid HTTP: HTTP/1.0 403 Forbidden
  from: http://ws.audioscrobbler.com/radio<snip>


Reproducible: Always

Steps to Reproduce:
1. launch shell-fm
2. shell-fm tries to connect as usual
3. returns 403 error code
Actual Results:  
not working.

Expected Results:  
i expect it to work as usual

I believe there has been an API change to shell-fm, and there is a fix for this bug in the upstream git version.  Perhaps we can enable the git version as an ebuild?

thanks.
Comment 1 Chris Reffett gentoo-dev Security 2012-12-12 02:41:55 UTC
The website is returning 403 Forbidden errors for regular browsers too. That's not from an API change, that's a problem with the website itself. You need to file this with the upstream maintainers, I doubt we can do anything here.
Comment 2 Naveen Goswamy 2012-12-12 03:15:38 UTC
I meant that its an API change with last-fm, not shell-fm.

So yeah, any applications which are written to use the old API will fail.

The latest version in git solves this.  I'm wondering if we could make an ebuild which tracks the latest git version.

thanks.
Comment 3 Naveen Goswamy 2012-12-12 03:37:12 UTC
(In reply to comment #1)
> The website is returning 403 Forbidden errors for regular browsers too.
> That's not from an API change, that's a problem with the website itself. You
> need to file this with the upstream maintainers, I doubt we can do anything
> here.

also, if you're trying to use the url I provided in my report (ie. http://ws.audioscrobbler.com/radio) that most certainly will fail, since I shortened it to protect personal information from being sent over this list.  Anyway, for a discussion of this problem see this link

https://github.com/jkramer/shell-fm/issues/72
Comment 4 Pacho Ramos gentoo-dev 2016-02-20 17:47:32 UTC
removed