Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 446920 - =app-office/libreoffice-3.6.4.3 - Crashes on "Check for updates" in the extension manager.
Summary: =app-office/libreoffice-3.6.4.3 - Crashes on "Check for updates" in the exten...
Status: RESOLVED WORKSFORME
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Office Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-11 21:17 UTC by Jérôme Borme
Modified: 2013-09-15 10:32 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
gdb trace for the crash (libreoffice-gdb.txt,3.05 KB, text/plain)
2012-12-11 21:18 UTC, Jérôme Borme
Details
emerge --info (libreoffice-einfo.txt,5.06 KB, text/plain)
2012-12-11 21:18 UTC, Jérôme Borme
Details
strace for the crash (strace.log.lzma,201.27 KB, application/x-lzma)
2012-12-11 21:20 UTC, Jérôme Borme
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jérôme Borme 2012-12-11 21:17:10 UTC
When pressing the "Check for updates" button the program crashes. 

The console displays the following message:
terminate called after throwing an instance of 'com::sun::star::uno::RuntimeException'

Reproducible: Always




gdb log, strace and einfo follow in attachment.
Comment 1 Jérôme Borme 2012-12-11 21:18:20 UTC
Created attachment 332070 [details]
gdb trace for the crash

It was taken after compiling with CFAGS="-O1 -pipe -ggdb" FEATURES="splitdebug nostrip"
Comment 2 Jérôme Borme 2012-12-11 21:18:50 UTC
Created attachment 332072 [details]
emerge --info
Comment 3 Jérôme Borme 2012-12-11 21:20:01 UTC
Created attachment 332074 [details]
strace for the crash
Comment 4 Tomáš Chvátal (RETIRED) gentoo-dev 2012-12-17 09:53:40 UTC
what the... it should not be there (the button) i will look to it at some point and fix it (but currently quite overwhelmed by preparing 4.0 release :-)), simply don't click it for now.

Anyway your gdb trace is still useless because you need to compile glibc with symbols too. (simple -g is enough)
Comment 5 Tomáš Chvátal (RETIRED) gentoo-dev 2013-03-09 18:05:56 UTC
Okey could you please verify the button is not present for 4.0.1.2?

Seems like it could be fixed :-)
Comment 6 Tomáš Chvátal (RETIRED) gentoo-dev 2013-04-26 18:57:14 UTC
Well i understood it wrong :-)
You are checking for extension updates, not for the app updates.

Anyway. This is heavily dependant of extensions you have installed at that moment.

Would you please create screenshot of the extensions window so I can try to replicate it?
Comment 7 Tomáš Chvátal (RETIRED) gentoo-dev 2013-09-15 10:32:24 UTC
Unable to reproduce with various extensions assigned. Feel free to reopen this bug at the point you provide the screenshot I asked before, or list of your extensions.