Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 44564 - rsync troubles link_stat "metadata/timestamp.chk" (in gentoo-portage) failed: No such file or directory
Summary: rsync troubles link_stat "metadata/timestamp.chk" (in gentoo-portage) failed:...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High critical (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-03-13 07:59 UTC by Hans-Christian Armingeon
Modified: 2010-01-22 09:00 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hans-Christian Armingeon 2004-03-13 07:59:24 UTC
Hi,

I am having some serious trouble.

I can't sync my portage tree.

>>> starting rsync with rsync://217.72.114.101/gentoo-portage...
>>> checking server timestamp ...
Welcome to rsync2.de.gentoo.org

Server Address : 217.72.114.99
Hardware       : PIV 2.66 Ghz, 1024 Megs of RAM
Connectivity   : 100 Mbit/s
user limit     : 100
Location       : Munich, Germany

receiving file list ...
link_stat "metadata/timestamp.chk" (in gentoo-portage) failed: No such file or directory
0 files to consider
client: nothing to do: perhaps you need to specify some filenames or the --recursive option?
rsync error: some files could not be transferred (code 23) at main.c(653)
>>> retry ...


I tried it many times, but no luck.

Ping works, sambe behaviour on three different boxes.
Johnny

Reproducible: Always
Steps to Reproduce:
1. emerge sync
2.
3.
Actual Results:  
 


Portage 2.0.50-r1 (default-x86-1.4, gcc-3.3.3, glibc-2.3.3_pre20040207-r0, 
2.6.3-gentoo-r2) 
================================================================= 
System uname: 2.6.3-gentoo-r2 i686 mobile AMD Athlon(tm) XP 2500+ 
Gentoo Base System version 1.4.3.13p1 
distcc 2.12.1 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) 
[enabled] 
ccache version 2.3 [enabled] 
Autoconf: sys-devel/autoconf-2.59-r3 
Automake: sys-devel/automake-1.8.2 
ACCEPT_KEYWORDS="x86 ~x86" 
AUTOCLEAN="yes" 
CFLAGS="-O3 -march=athlon-xp -funroll-loops -pipe" 
CHOST="i686-pc-linux-gnu" 
COMPILER="gcc3" 
CONFIG_PROTECT="/etc /lib/modules /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.1/share/config /usr/kde/3.2/share/config /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control /var/vpopmail/domains /var/vpopmail/etc" 
CONFIG_PROTECT_MASK="/etc/afs/C /etc/afs/afsws /etc/gconf /etc/terminfo /etc/env.d" 
CXXFLAGS="-O3 -march=athlon-xp -funroll-loops -pipe" 
DISTDIR="/usr/portage/distfiles" 
FEATURES="autoaddcvs ccache distcc sandbox" 
GENTOO_MIRRORS="ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo 
http://www.ibiblio.org/pub/Linux/distributions/gentoo 
http://gentoo.oregonstate.edu" 
MAKEOPTS="-j2" 
PKGDIR="/usr/portage/packages" 
PORTAGE_TMPDIR="/var/tmp" 
PORTDIR="/usr/portage" 
PORTDIR_OVERLAY="/usr/local/portage" 
SYNC="rsync://rsync.gentoo.org/gentoo-portage" 
USE="X Xaw3d aalib acl acpi afs alsa apache2 apm arts avi berkdb bonobo cdr 
crypt cscope cups curl dga directfb doc dvd emacs encode esd ethereal evo 
fbcon firebird flash foomaticdb freetds gb gd gdbm ggi gif gnome gphoto2 gpm 
gps gstreamer gtk gtk2 gtkhtml guile imap imlib informix innodb ipv6 jack java 
jikes joystick jpeg kde kerberos ladcca lcm ldap leim libg++ libgda libwww 
lirc mad maildir mbox mcal memlimit mikmod mmx motif mozilla mpeg mpi mule 
mysql nas ncurses nhc98 nls oci8 odbc oggvorbis opengl oss pam pcmcia pda 
pdflib perl plotutils png pnp postgres ppds prelude python qt quicktime 
readline ruby ruby18 samba sasl scanner sdl slang slp snmp socks5 spell ssl 
svga tcltk tcpd tetex tiff truetype usb wmf wxwindows x86 xface xinerama xml2 
xmms xosd xv zeo zlib"
Comment 1 Hans-Christian Armingeon 2004-03-13 08:12:58 UTC
It works again.

No idea why.

Johnny
Comment 2 Jorge Luis Williams 2008-09-06 05:34:52 UTC
That's strange I'm getting the exact same error  -- 

rsync: link_stat "/metadata/timestamp.chk" (in gentoo-portage) failed: No such file or directory (2)

I've tried changeing my GENTOO_MIRRORS and SYNC servers but that doesn't help -- any ideas?

Thanks...

emerge --info follows....

Portage 2.1.4.4 (default/linux/amd64/2008.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.25-gentoo-r7 x86_64)
=================================================================
System uname: 2.6.25-gentoo-r7 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 4200+
Timestamp of tree: Sun, 17 Aug 2008 21:17:01 +0000
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.4.4-r13, 2.5.2-r6
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=athlon64 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://gentoo.arcticnetwork.ca/pub/gentoo/ ftp://distro.ibiblio.org/pub/linux/distributions/gentoo/ ftp://mirror.iawnet.sandia.gov/pub/gentoo/ ftp://ftp.ucsb.edu/pub/mirrors/linux/gentoo/ ftp://gentoo.chem.wisc.edu/gentoo/ "
LDFLAGS="-Wl,-O1"
LINGUAS="en en_US es"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync21.us.gentoo.org/gentoo-portage"
USE="3dnow X acl acpi alsa amd64 avahi avi bash-completion beagle berkdb binfilter bluetooth branding bzip2 cairo cdr cli cracklib crypt cups dbus directfb divx divx4linux dri dvd dvdr dvdread eds emacs emboss encode esd evo fam ffmpeg firefox fortran gdbm gif gimpprint gmedia gnome gpgme gpm gstreamer gtk hal iconv ieee1394 imap ipv6 isdnlog java javascript jpeg kerberos ldap libcaca libnotify mad mbox mdnsresponder-compat midi mikmod mmx mono motif mp3 mpeg mplayer mudflap multilib nautilus ncurses nls nptl nptlonly nsplugin nvidia odk ogg ole opengl openmp pam pcre pdf perl png ppds pppd python qt3support quicktime readline realmedia reflection sdl session slang smartcard smp smtp sound spell spl sse sse2 ssl startup-notification svg sysfs tcpd thunderbird tiff tk truetype unicode usb vorbis webdav wmf wmp xattr xcomposite xinerama xml xmlrpc xorg xscreensaver xv zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US es" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 3 Decibels 2008-09-14 05:33:41 UTC
I'm getting the same thing today.
Comment 4 Serhiy Kalchuk 2008-10-07 16:10:58 UTC
Me too. Exactly the same. Please, reopen then.

emerge --info:

Portage 2.1.4.4 (default-linux/x86/2007.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.25-gentoo-r7 i686)
=================================================================
System uname: 2.6.25-gentoo-r7 i686 AMD Athlon(tm) XP 2500+
Timestamp of tree: Sat, 04 Oct 2008 11:15:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.4.4-r13, 2.5.2-r7
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon-xp -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=athlon-xp -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://src.gentoo.pl http://ftp.roedu.net/pub/mirrors/gentoo.org/ ftp://ftp.romnet.org/gentoo/ "
LC_ALL="uk_UA.UTF-8"
LINGUAS="uk en"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/home/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X aac acl acpi alsa berkdb cairo cdparanoia cdr cli cracklib crypt cups dbus djvu dri dvd dvdr dvdread encode evo exif fam ffmpeg firefox fortran gdbm gif gphoto2 gpm gstreamer gtk hal iconv icq ipv6 isdnlog jabber jpeg kerberos ldap mad midi mikmod mmx mmxext mp3 mpeg mudflap ncurses nls nptl nptlonly nvidia ogg opengl openmp pam pcre pdf perl png ppds pppd python qt3support quicktime readline reflection scanner sdl session spell spl sse ssl svg tcpd tiff truetype unicode usb vorbis win32codecs x86 xml xorg xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="uk en" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 5 Serhiy Kalchuk 2008-10-07 16:29:03 UTC
Darn.. I should have looked up on google more thoroughly. Because the simple solution is:

emerge --metadata && emerge --sync

My apologieses... Ignore my previous post.
Comment 6 Chris Slycord 2009-04-07 15:02:20 UTC
This is happening to me.

It happened when I tried to sync initially and when I:
1) Deleted my whole /usr/portage
2) Downloaded http://gentoo.osuosl.org/snapshots/portage-20090406.tar.bz2
3) Unpacked above like normal
4) Tried to "emerge --sync" again
Comment 7 Alex Barker 2009-04-09 00:57:40 UTC
Incase anyone else runs into this issue:  just delete your /usr/portage/metadata/timestamp.chk file
Comment 8 PhobosK 2009-05-24 10:36:28 UTC
(In reply to comment #7)
> Incase anyone else runs into this issue:  just delete your
> /usr/portage/metadata/timestamp.chk file
> 
It's not helping.
What helped me was:
rm /usr/portage/metadata/timestamp.chk
touch /usr/portage/metadata/timestamp.chk
emerge --sync
Comment 9 Mike Nelson 2009-05-25 16:58:35 UTC
(In reply to comment #8)
> What helped me was:
> rm /usr/portage/metadata/timestamp.chk
> touch /usr/portage/metadata/timestamp.chk
> emerge --sync
> 

I had this same issue as well. That worked for me.
Comment 10 Anders Kreinøe 2010-01-15 15:49:28 UTC
I just had the same problem. None of the sugested solutions worked for me. Instead a single run of emerge-webrsync fixed the problem.
Comment 11 Steffen 'j0inty' Stollfuß 2010-01-21 20:30:02 UTC
Hi,

today I ran into the same problem. So I google a while and found this bugreport here. I tried all posted solutionsb but noone helps really.

As I was tried the emerge-websync feature I got this message.

arko ~ # emerge-webrsync
Fetching most recent snapshot ...                                                                  
 * Latest snapshot date: 20100120                                                                  
 *                                                                           
 * Approximate snapshot timestamp: 1264038300
 *        Current local timestamp: 1264079101
 *
 * The current local timestamp is newer than the timestamp of the latest
 * snapshot. In order to force sync, use the --revert option or remove
 * the timestamp file located at '/usr/portage/metadata/timestamp.x'.

May it be that this is a sync problem for the rsync server ???

j0inty
Comment 12 Anders Kreinøe 2010-01-22 09:00:31 UTC
(In reply to comment #11)
> Hi,
> 
> today I ran into the same problem. So I google a while and found this bugreport
> here. I tried all posted solutionsb but noone helps really.
> 
> As I was tried the emerge-websync feature I got this message.
> 
> arko ~ # emerge-webrsync
> Fetching most recent snapshot ...                                               
>  * Latest snapshot date: 20100120                                               
>  *                                                                           
>  * Approximate snapshot timestamp: 1264038300
>  *        Current local timestamp: 1264079101
>  *
>  * The current local timestamp is newer than the timestamp of the latest
>  * snapshot. In order to force sync, use the --revert option or remove
>  * the timestamp file located at '/usr/portage/metadata/timestamp.x'.
> 
> May it be that this is a sync problem for the rsync server ???
> 
> j0inty
> 

If you have run the commands 

rm /usr/portage/metadata/timestamp.chk
touch /usr/portage/metadata/timestamp.chk

Then it is propely that timestamp that is newer than the one on the server. I think you can solve your problem by waiting a day or two (undtil the rsync server is updated with a new timestamp) and then run emerge-webrsync