Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 445560 - dev-libs/openssl: licenses/openssl has 2 licenses, one of them is a duplicate of licenses/SSLeay
Summary: dev-libs/openssl: licenses/openssl has 2 licenses, one of them is a duplicate...
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All All
: Normal minor (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-02 04:52 UTC by Samuli Suominen
Modified: 2012-12-02 10:27 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Samuli Suominen gentoo-dev 2012-12-02 04:52:10 UTC
I suggest:

1. Rename "sslwrap" to "SSLeay" since it's the original SSLeay license
2. Change net-misc/sslwrap to use the license
3. Change openssl to use the license, by dropping the duplicate from the openssl license and adjusting ebuild

Thanks
Comment 1 Samuli Suominen gentoo-dev 2012-12-02 05:04:36 UTC
There is now "SSLeay" license in tree. If we go about changing "openssl" to "openssl SSLeay", all of these need adjusting too:

af_alg, Net-SSLeay, google-musicmanager, makemkv, ssldump, bind, bind-tools, dropbox, vidalia, newrelic and google-talkplugin

Any opinions?
Comment 2 Ulrich Müller gentoo-dev 2012-12-02 08:10:37 UTC
Good catch, but unfortunately we can't do that, because the openssl license has been approved by the FSF in this form: <http://www.gnu.org/licenses/license-list.html#OpenSSL>
If we split it, we would have to remove it from the FSF-APPROVED license group.

And can you add SSLeay to MISC-FREE in profiles/license_groups, please?
Comment 3 Samuli Suominen gentoo-dev 2012-12-02 10:27:47 UTC
(In reply to comment #2)
> Good catch, but unfortunately we can't do that, because the openssl license
> has been approved by the FSF in this form:
> <http://www.gnu.org/licenses/license-list.html#OpenSSL>
> If we split it, we would have to remove it from the FSF-APPROVED license
> group.
> 
> And can you add SSLeay to MISC-FREE in profiles/license_groups, please?

OK, fine by me, thanks for clarification.