Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 445544 - media-video/dvdstyler-2.3.4 fails to generate .iso ([ac3 @ 0x21005e0] Specified sample_fmt is not supported)
Summary: media-video/dvdstyler-2.3.4 fails to generate .iso ([ac3 @ 0x21005e0] Specifi...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-02 01:08 UTC by Fabio Bonfante
Modified: 2013-03-01 15:57 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
dvdstyler-2.4.1.ebuild updated (dvdstyler-2.4.1.ebuild,1.50 KB, text/plain)
2013-03-01 13:51 UTC, Fabio Bonfante
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fabio Bonfante 2012-12-02 01:08:16 UTC
As already posted upstream here https://sourceforge.net/p/dvdstyler/bugs/496/
DVDStyler fails to make his job with this message:

> [ac3 @ 0x21005e0] Specified sample_fmt is not supported.

As noted on a forum post
https://sourceforge.net/p/dvdstyler/discussion/318795/thread/41531021?page=0
the same message happened with a probably inconsistent dependency on dvdauthor.

Posting here so, maybe some other gentoo user can help upstream figure out what's happening...

Sadly the dvdstyler projects made with version 2.3.4 are not compatible with 2.1. So I strongly advice to hard-mask version 2.3.4 to avoid other users to waste their time composing projects that can't be burned.
Comment 1 Fabio Bonfante 2013-02-28 18:31:23 UTC
As noted in a post on upstream bug report:
---------
Here's the problem. The issue is in the MENU properties. For some reason it's either not passing the variable at all or it's incorrect. If you don't include an audio file to it, it blows up. So, either create a silent mp3 or wav and include it, OR include whatever sound file you want. And it works just fine.
---------

The latest upstream released version is 2.4.1 that should be not affected of this bug. Didn't test it yet...
Comment 2 Fabio Bonfante 2013-03-01 13:51:05 UTC
Created attachment 340632 [details]
dvdstyler-2.4.1.ebuild updated

Tested version 2.4.1 requires media-libs/wxsvg-1.1.13 not in portage yet.
* Renamed ebuild wxsvg-1.1.9 to wxsvg-1.1.13... builds fine
* Emerge version 2.4.1 ... builds fine
* Test generating a dvd-iso without audio in menù... OK
Comment 3 Samuli Suominen gentoo-dev 2013-03-01 15:57:19 UTC
in portage. thanks for the reporting, ebuild, ...