Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 445492 - gnome-extra/nm-applet- leaks memory
Summary: gnome-extra/nm-applet- leaks memory
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo Linux Gnome Desktop Team
Depends on:
Reported: 2012-12-01 16:14 UTC by darkdimius
Modified: 2013-11-11 20:47 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description darkdimius 2012-12-01 16:14:40 UTC
After 1 day of process uptime mem usage by nm-applet is 400mb. Restarting it drops mem usage to 20mb.
I'm seeing this problem for 2-3 month now but it looks like it's fixed in ubuntu.

Reproducible: Always

Steps to Reproduce:
1. start nm-applet
2. eat pizza, watch tv or sleep for 1-2 days
3. look an nm-applet memory usage
Actual Results:  
5%(400mb) of my 8Gb is used by nm-applet

Expected Results:  
20 mb memory usage

Portage 2.2.0_alpha143 (default/linux/amd64/10.0/desktop, gcc-4.6.3, glibc-2.15-r3, 3.6.8-gentoo x86_64)
System uname: Linux-3.6.8-gentoo-x86_64-Intel-R-_Core-TM-_i7-2640M_CPU_@_2.80GHz-with-gentoo-2.1
Timestamp of tree: Sat, 01 Dec 2012 13:30:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.6
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3, 4.7.2
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo sage-on-gentoo
CFLAGS="-O2 -ftree-vectorize -pipe -march=native -fomit-frame-pointer "
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /usr/share/maven-bin-2.2/conf /usr/share/maven-bin-3.0/conf /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -ftree-vectorize -pipe -march=native -fomit-frame-pointer "
EMERGE_DEFAULT_OPTS="--with-bdeps y --jobs=5 --binpkg-respect-use y --load-average=4"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs candy collision-protect compress-build-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch parallel-install preserve-libs protect-owned sandbox sfperms split-log strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="ru en uk"
MAKEOPTS="-j5 -l5"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac acl acpi alsa amd64 amr apng archive aria2 avx awt bash-completion beanshell berkdb bluetooth branding btrfs bzip2 cairo cdda cdio cleartype cli colordiff compress consolekit cpio cracklib crypt cups curl custom-optimization cxx dbus dhclient djvu dnotify dri drm dts dvd dvdr dvi eclipse emboss encode epoll exif fam firefox flac fortran fuse gdbm gif gles glibc-omitfp gold gpm graphite gtk gzip hdaps iconv id3 id3tag inotify iptables jabber java java6 jce jemalloc jingle jmx jpeg jpeg2k laptop lcms libnotify log4j lxc mad matroska mktemp mmx mng modules mp3 mp4 mpeg mudflap multilib nautilus ncurses nfs nls nptl ogg opengl openmp openvpn pam pango pcre pdf png policykit ppds pppd prelink python3 qt3support qt4 rar readline resolvconf rtc samba sdl session smp sound spell sse sse2 sse3 sse4 sse4_1 ssh ssl ssse3 startup-notification svg symlink tcpd tga threads tiff truetype udev udisks unicode unzip upnp upower usb v4l vaapi vorbis vpx wav webm wimax wxwidgets x264 xcb xml xv xvid zip zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="ru en uk" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="intel vesa fbdev" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 1 Pacho Ramos gentoo-dev 2013-11-11 19:44:22 UTC
Should be solved in
Comment 2 darkdimius 2013-11-11 20:11:21 UTC
How can this be resolved if there's no (even keyworded or masked) version in Portage tree with this problem fixed.
Comment 3 Pacho Ramos gentoo-dev 2013-11-11 20:47:29 UTC
The bug you pointed:

suggests it was solved by a version from 2012 (looks like newer than should get it fixed)