Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 445232 - >www-client/firefox-16.0.2 - Quake Live doesn't work.
Summary: >www-client/firefox-16.0.2 - Quake Live doesn't work.
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Mozilla Gentoo Team
Depends on:
Reported: 2012-11-29 18:45 UTC by Paul Jewell
Modified: 2012-12-13 06:27 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Paul Jewell 2012-11-29 18:45:47 UTC
Firefox 17 - quakelive doesn't start Initial screen is OK, but on joining an arena the screen is not updated. See the bug in the url above for details on the bugzilla. Please can you put firefox-16.0.2 back in the tree until this is resolved upstream (by either mozilla or id)!

Reproducible: Always

Steps to Reproduce:
1. Emerge firefox-17*
2. Goto
3. Login and join an arena
Actual Results:  
Window in quakelive screen freezes

Expected Results:  
Join the arena and play!

I don't expect anything to be fixed, as the problem is upstream with either quakelive or firefox. If you put firefox-16.0.2 back in the tree, I'll close this bug when the problem is fixed.
Comment 1 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2012-11-30 11:53:22 UTC
> Please can you put firefox-16.0.2 back in the tree.

Have you tried 16.0.2 again to see whether that actually fixes it for you?
Comment 2 Paul Jewell 2012-11-30 12:16:14 UTC
Yes. I installed 17 as part of the normal system update, then identified the problem. I returned to 16.0.2, and everything worked OK. 16.0.2 was taken out of the tree, and 17.0-r1 added. I tried this version before posting the bug, in case the problem was solved in going from 17.0 to 17.0-r1.
Comment 3 Jory A. Pratt gentoo-dev 2012-11-30 13:13:17 UTC
dom.ipc.plugins.enabled  set to false as your work around, plugin breakage for a game does not trump security for any reason.
Comment 4 Paul Jewell 2012-11-30 19:17:19 UTC
Thanks Jory - that worked. Please close this bug!
Comment 5 Jory A. Pratt gentoo-dev 2012-11-30 20:52:16 UTC
I will leave bug open while we figure it out upstream.
Comment 6 Jory A. Pratt gentoo-dev 2012-12-12 23:34:09 UTC
As I can not decompile source without violating the license there is nothing I can do except refer you to upsteam for plugin. It will be for them to fix.
Comment 7 Paul Jewell 2012-12-13 06:27:31 UTC
Thanks Jory - I expected that to be the outcome. At least the workaround is documented here and in the forum so anyone else finding this problem can use it.