Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 444896 - net-nds/openldap-2.4.30 USE="overlays" - ld: cannot find -lldap_r
Summary: net-nds/openldap-2.4.30 USE="overlays" - ld: cannot find -lldap_r
Status: RESOLVED DUPLICATE of bug 408077
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: LDAP Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-27 07:13 UTC by Nikita S. Kipriyanov
Modified: 2014-10-11 23:49 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
/var/tmp/portage/net-nds/openldap-2.4.30/temp/build.log (build.log,383.86 KB, text/plain)
2012-11-27 07:20 UTC, Nikita S. Kipriyanov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nikita S. Kipriyanov 2012-11-27 07:13:30 UTC
When building openldap as USE="-overlays" emerge openldap, it builds fine.

If I build it with USE="overlays", emerge stops when linking contrib-module samba4. It assumes that libldap_r and liblber alredy installed into proper locations, but these libraries are still not installed (package is just in compile phase, nothing is merged) and linker fails.

This can be worked around, emerging openldap twice, first one being done without overlays flag. Then needed libraries are alredy in place and everything succeseeds.

Reproducible: Always

Steps to Reproduce:
1. Unmerge openldap if it is installed: emerge -C openldap
2. Emerge with overlays: USE="overlays" emerge openldap

Actual Results:  
Failure with ld can't find lldap_r and llber.

Expected Results:  
Package emerged correctly with overlays

Tried in LXC container with x86 and in bare system with amd64. Latter case emerge --info:

Portage 2.1.11.31 (default/linux/amd64/10.0, gcc-4.5.4, glibc-2.15-r3, 3.5.7-gentoo x86_64)
=================================================================
System uname: Linux-3.5.7-gentoo-x86_64-AMD_Athlon-tm-_X2_Dual_Core_Processor_BE-2350-with-gentoo-2.1
Timestamp of tree: Tue, 13 Nov 2012 05:00:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.4-r2 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo merlin
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=native"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gw http://mirror.yandex.ru/gentoo-distfiles"
LANG="ru_RU.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="ru en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://gw/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acl alsa amd64 bash-completion berkdb bzip2 cairo caps cdda cddb cdparanoia cli cracklib crypt cups curl cxx dbus djvu dri dts dvd encode exif ffmpeg flac fluidsynth fortran gdbm gif gimp gpm gs gstreamer gtk iconv id3tag idn ipv6 jack java jingle jpeg kde ladspa lame lash libnotify libsamplerate lzma mad matroska midi mmx mmxext mod modplug modules mp3 mpeg mudflap multilib ncurses nls nptl nsplugin ogg opengl openmp pam pcre png pppd qt3support qt4 readline samba scanner session smp sndfile soundtouch speex spell sse sse2 ssl startup-notification svg syslog system-sqlite taglib tcpd theora tiff truetype twolame udev unicode v4l vcd vorbis webkit x264 xattr xcomposite xinerama xscreensaver xv xvid xvmc zlib" ALSA_CARDS="hda-intel usb-audio aloop" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" GRUB_PLATFORMS="efi-32 efi-64 pc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="ru en" PHP_TARGETS="php5-3" PYTHON_TARGETS="python2_7 python3_2" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby18 ruby19" SANE_BACKENDS="net" USERLAND="GNU" VIDEO_CARDS="nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Nikita S. Kipriyanov 2012-11-27 07:20:16 UTC
Created attachment 330710 [details]
/var/tmp/portage/net-nds/openldap-2.4.30/temp/build.log

 * ERROR: net-nds/openldap-2.4.30 failed (compile phase):
 *   emake samba4 failed
 * 
 * Call stack:
 *     ebuild.sh, line  93:  Called src_compile
 *   environment, line 3819:  Called die
 * The specific snippet of code:
 *               emake CC="${CC}" libexecdir="/usr/$(get_libdir)/openldap" || die "emake samba4 failed";
 * 
 * If you need support, post the output of `emerge --info '=net-nds/openldap-2.4.30'`,
 * the complete build log and the output of `emerge -pqv '=net-nds/openldap-2.4.30'`.
 * The complete build log is located at '/var/tmp/portage/net-nds/openldap-2.4.30/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-nds/openldap-2.4.30/temp/environment'.
 * Working directory: '/var/tmp/portage/net-nds/openldap-2.4.30/work/openldap-2.4.30/contrib/slapd-modules/samba4'
 * S: '/var/tmp/portage/net-nds/openldap-2.4.30/work/openldap-2.4.30'
Comment 2 Alexander Tsoy 2013-09-16 12:59:38 UTC
This was fixed long time ago in 2.4.31. See bug 408077.
Comment 3 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2014-10-11 23:49:17 UTC

*** This bug has been marked as a duplicate of bug 408077 ***