Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 444816 - media-gfx/eog-3.4.3-r1 dosn't show me the entire picture
Summary: media-gfx/eog-3.4.3-r1 dosn't show me the entire picture
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-26 17:50 UTC by Alessandro Capogna
Modified: 2014-02-17 19:51 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
eog sshot (Screenshot from 2012-11-24 21:08:15.png,84.16 KB, image/png)
2012-11-26 17:50 UTC, Alessandro Capogna
Details
gimp sshot (Screenshot from 2012-11-24 21:08:40.png,386.10 KB, image/png)
2012-11-26 17:50 UTC, Alessandro Capogna
Details
one of the image that i'm having problem to open (1346791832769.jpg,470.38 KB, image/jpeg)
2012-12-02 19:56 UTC, Alessandro Capogna
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alessandro Capogna 2012-11-26 17:50:09 UTC
Created attachment 330662 [details]
eog sshot

As you can see from sshot, i have this error with images bigger than my screen resolution.

Tried to:

 resize the window
 remove .config/eog
 revdep-rebuild (to see is was any kind of lib problem)

The picture is correct it self because all other program (gimp, shotwell) show it.

This happen with a lot of pictures, not only the one you see in the paste.

Trying to start eog from terminal to see if error/warning comes out, but nothing happen.

Can you suggest me a way to find some info? Maybe a hidden log?
Comment 1 Alessandro Capogna 2012-11-26 17:50:35 UTC
Created attachment 330666 [details]
gimp sshot
Comment 2 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-11-26 18:12:39 UTC
Please use the correct content type for attachments: png images are "image/png", not "plain text" :)
Comment 3 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-11-26 18:16:42 UTC
What version of x11-libs/gdk-pixbuf are you using?

Please attach an image file that gives you this error.
Comment 4 Alessandro Capogna 2012-12-02 19:54:03 UTC
x11-libs/gdk-pixbuf-2.26.4 (X introspection jpeg tiff -debug -doc -jpeg2k -test)
Comment 5 Alessandro Capogna 2012-12-02 19:56:56 UTC
Created attachment 331232 [details]
one of the image that i'm having problem to open

it doesn't happen only with this image, but (it looks like) with all images with higher resolution than my screen
Comment 6 Alessandro Capogna 2013-01-01 19:35:10 UTC
same problem with media-gfx/eog-3.6.2 and x11-libs/gdk-pixbuf-2.26.5
Comment 7 Pacho Ramos gentoo-dev 2013-07-27 11:17:21 UTC
Please retry with 3.8
Comment 8 Alessandro Capogna 2013-08-24 06:23:53 UTC
seems to be solved with eog-3.8.2 (the only 3.8.* that i tried)
Comment 9 Alessandro Capogna 2014-02-17 16:33:47 UTC
same problem with:
   media-gfx/eog-3.10.2
   x11-libs/gdk-pixbuf-2.30.4
Comment 10 Alessandro Capogna 2014-02-17 19:00:44 UTC
ok, seems to be an intel driver issue https://bugs.freedesktop.org/show_bug.cgi?id=70527

With x11-drivers/xf86-video-intel-2.99.910 the problem is solved
Comment 11 Rémi Cardona gentoo-dev 2014-02-17 19:51:32 UTC
Closing then.

Cheers