Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 444668 - kde-base/kmix-4.9.3 causes plasma system tray to flicker
Summary: kde-base/kmix-4.9.3 causes plasma system tray to flicker
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL: https://bugs.kde.org/show_bug.cgi?id=...
Whiteboard: fixed in 4.10.0
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-25 12:17 UTC by Andreas Sturmlechner
Modified: 2013-03-17 11:32 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
kmix-4.9.3-fix-systray-flicker.patch (kmix-4.9.3-fix-systray-flicker.patch,11.86 KB, patch)
2012-11-25 12:17 UTC, Andreas Sturmlechner
Details | Diff
kmix-4.9.3-r1.ebuild.diff (kmix-4.9.3-r1.ebuild.diff,365 bytes, patch)
2012-11-25 12:18 UTC, Andreas Sturmlechner
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Sturmlechner gentoo-dev 2012-11-25 12:17:09 UTC
Created attachment 330532 [details, diff]
kmix-4.9.3-fix-systray-flicker.patch

There are several bug reports in bugs.kde.org and one in f.g.o from a user too lazy to report it himself: http://forums.gentoo.org/viewtopic-t-943360.html

I'm not sure if it is related as I can't quite make sense of the description there, but there was something strange going on at konversation notifications on my system - a window that was placed at the bottom border of the screen briefly went above the center panel that is holding systray. I'll have to check if that is gone now...
Comment 1 Andreas Sturmlechner gentoo-dev 2012-11-25 12:18:34 UTC
Created attachment 330534 [details, diff]
kmix-4.9.3-r1.ebuild.diff

updated kmix ebuild
Comment 2 Agostino Sarubbo gentoo-dev 2012-11-25 12:27:38 UTC
this is not reproducible here
Comment 3 Andreas Sturmlechner gentoo-dev 2012-11-25 12:46:53 UTC
My own observation with konv also isn't fixed after applying the patch, so it's something different.
Comment 4 Pavlos Ratis (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2012-11-25 16:21:14 UTC
Reproducible here but the patch didn't fix it.
Comment 5 Incinerator 2012-12-02 14:57:31 UTC
Yep, same for me - it flickers. But that flickering is not the worst part: the sound in SWAT4 has become somewhat clicky - when one game sound fx changes with another a short click is produced. I believe those two behaviors are connected with each other somehow.

The upstream patches (applied through userpatch portage feature) do not solve anything for me.

I'm using pulseaudio (wine shouts through pulseaudio too), alsa and vlc as phonon backend, btw.
Comment 6 Incinerator 2012-12-03 14:03:32 UTC
Oh, the patch actually fixed everything for me.

Looks like the upstream patches just weren't applied (i think the userpatch feature doesn't accept patches with *.diff extension or something as the patches weren't listed during the userpatch phase).

Thanks for the patch, sorry for my previous misleading comment.

Regards.
Comment 7 Chris Reffett (RETIRED) gentoo-dev Security 2013-02-14 20:28:22 UTC
Please verify whether this was fixed for you in 4.10.0.
Comment 8 Andreas K. Hüttel gentoo-dev 2013-03-17 11:32:58 UTC
fixed in 4.10.0