Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 444090 - sys-apps/sed-4.2.1 does hardcoded AR calls
Summary: sys-apps/sed-4.2.1 does hardcoded AR calls
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2012-11-20 19:09 UTC by Denis M. (Phr33d0m)
Modified: 2013-10-20 21:23 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Denis M. (Phr33d0m) 2012-11-20 19:09:13 UTC
$ ▶ ./blatt.sh /var/tmp/portage/logs/sys-apps\:sed-4.2.1-r1\:20121120-132327.log 
>>> sys-apps/sed-4.2.1: ISSUES FOUND
> Hardcoded calls:
ar cru libsed.a set-mode-acl.o copy-acl.o file-has-acl.o c-ctype.o localcharset.o xalloc-die.o xstrndup.o basename.o dirname.o exitfail.o quote.o quotearg.o regex.o stripslash.o tempname.o xmalloc.o 


Reproducible: Always
Comment 1 Michael Mair-Keimberger (iamnr3) 2013-06-15 19:31:26 UTC
This issue doesn't happen anymore with sed-4.2.2. It seems to be fixed upstream. I guess we can close this bug.
Comment 2 Tony Vroon gentoo-dev 2013-10-20 21:23:08 UTC
Closing due to upstream fix. Thank you for your report all the same, and sorry that it did not get actioned more meaningfully downstream.