Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 444050 - sys-libs/libunwind-1.1[lzma]: libunwind-$arch.so miss lzma linkage
Summary: sys-libs/libunwind-1.1[lzma]: libunwind-$arch.so miss lzma linkage
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Toolchain Maintainers
URL: https://lists.nongnu.org/archive/html...
Whiteboard:
Keywords:
: 501324 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-11-20 14:51 UTC by Marcin Mirosław
Modified: 2014-02-16 03:04 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,96.54 KB, text/plain)
2012-11-20 14:51 UTC, Marcin Mirosław
Details
libunwind-1.1-lzma-typo.patch (libunwind-1.1-lzma-typo.patch,474 bytes, patch)
2013-04-20 00:00 UTC, Matt Whitlock
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Marcin Mirosław 2012-11-20 14:51:24 UTC
libtool: link: clang -O2 -march=native -pipe -ggdb -fexceptions -Wall -Wsign-compare -Wl,-O1 -Wl,--as-needed -o test-ptrace-misc test-ptrace-misc.o ident.o 
/bin/sh ../libtool --tag=CC   --mode=link clang  -O2 -march=native -pipe -ggdb -fexceptions -Wall -Wsign-compare  -Wl,-O1 -Wl,--as-needed -o Lperf-simple Lperf-simple.o ../src/libunwind.la 
libtool: link: clang -O2 -march=native -pipe -ggdb -fexceptions -Wall -Wsign-compare -Wl,-O1 -Wl,--as-needed -o .libs/Gperf-simple Gperf-simple.o  ../src/.libs/libunwind-x86_64.so ../src/.libs/libunwind.so
../src/.libs/libunwind-x86_64.so: error: undefined reference to 'lzma_index_buffer_decode'
../src/.libs/libunwind-x86_64.so: error: undefined reference to 'lzma_index_end'
../src/.libs/libunwind-x86_64.so: error: undefined reference to 'lzma_index_size'
../src/.libs/libunwind-x86_64.so: error: undefined reference to 'lzma_index_uncompressed_size'
../src/.libs/libunwind-x86_64.so: error: undefined reference to 'lzma_stream_buffer_decode'
../src/.libs/libunwind-x86_64.so: error: undefined reference to 'lzma_stream_footer_decode'
clang: error: linker command failed with exit code 1 (use -v to see invocation)
make[1]: *** [Gperf-simple] Error 1
make[1]: *** Waiting for unfinished jobs....
libtool: link: clang -O2 -march=native -pipe -ggdb -fexceptions -Wall -Wsign-compare -Wl,-O1 -Wl,--as-needed -o .libs/Lperf-simple Lperf-simple.o  ../src/.libs/libunwind.so
make[1]: Leaving directory `/var/tmp/portage/sys-libs/libunwind-1.1/work/libunwind-1.1/tests'
make: *** [all-recursive] Error 1
 * ERROR: sys-libs/libunwind-1.1 failed (compile phase):
 *   emake failed



Reproducible: Always




# emerge --info
Portage 2.2.0_alpha142 (default/linux/amd64/10.0/desktop/kde, gcc-4.7.2, glibc-2.16.0, 3.6.6-gentoo x86_64)
=================================================================
System uname: Linux-3.6.6-gentoo-x86_64-Intel-R-_Core-TM-2_Duo_CPU_E8400_@_3.00GHz-with-gentoo-2.2
Timestamp of tree: Tue, 20 Nov 2012 07:00:01 +0000
ld GNU gold (GNU Binutils 2.23) 1.11
ccache version 3.1.8 [enabled]
app-shells/bash:          4.2_p39
dev-java/java-config:     2.1.12
dev-lang/python:          2.7.3-r2, 3.2.3-r1
dev-util/ccache:          3.1.8
dev-util/cmake:           2.8.10.1
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.5
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.5
sys-devel/binutils:       2.23
sys-devel/gcc:            4.4.7, 4.5.4, 4.7.2
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA AdobeFlash-10.3 PUEL Q3AEULA skype-eula dlj-1.1 Oracle-BCLA-JavaSE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe -ggdb"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=native -pipe -ggdb"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS=" --quiet-build=n"
FCFLAGS="-O2 -pipe"
FEATURES="Xfail-clean Xkeepwork assume-digests binpkg-logs ccache collision-protect config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="pl en es es_ES"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="-O"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://192.168.138.254/gentoo-portage"
USE="64bit X a52 aac acl acpi alsa amd64 apm async bash-completion bfq bittorrent branding bzip2 cairo caps cdda cdr chroot cli consolekit crypt cups cxx dbus declarative dmx dri dvd dvdr emboss encode exif fam firefox ftp gif glibc-omitfp gpm graphite gstreamer iconv idn iproute2 ipv6 ithreads jpeg kde kipi laptop lcms libnotify lightning logrotate mad mmap mmx mmxext mng modules mp3 mp4 mpeg mudflap multilib ncurses network-cron nls nptl nsplugin nspluginwrapper objc ogg opengl openmp openssl optimization optimized-qmake pam pango pch pcre pdf phonon plasma png policykit ppds pppd qt3support qt4 readline samba sdl semantic-desktop session sharedmem smp spell sse sse2 sse3 sse4_1 ssl ssse3 startup-notification svg threads threadsafe tiff tools truetype udev udisks unicode upower urandom usb vim vim-pager vim-syntax vorbis wxwidgets x264 xattr xcb xcomposite xinerama xml xscreensaver xv xvid zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cgid dav dbd deflate dir env expires ext_filter filter headers include info log_config logio mime mime_magic negotiation rewrite setenvif speling status unique_id usertrack vhost_alias" APACHE2_MPMS="worker" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DRACUT_MODULES="caps lvm mdraid" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="pl en es es_ES" PHP_TARGETS="php5-3" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, USE_PYTHON
Comment 1 Marcin Mirosław 2012-11-20 14:51:52 UTC
Created attachment 330084 [details]
build.log
Comment 2 Matt Whitlock 2013-04-20 00:00:01 UTC
Created attachment 346048 [details, diff]
libunwind-1.1-lzma-typo.patch

This is caused by a typo in configure.ac. The attached patch fixes it. (Run autoreconf after applying.)
Comment 3 Samuli Suominen gentoo-dev 2013-09-12 19:15:45 UTC
+  12 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> libunwind-1.1.ebuild:
+  Correct LIBLZMA="-lzma" with LIBLZMA="-llzma" (and edit both configure and
+  configure.ac to avoid running eautoreconf only for this) as per #444050 by
+  Marcin Mirosław
Comment 4 SpanKY gentoo-dev 2014-02-16 01:13:02 UTC
*** Bug 501324 has been marked as a duplicate of this bug. ***
Comment 5 SpanKY gentoo-dev 2014-02-16 02:12:34 UTC
should be all set now in the tree; thanks for the report!

Commit message: Fix lzma linkage
http://sources.gentoo.org/sys-libs/libunwind/files/libunwind-1.1-lzma.patch?rev=1.1
http://sources.gentoo.org/sys-libs/libunwind/libunwind-1.1.ebuild?r1=1.13&r2=1.14