Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 44392 - php-cvs doesn't install ("cp: cannot stat `modules/*': No such file or directory")
Summary: php-cvs doesn't install ("cp: cannot stat `modules/*': No such file or direct...
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: PHP Bugs
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-03-11 14:12 UTC by Holly
Modified: 2004-08-07 13:25 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Holly 2004-03-11 14:12:24 UTC
php-cvs fails on installing, details below.
compiling seems to have finished correctly.

Reproducible: Always
Steps to Reproduce:
1. emerge -v /usr/portage/dev-php/php-cvs/php-cvs-5.0-r2.ebuild
2.
3.

Actual Results:  
>>> Install php-cvs-5.0-r2 into /var/tmp/portage/php-cvs-5.0-r2/image/ category
dev-php
Installing shared extensions:    
/var/tmp/portage/php-cvs-5.0-r2/image//usr/lib/php/extensions/no-debug-non-zts-20020429/
cp: cannot stat `modules/*': No such file or directory
make: *** [install-modules] Error 1

!!! ERROR: dev-php/php-cvs-5.0-r2 failed.
!!! Function php_src_install, Line 418, Exitcode 2
!!! (no error message)


Expected Results:  
installation of php-cvs

Portage 2.0.50-r1 (default-x86-1.4, gcc-3.3.3, glibc-2.3.3_pre20040207-r0,
2.6.3-gentoo-r2)
=================================================================
System uname: 2.6.3-gentoo-r2 i586 Pentium 75 - 200
Gentoo Base System version 1.4.3.13p1
distcc 2.13 i486-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [enabled]
Autoconf: sys-devel/autoconf-2.59-r3
Automake: sys-devel/automake-1.8.2
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CFLAGS="-Os -mcpu=pentium -fomit-frame-pointer -funroll-loops -pipe"
CHOST="i486-pc-linux-gnu"
COMPILER="gcc3"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.1/share/config /usr/kde/3.2/share/config /usr/kde/3/share/config
/usr/share/config /var/qmail/alias /var/qmail/control /var/vpopmail/domains
/var/vpopmail/etc"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-Os -mcpu=pentium -fomit-frame-pointer -funroll-loops -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs ccache sandbox"
GENTOO_MIRRORS="http://212.219.247.19/sites/www.ibiblio.org/gentoo/
http://ftp.easynet.nl/mirror/gentoo/
http://212.219.247.15/sites/www.ibiblio.org/gentoo/
http://212.219.247.21/sites/www.ibiblio.org/gentoo/"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://<local-rsync-server>/gentoo-portage"
USE="3dfx X Xaw3d aalib aavm acl afs alsa apache2 apm arts avi berkdb crypt
cscope cups dga directfb encode esd ethereal evms2 fbcon foomaticdb gd gdbm ggi
gif gnome gpm gps gtk gtk2 imap imlib ipv6 jpeg kde lcms ldap libg++ libwww mad
maildir matroska matrox memlimit mikmod motif mpeg mysql nas ncurses nls nptl
oav oggvorbis opengl oss pam pdflib perl png pnp python qt quicktime readline
ruby samba sasl sdl slang spell src ssl svga tcltk tcpd tiff truetype vim-with-x
wmf wxwindows x86 xface xml xml2 xmms xosd xv zlib"
Comment 1 Tal Peer (RETIRED) gentoo-dev 2004-03-14 06:05:25 UTC
I'm currently working on full support for PHP5 in the php eclasses, so stay tuned regarding this.
btw, i also currently get this error and investigating on it.
Comment 2 Holly 2004-03-14 06:16:43 UTC
ok thanks, good to know. will it be possible to have php4 and php5 as apache-modules at the same time? (like php4 parses .php files and php5 parses .php5 files?
Comment 3 Stuart Herbert (RETIRED) gentoo-dev 2004-03-28 16:38:26 UTC
This is caused by our php-cvs ebuild doing a 'make install-modules' when there are no shared modules.  It's really a bug in PHP's build scripts.
Comment 4 R Brenton Strickler 2004-06-30 17:30:33 UTC
After it started it's ./configure, i did a 'touch /var/tmp/portage/php-cvs-5.0-r2/work/php-src/modules/test_module' and that seemed to allow it to finish it's build without errors.
Comment 5 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2004-08-07 13:25:37 UTC
php-cvs obsolete.
go and use one of the new php5 packages (-arch masked for the next week).