Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 443648 - app-emulation/dosemu-1.4.1_pre20091009 hangs
Summary: app-emulation/dosemu-1.4.1_pre20091009 hangs
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal critical (vote)
Assignee: Hanno Böck
URL:
Whiteboard:
Keywords:
Depends on: 451092
Blocks:
  Show dependency tree
 
Reported: 2012-11-17 16:57 UTC by Tom Poplawski
Modified: 2013-08-06 06:28 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Poplawski 2012-11-17 16:57:02 UTC
app-emulation/dosemu-1.4.1_pre20091009 hangs.  Patch is available but not included in gentoo build.

http://dosemu.svn.sourceforge.net/viewvc/dosemu?view=revision&revision=2058


Reproducible: Always

Steps to Reproduce:
1. emerge dosemu
2. run dosemu
3. dosemu hangs



patch is simple and tested to work on multiple machines.

http://dosemu.svn.sourceforge.net/viewvc/dosemu/trunk/src/plugin/translate/translate.c?r1=2032&r2=2058&view=patch


h2 ~ # emerge --info
Portage 2.1.11.31 (default/linux/x86/10.0/desktop/kde, gcc-4.5.4, glibc-2.15-r3, 3.3.8-gentoo i686)
=================================================================
System uname: Linux-3.3.8-gentoo-i686-AMD_Athlon-tm-_II_X3_440_Processor-with-gentoo-2.1
Timestamp of tree: Fri, 16 Nov 2012 20:30:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.4 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo Mine mythtv
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=amdfam10  -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=amdfam10  -fomit-frame-pointer"
DISTDIR="/var/tmp/distfiles"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="http://gentoo.osuosl.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en"
MAKEOPTS="-j4"
PKGDIR="/var/tmp/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /usr/local/overlays/mythtv_portage/Gentoo"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fam ffmpeg firefox flac fortran gdbm gif gpm gstreamer gtk iconv icu ipv6 jpeg kde kipi lcms libnotify lm_sensors loop-aes mad mmx mmxext mng modules mp3 mp4 mpeg mudflap mythtv ncurses nls nptl nsplugin ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds pppd qt3support qt4 readline sdl session spell sse sse2 ssl startup-notification svg tcpd thumbnail tiff truetype udev udisks unicode upower usb vdpau vorbis wxwidgets x264 x86 xcb xcomposite xinerama xml xscreensaver xv xvid zlib" ALSA_CARDS="snd-intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en" LIRC_DEVICES="mceusb" PHP_TARGETS="php5-3" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Fred Krogh 2013-04-06 23:15:07 UTC
Same problem here. Hoping a fix is easily available before I need to use it.  (Still running an old dos binary from time to time.)
Comment 2 Tom 2013-05-19 20:00:28 UTC
I'm able to confirm this bug, after "solving" the compile problems using flex 2.5.33 instead of flex 2.5.37 only for doesmu.

Even though, the vm.mmap_min_addr has been set to zero (in the kernel), dosemu starts and hangs.

The reason, why I wanted to recompile dosemu was the failure message, after the dos-command has exited, to map some memory - the older dosemu has been compiled using gcc 4.4.5 and I had done no changes on the configuration files regarding dosemu.

I've tried to recompile dosemu against kernel 3.4.45, but it was of no help.

Does anyone has some useful tips to solve this problem?
Comment 3 Tom 2013-05-20 12:39:43 UTC
In the meantime I've installed gcc 4.4.5 in parallel to 4.6.3 and compiled dosemu using the older compiler, for which my old binary worked fine, but the problem stays the same, so the compiler should not be the reason for failure.

Additionally I've checked painfully the kernel settings, but everything is okay; even the vm86-support has been enabled, which was enabled before and seems to be neccesary for that.

As far as I can see, all settings inside the kernel seems to be okay...
Comment 4 far jump 2013-06-12 03:02:51 UTC
I am having the same problem.  Had to install linux mint in order to get dosemu working to run needed legacy software.
Comment 5 Sergei Trofimovich gentoo-dev 2013-08-05 10:27:46 UTC
Does 1.4.1_pre20130107 or upper work for you?
Comment 6 far jump 2013-08-05 14:19:04 UTC
(In reply to Sergei Trofimovich from comment #5)
> Does 1.4.1_pre20130107 or upper work for you?

yes, it compiles on 2 of my newer systems,  I will test with some dos programs
Comment 7 Sergei Trofimovich gentoo-dev 2013-08-06 06:28:33 UTC
(In reply to far jump from comment #6)
> (In reply to Sergei Trofimovich from comment #5)
> > Does 1.4.1_pre20130107 or upper work for you?
> 
> yes, it compiles on 2 of my newer systems,  I will test with some dos
> programs

Aha, thanks! Please, reopen the bug if it will happen apear on test.