Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 443534 - x11-apps/xconsole-1.0.4 eats 100% CPU if -file option is used
Summary: x11-apps/xconsole-1.0.4 eats 100% CPU if -file option is used
Status: RESOLVED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: PPC Linux
: Normal normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-16 17:30 UTC by Johannes Geiss
Modified: 2017-01-29 21:30 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Geiss 2012-11-16 17:30:05 UTC
XConsole uses 100% CPU if started with a regular file.

Reproducible: Always

Steps to Reproduce:
1. ./xconsole -file README

Actual Results:  
The window appears and sometimes a few letters from the README file are seen but never all of them. Mostly none. The window is not refreshing due to 100% CPU usage.

Expected Results:  
The window shows the last lines of the README file and nearly no CPU is used.

Portage 2.1.11.31 (default/linux/powerpc/ppc32/10.0/desktop, gcc-4.5.3, glibc-2.14.1-r3, 3.2.1-gentoo-r2-polaris ppc)
=================================================================
System uname: Linux-3.2.1-gentoo-r2-polaris-ppc-7447-7457,_altivec_supported-with-gentoo-2.1
Timestamp of tree: Sat, 03 Nov 2012 17:45:01 +0000
ld GNU ld (GNU Binutils) 2.21.1
app-shells/bash: 4.2_p20
dev-java/java-config: 2.1.11-r3
dev-lang/python: 2.7.3-r2, 3.2.3
dev-util/cmake: 2.8.6-r4
dev-util/pkgconfig: 0.27.1
sys-apps/baselayout: 2.1-r1
sys-apps/openrc: 0.9.8.4
sys-apps/sandbox: 2.5
sys-devel/autoconf: 2.13, 2.68
sys-devel/automake: 1.11.1
sys-devel/binutils: 2.21.1-r1
sys-devel/gcc: 3.4.6-r2, 4.5.3-r2
sys-devel/gcc-config: 1.6
sys-devel/libtool: 2.4-r1
sys-devel/make: 3.82-r1
sys-kernel/linux-headers: 3.4 (virtual/os-headers)
sys-libs/glibc: 2.14.1-r3
Repositories: gentoo private-overlay armagetron x-m68k sabayon java-overlay
ACCEPT_KEYWORDS="ppc"
ACCEPT_LICENSE="* -@EULA"
CBUILD="powerpc-unknown-linux-gnu"
CFLAGS="-g -O2 -fPIC -fno-strict-aliasing -pipe"
CHOST="powerpc-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-g -O2 -fPIC -fno-strict-aliasing -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--alphabetical --nospinner --quiet-build --usepkg --binpkg-respect-use=y"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg config-protect-if-modified distlocks ebuild-locks fixlafiles installsources merge-sync news parallel-fetch protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://de-mirror.org/distro/gentoo/ [^] ftp://de-mirror.org/distro/gentoo/ [^] http://mirror.umd.edu/gentoo [^] "
LANG="en_US.UTF8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en de"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /var/lib/layman/armagetron /var/lib/layman/m68k /var/lib/layman/sabayon /var/lib/layman/java-overlay"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage" [^]
USE="X Xaw3d a52 aac acl alsa altivec berkdb bluetooth branding bzip2 cairo cdda cdr cgi cjk cli consolekit cracklib crypt css cups cxx dbus device-mapper dri dts dvd dvdr dvi emboss encode esd exif extensions extras fam fastcgi fat ffmpeg firefox flac fontconfig fortran fuse gd gdbm gif gnutls gpm gtk hfs iconv icu id3tag imagemagick imap ipv6 jfs joystick jpeg jpeg2k kpathsea lcms ldap libnotify mad midi mikmod minizip mng mod modules mp3 mp4 mpeg mudflap mule musicbrainz mysql ncurses nls nptl ntfs ntfsprogs objc odbc ogg opengl openmp pam pango pcre pdf png policykit ppc ppds pppd private-headers qt3support qt4 readline reiserfs sasl sdl server session sid sieve spell sqlite srt ssl startup-notification stream svg tcpd theora threads tiff timidity truetype twolame udev udisks unicode upower usb vamp videos vorbis wxwidgets xcb xfs xml xulrunner xv xvid zlib" ALSA_CARDS="via82xx" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en de" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" QEMU_SOFTMMU_TARGETS="arm i386 ppc" QEMU_USER_TARGETS="arm i386 ppc" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset: CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, MAKEOPTS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Johannes Geiss 2012-11-16 17:30:37 UTC
Some back traces from interrupted run:

#0 0x0fc70cd0 in __read_nocancel () from /lib/libc.so.6
0000001 0x10001ca0 in read (__nbytes=1024, __buf=0xbfffe534, __fd=<optimized out>) at /usr/include/bits/unistd.h:45
0000002 inputReady (w=0x10031b88, source=<optimized out>, id=0xbfffe968) at xconsole.c:513
0000003 0x0fee2168 in XtAppProcessEvent (app=0x10017870, mask=<optimized out>) at /usr/src/debug/x11-libs/libXt-1.1.3/libXt-1.1.3/src/NextEvent.c:1356
0000004 0x0fed431c in XtAppMainLoop (app=0x10017870) at /usr/src/debug/x11-libs/libXt-1.1.3/libXt-1.1.3/src/Event.c:1554
0000005 0x0fed4388 in XtMainLoop () at /usr/src/debug/x11-libs/libXt-1.1.3/libXt-1.1.3/src/Event.c:1546
0000006 0x10002500 in main (argc=0, argv=0xbfffed14) at xconsole.c:707

#0 0x0fc70cd0 in __read_nocancel () from /lib/libc.so.6
0000001 0x10001ca0 in read (__nbytes=1024, __buf=0xbfffe534, __fd=<optimized out>) at /usr/include/bits/unistd.h:45
0000002 inputReady (w=0x10031b88, source=<optimized out>, id=0xbfffe968) at xconsole.c:513
0000003 0x0fee2168 in XtAppProcessEvent (app=0x10017870, mask=<optimized out>) at /usr/src/debug/x11-libs/libXt-1.1.3/libXt-1.1.3/src/NextEvent.c:1356
0000004 0x0fed431c in XtAppMainLoop (app=0x10017870) at /usr/src/debug/x11-libs/libXt-1.1.3/libXt-1.1.3/src/Event.c:1554
0000005 0x0fed4388 in XtMainLoop () at /usr/src/debug/x11-libs/libXt-1.1.3/libXt-1.1.3/src/Event.c:1546
0000006 0x10002500 in main (argc=0, argv=0xbfffed14) at xconsole.c:707

#0 0x0fd80cb8 in XPending (dpy=0x1001bf38) at /usr/src/debug/x11-libs/libX11-1.5.0/libX11-1.5.0/src/Pending.c:58
0000001 0x10001eb0 in inputReady (w=0x10031b88, source=<optimized out>, id=0xbfffe968) at xconsole.c:518
0000002 0x0fee2168 in XtAppProcessEvent (app=0x10017870, mask=<optimized out>) at /usr/src/debug/x11-libs/libXt-1.1.3/libXt-1.1.3/src/NextEvent.c:1356
0000003 0x0fed431c in XtAppMainLoop (app=0x10017870) at /usr/src/debug/x11-libs/libXt-1.1.3/libXt-1.1.3/src/Event.c:1554
0000004 0x0fed4388 in XtMainLoop () at /usr/src/debug/x11-libs/libXt-1.1.3/libXt-1.1.3/src/Event.c:1546
0000005 0x10002500 in main (argc=0, argv=0xbfffed14) at xconsole.c:707

#0 0x0fc18eb0 in *__GI___libc_free (mem=0x100387d8) at malloc.c:3692
0000001 0x0fec1e3c in XtFree (ptr=<optimized out>) at /usr/src/debug/x11-libs/libXt-1.1.3/libXt-1.1.3/src/Alloc.c:217
0000002 0x0fee03a4 in _XtWaitForSomething (app=<optimized out>, ignoreEvents=<optimized out>, ignoreTimers=<optimized out>, ignoreInputs=<optimized out>, ignoreSignals=<optimized out>, block=<optimized out>, drop_lock=<optimized out>, howlong=0x0) at /usr/src/debug/x11-libs/libXt-1.1.3/libXt-1.1.3/src/NextEvent.c:738
0000003 0x0fee219c in XtAppProcessEvent (app=0x10017870, mask=<optimized out>) at /usr/src/debug/x11-libs/libXt-1.1.3/libXt-1.1.3/src/NextEvent.c:1344
0000004 0x0fed431c in XtAppMainLoop (app=0x10017870) at /usr/src/debug/x11-libs/libXt-1.1.3/libXt-1.1.3/src/Event.c:1554
0000005 0x0fed4388 in XtMainLoop () at /usr/src/debug/x11-libs/libXt-1.1.3/libXt-1.1.3/src/Event.c:1546
0000006 0x10002500 in main (argc=0, argv=0xbfffed14) at xconsole.c:707

#0 0x0fc70cd0 in __read_nocancel () from /lib/libc.so.6
0000001 0x10001ca0 in read (__nbytes=1024, __buf=0xbfffe534, __fd=<optimized out>) at /usr/include/bits/unistd.h:45
0000002 inputReady (w=0x10031b88, source=<optimized out>, id=0xbfffe968) at xconsole.c:513
0000003 0x0fee2168 in XtAppProcessEvent (app=0x10017870, mask=<optimized out>) at /usr/src/debug/x11-libs/libXt-1.1.3/libXt-1.1.3/src/NextEvent.c:1356
0000004 0x0fed431c in XtAppMainLoop (app=0x10017870) at /usr/src/debug/x11-libs/libXt-1.1.3/libXt-1.1.3/src/Event.c:1554
0000005 0x0fed4388 in XtMainLoop () at /usr/src/debug/x11-libs/libXt-1.1.3/libXt-1.1.3/src/Event.c:1546
0000006 0x10002500 in main (argc=0, argv=0xbfffed14) at xconsole.c:707
Comment 2 Jeroen Roovers gentoo-dev 2012-11-16 17:55:55 UTC
  -file file-name
    To  monitor some other device, use this option to specify the device name.
    This does not work on regular files as they are always ready  to  be  read
    from.

Maybe you're using it the wrong way?
Comment 3 Johannes Geiss 2012-11-16 18:57:33 UTC
(In reply to comment #2)

> Maybe you're using it the wrong way?

You are right. Now as I read the man page. It's clear to me. But in the past it worked, though: xconsole -file ~/.xsession-errors

So I guess this issue is not a bug.

Sorry for the inconvenience.