Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 443076 - net-print/foomatic-filters-4.0.16 - configure.ac:6: version mismatch. This is Automake 1.11.6, but the definition used by this AM_INIT_AUTOMAKE comes from Automake 1.11.1.
Summary: net-print/foomatic-filters-4.0.16 - configure.ac:6: version mismatch. This i...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Printing (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Printing Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-14 12:22 UTC by Markus Oehme
Modified: 2013-09-03 09:09 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (info.txt,5.39 KB, text/plain)
2012-11-14 12:22 UTC, Markus Oehme
Details
automake output (automake.out,403 bytes, text/plain)
2012-11-14 12:22 UTC, Markus Oehme
Details
build log (build.log,2.16 KB, text/plain)
2012-11-14 12:23 UTC, Markus Oehme
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Oehme 2012-11-14 12:22:19 UTC
Created attachment 329522 [details]
emerge --info

On my fresh amd64 box I see the following error when trying to merge foomatic-filters. I have automake-1.11.6 installed.

***** automake *****
***** PWD: /var/tmp/portage/net-print/foomatic-filters-4.0.16/work/foomatic-filters-4.0.16
***** automake --add-missing --copy

configure.ac:6: version mismatch.  This is Automake 1.11.6,
configure.ac:6: but the definition used by this AM_INIT_AUTOMAKE
configure.ac:6: comes from Automake 1.11.1.  You should recreate
configure.ac:6: aclocal.m4 with aclocal and run automake again.
Comment 1 Markus Oehme 2012-11-14 12:22:54 UTC
Created attachment 329524 [details]
automake output
Comment 2 Markus Oehme 2012-11-14 12:23:32 UTC
Created attachment 329526 [details]
build log
Comment 3 Bob Johnson 2012-11-16 16:45:33 UTC
On my not-so-fresh stable amd64 box I get exactly the same error.
Comment 4 hammackj 2013-01-17 16:31:09 UTC
Getting this on my freshly installed gentoo as of last night. Any work arounds?
Comment 5 Will Tomlinson 2013-01-19 06:59:22 UTC
I can confirm this issue as well. Re-starting the build will resolve the issue but it always fails when being built with other packages. This happens with other packages as well, I will be filing bug reports for those too.
Comment 6 Fred Krogh 2013-03-25 22:56:57 UTC
I just did an emerge -e world on an ~amd64 system, after switching to /gcc-4.7.2-r1 and got this same kind of error when emerging foomatic-filters-4.0.17.  (Only other error was on dosemu which I believe was not a problem with the compiler.)
Comment 7 Manuel Rüger (RETIRED) gentoo-dev 2013-08-05 14:33:49 UTC
I can't reproduce this here. Is it still failing? 

I've installed automake 1.11.6 and 1.12.6. It should use the last one.
Comment 8 Manuel Rüger (RETIRED) gentoo-dev 2013-08-10 13:49:23 UTC
Please test, and report back if it is still failing.
Comment 9 Markus Oehme 2013-09-03 09:09:09 UTC
(In reply to Manuel Rüger from comment #8)
> Please test, and report back if it is still failing.

4.0.17-r1 works fine for me. :)