Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 442992 - <dev-libs/boost-1.52.0-r2[python] fail install phase in prefix
Summary: <dev-libs/boost-1.52.0-r2[python] fail install phase in prefix
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo/Alt
Classification: Unclassified
Component: Prefix Support (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Prefix
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-13 17:10 UTC by Steven Trogdon
Modified: 2014-12-22 10:25 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steven Trogdon 2012-11-13 17:10:25 UTC
The subject packages build but will not install in prefix with USE=python. The failure for boost-1.50.0 is

[31;01m*[0m ERROR: dev-libs/boost-1.51.0 failed (install phase):
 [31;01m*[0m   python_mod_optimize() can be used only in pkg_postinst() phase
 [31;01m*[0m 
 [31;01m*[0m Call stack:
 [31;01m*[0m     ebuild.sh, line   93:  Called call-ebuildshell 'src_install'
 [31;01m*[0m   environment, line 1212:  Called src_install
 [31;01m*[0m   environment, line 5962:  Called python_mod_optimize 'boost_1_51'
 [31;01m*[0m   environment, line 5088:  Called die
 [31;01m*[0m The specific snippet of code:
 [31;01m*[0m           die "${FUNCNAME}() can be used only in pkg_postinst() phase";
 [31;01m*[0m 
 [31;01m*[0m If you need support, post the output of `emerge --info '=dev-libs/boost-1.51.0'`,
 [31;01m*[0m the complete build log and the output of `emerge -pqv '=dev-libs/boost-1.51.0'`.
 [31;01m*[0m The complete build log is located at '/storage/strogdon/gentoo/var/tmp/portage/dev-libs/boost-1.51.0/temp/build.log'.
 [31;01m*[0m The ebuild environment file is located at '/storage/strogdon/gentoo/var/tmp/portage/dev-libs/boost-1.51.0/temp/environment'.
 [31;01m*[0m Working directory: '/storage/strogdon/gentoo/var/tmp/portage/dev-libs/boost-1.51.0/work/boost_1_51_0'
 [31;01m*[0m S: '/storage/strogdon/gentoo/var/tmp/portage/dev-libs/boost-1.51.0/work/boost_1_51_0'

boost-1.52.0-r2 from the main tree does put the python_mod_optimize() in pkg_postinst()
Comment 1 Steven Trogdon 2012-11-13 18:17:25 UTC
It should boost-1.51.0 not boost-1.50.0
Comment 2 Fabian Groffen gentoo-dev 2012-12-05 12:51:25 UTC
I synced boost yesterday, and would be interested to hear if that fixed/changed things here
Comment 3 Steven Trogdon 2012-12-05 22:42:20 UTC
dev-libs/boost-1.49.0-r2 will not build because it pulls in sys-libs/glibc-2.15-r3 which fails to build

Inconsistency detected by ld.so: dynamic-link.h: 210: elf_get_dynamic_info: Assertion `info[29] == ((void *)0)' failed!
make[2]: *** [/storage/strogdon/gentoo/var/tmp/portage/sys-libs/glibc-2.15-r3/work/build-amd64-x86_64-pc-linux-gnu-nptl/sunrpc/xbootparam_prot.stmp] Error 127

and a bunch of similar errors in the sunrpc folder.

---
dev-libs/boost-1.52.0-r4 will not install due to file collisions:


Detected file collision(s):

        /storage/strogdon/gentoo/usr/lib/libboost_math_tr1l-mt.so
        /storage/strogdon/gentoo/usr/lib/libboost_chrono-mt.so
        /storage/strogdon/gentoo/usr/lib/libboost_filesystem-mt.so
        /storage/strogdon/gentoo/usr/lib/libboost_random-mt.so
        /storage/strogdon/gentoo/usr/lib/libboost_python-2.7-mt.so
        /storage/strogdon/gentoo/usr/lib/libboost_math_c99-mt.so
        /storage/strogdon/gentoo/usr/lib/libboost_date_time-mt.so
        /storage/strogdon/gentoo/usr/lib/libboost_regex-mt.so
        /storage/strogdon/gentoo/usr/lib/libboost_thread.so
        /storage/strogdon/gentoo/usr/lib/libboost_prg_exec_monitor-mt.so
        /storage/strogdon/gentoo/usr/lib/libboost_graph-mt.so
        /storage/strogdon/gentoo/usr/lib/libboost_iostreams-mt.so
        /storage/strogdon/gentoo/usr/lib/libboost_system-mt.so
        /storage/strogdon/gentoo/usr/lib/libboost_math_tr1f-mt.so
        /storage/strogdon/gentoo/usr/lib/libboost_signals-mt.so
        /storage/strogdon/gentoo/usr/lib/libboost_math_tr1-mt.so
        /storage/strogdon/gentoo/usr/lib/libboost_program_options-mt.so
        /storage/strogdon/gentoo/usr/lib/libboost_locale-mt.so
        /storage/strogdon/gentoo/usr/lib/libboost_math_c99l-mt.so
        /storage/strogdon/gentoo/usr/lib/libboost_wserialization-mt.so
        /storage/strogdon/gentoo/usr/lib/libboost_serialization-mt.so
        /storage/strogdon/gentoo/usr/lib/libboost_wave-mt.so
        /storage/strogdon/gentoo/usr/lib/libboost_timer-mt.so
        /storage/strogdon/gentoo/usr/lib/libboost_unit_test_framework-mt.so
        /storage/strogdon/gentoo/usr/lib/libboost_math_c99f-mt.so
        /storage/strogdon/gentoo/usr/lib/libboost_thread-mt.so

I can probably resolve this locally, but the question is whether I should have to do that.
Comment 4 Steven Trogdon 2012-12-05 22:51:32 UTC
I see. I have dev-libs/boost-1.49.0-r1 from a local overlay installed. I guess I've been limping along for some time. This may be the source of the collisions.
Comment 5 Steven Trogdon 2012-12-07 22:20:12 UTC
FEATURES="-collision-protect" emerge =dev-libs/boost-1.52.0-r4 allowed the collisions to be overridden and boost was installed. This is good. I noticed that I had a similar issue when upgrading boost-1.49.0-r1 -> boost-1.49.0-r2 with native gentoo where I had to use FEATURES="-collision-protect". In prefix the collisions seemed to be confined to the *.mt.so (threaded) shared objects, while there were additional collisions on native gentoo. In retrospect, my overlay probably had nothing to do with the collisions.
Comment 6 Fabian Groffen gentoo-dev 2012-12-08 09:11:17 UTC
I had collisions too, they are caused by the large changes (and de-SLOT-ting) of boost, IMO.  Not much we can do about that, I think.
Comment 7 Sergey Popov gentoo-dev Security 2014-12-22 10:25:55 UTC
Revisions of Boost in bug's summary has been dropped from tree long time ago, closing this as OBSOLETE